You are not logged in.

#201 2018-02-10 18:00:53

jjacky
Member
Registered: 2011-11-09
Posts: 347
Website

Re: kalu: Keeping Arch Linux Up-to-date

kalu 4.2.0 is out, with contributions from Bricabraque & pepecuis.

  • kalu: Add --tmp-dbpath and --keep-tmp-dbpath
    Mainly useful for CLI use (or not?), to be able to keep & re-use the tmp dbs over time, much like the GUI does during its run.

  • Add Spanish translation; Thanks to pepecuis!

  • Support disabling auto-checks (via Interval = 0)

  • news: Fix issue if title needs trimming, that is, if a news title (used to determine whether it has been read or not) could be trimmedg, there was an issue because titles read from news.conf are trimmed, so the two wouldn't match, and the news incorrectly considered unread. To fix this we trim the titles read from the XML (RSS feed) as well.
    Thanks to Ada Joule; Also adam777 for the report.

  • Update French translation

  • doc: Adjust example path about custom icons

  • doc: List options in alphabetical order

  • Some other fixes (see git log for details)

Thanks to everyone who contributed/reported bugs!

Offline

#202 2019-09-11 01:19:28

verndog
Member
Registered: 2007-09-21
Posts: 54

Re: kalu: Keeping Arch Linux Up-to-date

I kept getting a dialog message on bootup:

Unable to check for updates- could not synchronize databases
Failed to Update core: invalid url for server

Which doesn't ID kalu as the reason for it. I needed to add delay to autostart to stop the message ouput.
Any other way to pause kalu?

Online

#203 2019-09-11 21:56:51

zpg443
Member
Registered: 2016-12-03
Posts: 47

Re: kalu: Keeping Arch Linux Up-to-date

Go to Kalu Preferences, select the Misc tab, then uncheck "Show if databases can be synchronized in tooltip".

That should stop the message output from Kalu.

Offline

#204 2019-09-12 02:07:41

verndog
Member
Registered: 2007-09-21
Posts: 54

Re: kalu: Keeping Arch Linux Up-to-date

zpg443 wrote:

Go to Kalu Preferences, select the Misc tab, then uncheck "Show if databases can be synchronized in tooltip".

That should stop the message output from Kalu.

That might "hide" the message, but there's another issue.
If I sleep for 5sec Kalu on autostart, then the message doesn't appear and Kala does check for current upgrades. [I see the Arch icon blink as it checks for upgrades.]
If I remove the sleep then Kalu never gets a chance to active and check for upgrades. [The Arch icon is grayed out]

Edit: I tried your method. Not only did the error message appear, but clicking on Kalu the message would reappear each time I clicked on Kalu.

The sleep function works as it should. Maybe add it to preferences somehow , or a config file.

Last edited by verndog (2019-09-12 02:14:52)

Online

Board footer

Powered by FluxBB