You are not logged in.

#1 2019-09-11 14:28:54

mbrennr
Member
Registered: 2012-09-17
Posts: 7

glslang 7.12.3352-1 breaks mpv

Got this problem after sysupgrade.

https://bugzilla.opensuse.org/show_bug.cgi?id=1149869

Suse/Reddit recommended fix:
https://lists.opensuse.org/opensuse-fac … 00086.html

Am I alone on this?
Have not sent bug report, please advise.

Offline

#2 2019-09-11 15:04:46

loqs
Member
Registered: 2014-03-06
Posts: 8,821

Re: glslang 7.12.3352-1 breaks mpv

Offline

#3 2019-09-12 11:53:53

mbrennr
Member
Registered: 2012-09-17
Posts: 7

Re: glslang 7.12.3352-1 breaks mpv

Thank you for pointing out already existing bug report.
In the comments of the arch bugreport mentioned by loqs, a fix is mentioned by user CalimeroTeknik: "rebuild shaderc from the PKGBUILD for mpv to run again".
It is to rebuild the package "shaderc" from PKGBUILD:

wget -O PKGBUILD https://git.archlinux.org/svntogit/packages.git/plain/trunk/PKGBUILD?h=packages/shaderc
makepkg
sudo pacman -S asciidoctor ninja
makepkg
sudo pacman -U shaderc-2019.0-2-x86_64.pkg.tar.xz

apart from asciidoctor and ninja, you may need other build-dependencies.

Happy movie watching.

Offline

Board footer

Powered by FluxBB