You are not logged in.

#1 2019-09-14 14:23:43

Marvix
Member
Registered: 2013-10-08
Posts: 113

Deadbeef can't load Vorbis Opus files

I can't play opus files in Deadbeef.

I get error log message as below:

bad signature
playlist load fail (/home/marvix/Music/audiofile.opus)!
failed to add file or folder /home/marvix/Music/audiofile.opus
Version Deadbeef 1.8.2

And the pacman -Qi result

[marvix@arch ~]$ pacman -Qi deadbeef
Name            : deadbeef
Version         : 1.8.2-1
Description     : A GTK+ audio player for GNU/Linux.
Architecture    : x86_64
URL             : http://deadbeef.sourceforge.net
Licenses        : GPL2
Groups          : None
Provides        : None
Depends On      : alsa-lib  hicolor-icon-theme  desktop-file-utils  jansson
Optional Deps   : gtk2: for the GTK2 interface [installed]
                  gtk3: for the GTK3 interface [installed]
                  libsamplerate: for Resampler plugin [installed]
                  libvorbis: for Ogg Vorbis playback [installed]
                  libmad: for MP1/MP2/MP3 playback [installed]
                  mpg123: for MP1/MP2/MP3 playback [installed]
                  flac: for FLAC playback [installed]
                  curl: for Last.fm scrobbler, SHOUTcast, Icecast, Podcast
                  support [installed]
                  imlib2: for artwork plugin [installed]
                  wavpack: for WavPack playback [installed]
                  libsndfile: for Wave playback [installed]
                  libcdio: audio cd plugin [installed]
                  libcddb: audio cd plugin [installed]
                  faad2: for AAC/MP4 support [installed]
                  dbus: for OSD notifications support [installed]
                  pulseaudio: for PulseAudio output plugin [installed]
                  libx11: for global hotkeys plugin [installed]
                  zlib: for Audio Overload plugin [installed]
                  libzip: for vfs_zip plugin [installed]
                  ffmpeg: for ffmpeg plugin [installed]
Required By     : None
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 11.16 MiB
Packager        : Lukas Fleischer <lfleischer@archlinux.org>
Build Date      : Σαβ 17 Αυγ 2019 02:29:29 πμ EEST
Install Date    : Σαβ 17 Αυγ 2019 11:55:54 πμ EEST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature

Offline

#2 2019-09-16 07:39:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,991

Re: Deadbeef can't load Vorbis Opus files

Offline

#3 2019-09-16 22:16:02

Marvix
Member
Registered: 2013-10-08
Posts: 113

Re: Deadbeef can't load Vorbis Opus files

Deadbeef's FFMpeg plugin "Use all extensions supported by ffmpeg" is disabled by default.

Enable it, restart, try to play audio and disable it, restart and try to play a file unfortunately doesn't work either.

Offline

#4 2020-02-08 16:16:10

mrepnenkov
Member
Registered: 2020-02-08
Posts: 1

Re: Deadbeef can't load Vorbis Opus files

I confirm. Files with the opus extension cannot be selected in the file selection dialog and they are not added to the playlist.

deadbeef 1.8.2

Offline

#5 2020-02-09 11:10:35

xerxes_
Member
Registered: 2018-04-29
Posts: 267

Re: Deadbeef can't load Vorbis Opus files

I also can confirm that in deadbeef 1.8.2-1 files with the opus extension cannot be opened or added to play, even if ffmpeg plugin enabled option "Use all extensions supported by ffmpeg" and added at the end of supported extensions opus extension or this option unselected, deadbeef restarted, etc.

But in qmmp opening and playing opus files works (and I writing this because qmmp looks similar to me - similar plugins used, basic interface without skins, etc.). Qmmp instead can't open umx (Unreal 1 music tracker files - mostly s3m, xm, it, mod based) which deadbeef can. There is no ideal music player yet.

Last edited by xerxes_ (2020-02-09 11:21:12)

Offline

#6 2020-02-09 12:01:58

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,991

Re: Deadbeef can't load Vorbis Opus files

Make a bug report on the Arch Flyspray to add opusfile to the optional dependencies of deadbeef

Edit: Or rather vote on the already existing report: https://bugs.archlinux.org/task/63484

Or if deadbeef is the perfect player safe for this, download the PKGBUILD from the ABS[1] and add the opusfile dep and build it until the maintainer gets around to adding it.

[1] https://wiki.archlinux.org/index.php/Ar … ILD_source

Last edited by V1del (2020-02-15 18:26:14)

Offline

#7 2020-02-15 16:30:03

mila.nuts
Member
Registered: 2018-10-09
Posts: 2

Re: Deadbeef can't load Vorbis Opus files

xerxes_ wrote:

There is no ideal music player yet.

what about VLC?

recursion is disabled by default, but can be enabled with:
tools > prefs > show settings: all > playlist > subdir behave > expand

what i miss: playback queue and auto-save playlist

Offline

#8 2020-04-16 17:52:28

Barafu Albino Cheetah
Member
From: Moscow
Registered: 2011-09-16
Posts: 34

Re: Deadbeef can't load Vorbis Opus files

Same thing here. And I have installed everything with word "opus" in community repos. And toggled both states of FFMPEG plugin.

OK, I did a bit of investigation and found out: there should be an explicitly listed plugin "OPUS player" and it is missing from the deadbeef version in repository. If you install deadbeef-git from AUR, it is there and files play without problems. I'll write a bug report about that.

And final update: the bug has already been reported and has been there for more than a year. Use deadbeef-git or rebuild the package yourself.

Last edited by Barafu Albino Cheetah (2020-04-16 18:48:47)

Offline

#9 2020-06-10 08:45:05

kij
Member
Registered: 2009-10-06
Posts: 3

Re: Deadbeef can't load Vorbis Opus files

This worked for me.

Edit->Preferences->Plugins->FFMPEG audio player->Configure 

Add opus to the list of file extensions.

$yay -Q | grep 'opus\|deadbeef\|ffmpeg'

deadbeef 1.8.3-1
ffmpeg 1:4.2.3-4
opus 1.3.1-2

Offline

Board footer

Powered by FluxBB