You are not logged in.

#1 2019-09-17 09:44:39

pepijndevos
Member
Registered: 2014-02-02
Posts: 14

Internal microphone disabled when headphone is plugged in

I have a Thinkpad P1 Gen2 which has an internal microphone and a combo headphone/mic jack.
Alsa lists the input as

card 0: PCH [HDA Intel PCH], device 0: CX8070 Analog [CX8070 Analog]

When nothing is plugged in, it's using the internal speaker and microphone just fine.
But when I plug in a headphone (JUST a headphone, not a headset), it switches to the headphone and imaginary headset mic.
When a headphone is plugged in, pavucontrol lists the speaker as unavailable and the internal microphone as disconnected.
Selecting them does not produce/record any audio.

Elsewhere I read that hdajackretask might offer some solution.
There it can be seen that it indeed thinks there is a microphone plugged into the combo jack.

I tried to override this to "not connected", but get a device busy error.
I googled this error, but several solutions that disable PulseAudio did not make a change.

So now I'm stuck...

Offline

#2 2019-09-17 11:05:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,797

Re: Internal microphone disabled when headphone is plugged in

If you want to make adjustments via hdajackretask you have to stop everything currently actively accessing your audio card. The easiest to do this with pulseaudio is

systemctl --user mask pulseaudio.socket #Prevent autostarting
systemctl --user stop pulseaudio
sudo fuser -v /dev/snd/* #This should show no application using your card.
#Do your hdajack adjustments
systemctl --user unmask pulseaudio.socket
systemctl --user start pulseaudio

Offline

#3 2019-09-17 13:25:20

pepijndevos
Member
Registered: 2014-02-02
Posts: 14

Re: Internal microphone disabled when headphone is plugged in

Okay, that worked this time around, somehow. (it's pretty much the same command as I used before)
That is, it allowed me to override the imaginary mic to be disconnected.
After that it just showed "Microphone" in pavucontrol, and it did not work.
Actually, after starting pulseaudio again, nothing works, and it thinks the headphone is still plugged in.

Offline

#4 2019-09-17 14:38:23

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,797

Re: Internal microphone disabled when headphone is plugged in

Pretty much the same command and the same command are - as evident-  not the same thing...

What pulse thinks might be irrelevant if it works otherwise, FWIW you might want to test this without pulseaudio, rerun the first two commands and try to record with arecord on the relevant hw device. This behaviour might however be hardcoded in hardware/firmware if you are unlucky.

Last edited by V1del (2019-09-17 14:39:06)

Offline

#5 2019-09-17 15:36:07

pepijndevos
Member
Registered: 2014-02-02
Posts: 14

Re: Internal microphone disabled when headphone is plugged in

These are all the devices it lists, not really obvious to me that one is internal vs external.

$ arecord -L
null
    Discard all samples (playback) or generate zero samples (capture)
jack
    JACK Audio Connection Kit
pulse
    PulseAudio Sound Server
default
    Default ALSA Output (currently PulseAudio Sound Server)
sysdefault:CARD=PCH
    HDA Intel PCH, CX8070 Analog
    Default Audio Device
front:CARD=PCH,DEV=0
    HDA Intel PCH, CX8070 Analog
    Front speakers
usbstream:CARD=PCH
    HDA Intel PCH
    USB Stream Output
usbstream:CARD=NVidia
    HDA NVidia
    USB Stream Output

With the following command, I'm able to record without headphone, but not with it plugged in.
Well, it does record *something*, but just noise, after I crank the mic gain all the way up in alsamixer.

arecord -d5 -Dsysdefault -f dat test.wav

Does that mean it's hardcoded in firmware? That sucks. I already dug around in the bios, but I can't find a setting to change this.

Last edited by pepijndevos (2019-09-17 15:38:30)

Offline

#6 2019-09-18 07:51:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,797

Re: Internal microphone disabled when headphone is plugged in

What's your output for

amixer -c0

Offline

#7 2019-09-18 16:37:57

pepijndevos
Member
Registered: 2014-02-02
Posts: 14

Re: Internal microphone disabled when headphone is plugged in

Simple mixer control 'Master',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 74
  Mono: Playback 61 [82%] [-13.00dB] [on]
Simple mixer control 'Headphone',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 61 [82%] [-13.00dB] [on]
  Front Right: Playback 61 [82%] [-13.00dB] [on]
Simple mixer control 'Speaker',0
  Capabilities: pvolume pswitch
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 74
  Mono:
  Front Left: Playback 64 [86%] [-10.00dB] [on]
  Front Right: Playback 64 [86%] [-10.00dB] [on]
Simple mixer control 'PCM',0
  Capabilities: pvolume
  Playback channels: Front Left - Front Right
  Limits: Playback 0 - 255
  Mono:
  Front Left: Playback 255 [100%] [0.00dB]
  Front Right: Playback 253 [99%] [-0.40dB]
Simple mixer control 'Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 1 [33%] [12.00dB]
  Front Right: 1 [33%] [12.00dB]
Simple mixer control 'Mic Mute-LED Mode',0
  Capabilities: enum
  Items: 'On' 'Off' 'Follow Capture' 'Follow Mute'
  Item0: 'Follow Mute'
Simple mixer control 'Beep',0
  Capabilities: pvolume pvolume-joined pswitch pswitch-joined
  Playback channels: Mono
  Limits: Playback 0 - 7
  Mono: Playback 3 [43%] [-16.00dB] [on]
Simple mixer control 'Capture',0
  Capabilities: cvolume cswitch
  Capture channels: Front Left - Front Right
  Limits: Capture 0 - 80
  Front Left: Capture 80 [100%] [6.00dB] [on]
  Front Right: Capture 80 [100%] [6.00dB] [on]
Simple mixer control 'Auto-Mute Mode',0
  Capabilities: enum
  Items: 'Disabled' 'Enabled'
  Item0: 'Enabled'
Simple mixer control 'Internal Mic Boost',0
  Capabilities: volume
  Playback channels: Front Left - Front Right
  Capture channels: Front Left - Front Right
  Limits: 0 - 3
  Front Left: 1 [33%] [12.00dB]
  Front Right: 1 [33%] [12.00dB]

Already tried fiddling with all of them...
This is with headphone plugged in.

Offline

Board footer

Powered by FluxBB