You are not logged in.

#1 2019-09-19 02:47:58

rapiz
Member
Registered: 2017-01-02
Posts: 4

PKGBUILD review request ( petal )

I'm packaging a music player Petal https://github.com/ilime/Petal, which is written with Electron.
I want to make a binary package. This PKGBUILD works on my computer but namcap emits lots of warning and errors.

# Maintainer:
# g1eny0ung <g1eny0ung@gmail.com>
# rapiz <contact@rapiz.me>
# lxs137 <lxs137@hotmail.com>
pkgname=petal
pkgver=2.20.0
pkgrel=1
epoch=
pkgdesc="A Douban.FM Client With Extra"
arch=('x86_64')
url="https://ilime.github.io/Petal/"
license=('MIT')
groups=()
depends=('gtk3' 'nss' 'libxss')
makedepends=()
checkdepends=()
optdepends=()
provides=()
conflicts=()
replaces=()
backup=()
options=()
install=
changelog=
source=("https://github.com/ilime/Petal/releases/download/v$pkgver/Petal-$pkgver.tar.gz"
        'https://raw.githubusercontent.com/ilime/Petal/dev/LICENSE'
        'petal.svg'
        'Petal.desktop'
        'petal.sh'
)
noextract=()
validpgpkeys=()
md5sums=('41c8c259ff57c36749f6615105c33937'
         'cebd0dda9b913e6254f5e09a257955bb'
         'a4f3cb91573bbc3fce9466350ddfb4d2'
         'e946f427355b1a85454b74e7ca918072'
         '5c3aace4646132860b8084cbbb55ad55')

package() {
    mkdir -p "$pkgdir/usr/lib"
    cp -r "$srcdir/Petal-$pkgver" "$pkgdir/usr/lib/$pkgname"
    
    install -Dm755 "$srcdir/petal.sh" "$pkgdir/usr/bin/petal"
    install -Dm644 "$srcdir/Petal.desktop" -t "$pkgdir/usr/share/applications/"

    ICON="$srcdir/petal.svg"
    install -Dm644 "$ICON" "$pkgdir/usr/share/icons/hicolor/scalable/apps/${pkgname}.svg"

    install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}
petal W: ELF file ('usr/lib/petal/libEGL.so') lacks FULL RELRO, check LDFLAGS.
petal W: ELF file ('usr/lib/petal/libGLESv2.so') lacks FULL RELRO, check LDFLAGS.
petal W: ELF file ('usr/lib/petal/libffmpeg.so') lacks FULL RELRO, check LDFLAGS.
petal W: ELF file ('usr/lib/petal/petal') lacks FULL RELRO, check LDFLAGS.
petal W: ELF file ('usr/lib/petal/swiftshader/libEGL.so') lacks FULL RELRO, check LDFLAGS.
petal W: ELF file ('usr/lib/petal/swiftshader/libGLESv2.so') lacks FULL RELRO, check LDFLAGS.
petal W: Referenced library 'libffmpeg.so' is an uninstalled dependency

Last edited by rapiz (2019-09-19 03:23:24)

Offline

#2 2019-09-19 12:03:26

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,362

Re: PKGBUILD review request ( petal )

Normally the license is also included in a release tarball, are you sure you need to download it separately ?

Pacakaging electron apps is tricky on archlinux, as they tend to use their own versions of system libraries.
This often leads to conflicts between the elctron app and archlinux system libs at runtime.

The package is published under the MIT license and it's source is available .
I recommend you try building from source and use electron from [community] repo.
If you prefer using binaries created by others, please append -bin to the package name .
That will make clear to others this package is not build from source.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB