You are not logged in.

#1 2019-09-20 02:49:40

Registered: 2019-09-20
Posts: 5

[SOLVED] Dual Boot keeps booting directly into Windows 10

After first having a Debian Buster dual boot with Windows 10, I now want to start using Arch instead of Debian and dual boot it with my already installed Windows 10 installation.

I have followed all the steps on the Wiki, and also tried the troubleshooting. But for some reason, when I start up my PC, it directly boots into Windows, instead of giving me a GRUB screen with my booting options.

My computer is a Acer Aspire E15 with an Intel i5 inside.

My InsydeH2O Setup Utility Boot page shows:

Boot Mode:		UEFI
Secure Boot:		Disabled

Boot priority order:
2. Windows Boot Manager
3. HDD
5. Network Voot IPV4
8. Network Boot-IPV6

For turning off Fast Startup I used the BAT file on this site: … -10-a.html

These are my current partitions:

Device		Start		End		Sectors		Size	Type
/dev/sda1	2048	        1230847		1228800		600M	Windows Recovery Environment
/dev/sda2	1230848		1845247		614400		300M	EFI System
/dev/sda3	1845248		2107391		262144		128M	Microsoft reserved
/dev/sda4 	2107392		71157759	69050368	32.9G	Microsoft basic data
/dev/sda5	71157760	105324543	34166784	16.3G	Windows recovery environment
/dev/sda6	105324544	163508223	58183680	27.8G	Linux filesystem
/dev/sda7	163917824	180520959	16603136	7.9G	Linux swap
/dev/sda8	180520960	1953523711	1773002752	845.4G	Linux filesystem
/dev/sda9	163508224	163917823	409600		200M	Linux filesystem

These are the steps I took.

I burned the Arch ISO on a CD-ROM, and ran the following commands.

# loadkeys us
# wifi-menu
# timedatectl set-ntp true
# mkfs.ext4 /dev/sda6
# mkfs.ext4 /dev/sda9
# mkswap /dev/sda7
# swapon /dev/sda7
# mount /dev/sda6 /mnt
# mkdir /mnt/boot
# mount /dev/sda9 /mnt/boot
# mkdir /mnt/boot/efi
# mount /dev/sda2 /mnt/boot/efi
# mkdir /mnt/home
# mount /dev/sda8 /mnt/home		\\ I don't want to format my \home folder, I created this one already for my Debian install
# nano /etc/pacman.d/mirrorlist		\\ Edited to my preferences
# pacstrap /mnt base
# genfstab -U /mnt >> /mnt/etc/fstab
# arch-chroot /mnt
# ln -sf /usr/share/zoneinfo/Europe/Amsterdam /etc/localtime
# hwclock --systohc
# nano /etc/locale.gen			\\ Choose my locales (UTF-8)
# locale-gen
# nano /etc/locale.conf			\\ LANG=en_US.UTF-8
# nano /etc/hostname			\\ myhostname
# nano /etc/hosts			\\	localhost
						::1		localhost	myhostname.localdomain	myhostname
# passwd
# pacman -Syu grub efibootmgr os-prober intel-ucode
# grub-install --target=x86_64-efi --efi-directory=/boot/efi --bootloader-id=grub
# grub-mkconfig -o /boot/grub/grub.cfg
# exit
# umount -R /mnt
# reboot

During the reboot I removed the CD-ROM from the PC. When I do this the computer just boots to Windows (with, for some reason, the time two hours earlier).

Then I tried some troubleshooting. I tried all the options mentioned on the UEFI wikipage.

First I reran all the steps above, with one difference. After 'grub-mkconfig -o /boot/grub/grub.cfg' I ran:

# efibootmgr --create --disk /dev/sda --part 2 --loader /EFI/grub/grubx64.efi --label "GRUB Boot Manager" --verbose

and then again

# exit
# umount -R /mnt
# reboot

But I still booted into Windows.

After that, in Windows, I opened the command line as Admin and ran:
bcdedit /set "{bootmgr}" path "\EFI\grub\grubx64.efi"

But after a reboot still nothing changed.

Finally I made the BAT file as proposed in the troubleshoot:


bcdedit /set "{fwbootmgr}" DEFAULT "{1644d17d-db31-11e9-93ea-806e6f6e6963}"

For the id I choose the entry with the name: "GRUB Boot Manager". I also put in the right place with gpedit.msc.

But still my computer directly boots into Windows. What is going on? What am I missing? I tried to give as much information as possible.

All the best,

My sources for this install are … th_Windows … ncryption/ (I made a separate /boot partition because of this tutorial) … boot_order

Last edited by kromsam (2019-09-20 10:56:32)


#2 2019-09-20 08:14:13

Forum Moderator
Registered: 2012-10-16
Posts: 9,988

Re: [SOLVED] Dual Boot keeps booting directly into Windows 10

Welcome to the boards, excellent well structured first post, good job!

Acer's have a bit of a speciality here. Go into your UEFI, enable secure boot -> save. Once enabled a menu option will become available to mark an EFI binary as trusted, select your GRUB EFI as trusted and give it a name -> save, disable secure boot again, the created entry should stick.

Last edited by V1del (2019-09-20 08:16:13)


#3 2019-09-20 10:56:11

Registered: 2019-09-20
Posts: 5

Re: [SOLVED] Dual Boot keeps booting directly into Windows 10

Thanks for mentioning smile

And also thanks a lot for your reply. It worked!


Board footer

Powered by FluxBB