You are not logged in.

#1 2019-09-21 17:59:47

MrMugame
Member
Registered: 2019-08-06
Posts: 6

Nvidia glx is not loading

Hello,
I lately updated my arch machine and everything went fine but after rebooting, the nvidia dirver didn't want to boot. It sad "segmantation fault" after loading the glxserver_nvidia module in the Xorg log. After houers of trying to fix it I found out that if I disable the libglxserver_nvidia.so in /usr/lib/xorg/modules/extensions (by simply renaming it) it started just fine, but the glx is super slow and I dont now how to fix it ?! I tried reinstalling nvidia-utils , nvidia and xorg but nothing helped.

/var/log/Xorg.0.log

(II) Loading sub module "glxserver_nvidia"
(II) LoadModule: "glxserver_nvidia"
(WW) Warning, couldn't open module glxserver_nvidia
(EE) NVIDIA: Failed to load module "glxserver_nvidia" (module does not exist, 0)
(EE) NVIDIA(0): Failed to initialize the GLX module; please check in your X
(EE) NVIDIA(0):     log file that the GLX module has been loaded in your X
(EE) NVIDIA(0):     server, and that the module is the NVIDIA GLX module.  If
(EE) NVIDIA(0):     you continue to encounter problems, Please try
(EE) NVIDIA(0):     reinstalling the NVIDIA driver.

Last edited by MrMugame (2019-09-21 18:00:15)

Offline

#2 2019-09-21 18:15:41

loqs
Member
Registered: 2014-03-06
Posts: 12,952

Re: Nvidia glx is not loading

Please post the full Xorg.log,  contents of dmesg and pacman.log for the update.

Offline

#3 2019-09-21 18:52:12

MrMugame
Member
Registered: 2019-08-06
Posts: 6

Re: Nvidia glx is not loading

Found the problem in the ubuntu forum. Put this in your xorg.conf and change VERSION to the nvidia version

Section "Files"
    ModulePath      "/usr/lib/nvidia-VERSION/xorg"
    ModulePath      "/usr/lib/xorg/modules"
EndSection

Offline

#4 2019-09-21 18:58:45

loqs
Member
Registered: 2014-03-06
Posts: 12,952

Re: Nvidia glx is not loading

That is done by /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf with contents from https://git.archlinux.org/svntogit/pack … idia-utils
Edit:
If you have files in /usr/lib/nvidia-VERSION/xorg what created those files?

Last edited by loqs (2019-09-21 19:00:52)

Offline

Board footer

Powered by FluxBB