You are not logged in.

#1 2019-09-30 19:50:35

TrueParrot
Member
Registered: 2019-08-17
Posts: 4

[Bluetooth] Audio works, but microphone doesn't

Hello,

I recently got some Bluetooth headphones (Hesh 3), audio works fine but the microphone doesn't. I know it's not a headset issue because they work fine on my phone.
I'm using PulseAudio and bluez (with bluez-tools) on kernel 4.19.69-1-lts

$ pacmd list-cards
[...]
index: 2
	 name: <bluez_card.[removed]>
	driver: <module-bluez5-device.c>
	owner module: 26
	properties:
		device.description = "Hesh 3"
		device.string = "[removed]"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_[removed]"
		bluez.class = "0x240404"
		bluez.alias = "Hesh 3"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
	profiles:
		headset_head_unit: Headset Head Unit (HSP/HFP) (priority 30, available: unknown)
		a2dp_sink: High Fidelity Playback (A2DP Sink) (priority 40, available: unknown)
		off: Off (priority 0, available: yes)
	active profile: <a2dp_sink>
	sinks:
		bluez_sink.[removed].a2dp_sink/#2: Hesh 3
	sources:
		bluez_sink.[removed].a2dp_sink.monitor/#2: Monitor of Hesh 3
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: unknown)
			properties:
				
		headset-input: Headset (priority 0, latency offset 0 usec, available: unknown)
			properties:

I've tried

$ pacmd set-source-port bluez_sink.[removed].a2dp_sink.monitor headset-input
Failed to set source port to 'headset-input'.

Offline

#2 2019-09-30 19:54:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 16,812

Re: [Bluetooth] Audio works, but microphone doesn't

any chance the phone still has the headphones paired/connected?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#3 2019-09-30 19:56:20

TrueParrot
Member
Registered: 2019-08-17
Posts: 4

Re: [Bluetooth] Audio works, but microphone doesn't

ewaller wrote:

any chance the phone still has the headphones paired/connected?

Do you mean the headphones are connected to the phone? They're connected to my computer I can hear sound coming out but the microphone doesn't work (Bluetooth on my phone is turned off most of the time).

Offline

#4 2019-09-30 20:11:44

Stellarator
Member
Registered: 2019-01-12
Posts: 21

Re: [Bluetooth] Audio works, but microphone doesn't

if I'm not mistaken a2dp is unidirectional thing. So you need to activate headset_head_unit profile to be able to use your mic.

Offline

#5 2019-09-30 20:15:19

TrueParrot
Member
Registered: 2019-08-17
Posts: 4

Re: [Bluetooth] Audio works, but microphone doesn't

Stellarator wrote:

if I'm not mistaken a2dp is unidirectional thing. So you need to activate headset_head_unit profile to be able to use your mic.

No audio when I set to that (audio and mic both don't work)

Last edited by TrueParrot (2019-09-30 20:15:36)

Offline

#6 2019-09-30 21:33:50

Stellarator
Member
Registered: 2019-01-12
Posts: 21

Re: [Bluetooth] Audio works, but microphone doesn't

Offline

#7 2019-10-01 08:47:15

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,790

Re: [Bluetooth] Audio works, but microphone doesn't

Post

pacmd list-sinks
pacmd list-sources

with the profile switched.

Offline

#8 2019-10-01 14:34:59

TrueParrot
Member
Registered: 2019-08-17
Posts: 4

Re: [Bluetooth] Audio works, but microphone doesn't

V1del wrote:

Post

pacmd list-sinks
pacmd list-sources

with the profile switched.

$ pacmd list-sinks
2 sink(s) available.
    index: 0
	name: <alsa_output.pci-0000_01_00.1.hdmi-stereo-extra2>
	driver: <module-alsa-card.c>
	flags: HARDWARE DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: IDLE
	suspend cause: (none)
	priority: 9030
	volume: front-left: 42593 /  65% / -11.23 dB,   front-right: 42593 /  65% / -11.23 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 39.78 ms
	max request: 6 KiB
	max rewind: 6 KiB
	monitor source: 0
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 0
	linked by: 1
	configured latency: 40.00 ms; range is 0.50 .. 1999.82 ms
	card: 0 <alsa_card.pci-0000_01_00.1>
	module: 6
	properties:
		alsa.resolution_bits = "16"
		device.api = "alsa"
		device.class = "sound"
		alsa.class = "generic"
		alsa.subclass = "generic-mix"
		alsa.name = "HDMI 2"
		alsa.id = "HDMI 2"
		alsa.subdevice = "0"
		alsa.subdevice_name = "subdevice #0"
		alsa.device = "8"
		alsa.card = "1"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xdf080000 irq 17"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10f1"
		device.product.name = "GP106 High Definition Audio Controller"
		device.string = "hdmi:1,2"
		device.buffering.buffer_size = "352768"
		device.buffering.fragment_size = "176384"
		device.access_mode = "mmap+timer"
		device.profile.name = "hdmi-stereo-extra2"
		device.profile.description = "Digital Stereo (HDMI 3)"
		device.description = "GP106 High Definition Audio Controller Digital Stereo (HDMI 3)"
		alsa.mixer_name = "Nvidia GPU 84 HDMI/DP"
		alsa.components = "HDA:10de0084,104385b7,00100100"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
	ports:
		hdmi-output-2: HDMI / DisplayPort 3 (priority 5700, latency offset 0 usec, available: yes)
			properties:
				device.icon_name = "video-display"
				device.product.name = "ZOWIE XL LCD
"
	active port: <hdmi-output-2>
  * index: 16
	name: <bluez_sink.[removed-addr].headset_head_unit>
	driver: <module-bluez5-device.c>
	flags: HARDWARE HW_VOLUME_CTRL LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 9050
	volume: mono: 65536 / 100%
	        balance 0.00
	base volume: 65536 / 100%
	volume steps: 16
	muted: no
	current latency: 34.00 ms
	max request: 0 KiB
	max rewind: 0 KiB
	monitor source: 20
	sample spec: s16le 1ch 8000Hz
	channel map: mono
	             Mono
	used by: 1
	linked by: 3
	fixed latency: 28.00 ms
	card: 7 <bluez_card.[removed-addr]>
	module: 32
	properties:
		bluetooth.protocol = "headset_head_unit"
		device.intended_roles = "phone"
		device.description = "Hesh 3"
		device.string = "[removed-addr]"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_[removed-addr]"
		bluez.class = "0x240404"
		bluez.alias = "Hesh 3"
		device.icon_name = "audio-headset-bluetooth"
	ports:
		headset-output: Headset (priority 0, latency offset 0 usec, available: yes)
			properties:
				
	active port: <headset-output>
$ pacmd list-sources
3 source(s) available.
  * index: 0
	name: <alsa_output.pci-0000_01_00.1.hdmi-stereo-extra2.monitor>
	driver: <module-alsa-card.c>
	flags: DECIBEL_VOLUME LATENCY DYNAMIC_LATENCY
	state: RUNNING
	suspend cause: (none)
	priority: 1030
	volume: front-left: 65536 / 100% / 0.00 dB,   front-right: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 6 KiB
	sample spec: s16le 2ch 44100Hz
	channel map: front-left,front-right
	             Stereo
	used by: 1
	linked by: 1
	configured latency: 40.00 ms; range is 0.50 .. 1999.82 ms
	monitor_of: 0
	card: 0 <alsa_card.pci-0000_01_00.1>
	module: 6
	properties:
		device.description = "Monitor of GP106 High Definition Audio Controller Digital Stereo (HDMI 3)"
		device.class = "monitor"
		alsa.card = "1"
		alsa.card_name = "HDA NVidia"
		alsa.long_card_name = "HDA NVidia at 0xdf080000 irq 17"
		alsa.driver_name = "snd_hda_intel"
		device.bus_path = "pci-0000:01:00.1"
		sysfs.path = "/devices/pci0000:00/0000:00:01.0/0000:01:00.1/sound/card1"
		device.bus = "pci"
		device.vendor.id = "10de"
		device.vendor.name = "NVIDIA Corporation"
		device.product.id = "10f1"
		device.product.name = "GP106 High Definition Audio Controller"
		device.string = "1"
		module-udev-detect.discovered = "1"
		device.icon_name = "audio-card-pci"
    index: 20
	name: <bluez_sink.[removed-addr].headset_head_unit.monitor>
	driver: <module-bluez5-device.c>
	flags: DECIBEL_VOLUME LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 1050
	volume: mono: 65536 / 100% / 0.00 dB
	        balance 0.00
	base volume: 65536 / 100% / 0.00 dB
	volume steps: 65537
	muted: no
	current latency: 0.00 ms
	max rewind: 0 KiB
	sample spec: s16le 1ch 8000Hz
	channel map: mono
	             Mono
	used by: 2
	linked by: 2
	fixed latency: 28.00 ms
	monitor_of: 16
	card: 7 <bluez_card.[removed-addr]>
	module: 32
	properties:
		device.description = "Monitor of Hesh 3"
		device.class = "monitor"
		device.string = "[removed-addr]"
		device.api = "bluez"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_[removed-addr]"
		bluez.class = "0x240404"
		bluez.alias = "Hesh 3"
		device.icon_name = "audio-headset-bluetooth"
		device.intended_roles = "phone"
    index: 21
	name: <bluez_source.[removed-addr].headset_head_unit>
	driver: <module-bluez5-device.c>
	flags: HARDWARE HW_VOLUME_CTRL LATENCY 
	state: RUNNING
	suspend cause: (none)
	priority: 9050
	volume: mono: 65536 / 100%
	        balance 0.00
	base volume: 65536 / 100%
	volume steps: 16
	muted: no
	current latency: 28.00 ms
	max rewind: 0 KiB
	sample spec: s16le 1ch 8000Hz
	channel map: mono
	             Mono
	used by: 1
	linked by: 1
	fixed latency: 28.00 ms
	card: 7 <bluez_card.[removed-addr]>
	module: 32
	properties:
		bluetooth.protocol = "headset_head_unit"
		device.intended_roles = "phone"
		device.description = "Hesh 3"
		device.string = "[removed-addr]"
		device.api = "bluez"
		device.class = "sound"
		device.bus = "bluetooth"
		device.form_factor = "headset"
		bluez.path = "/org/bluez/hci0/dev_[removed-addr]"
		bluez.class = "0x240404"
		bluez.alias = "Hesh 3"
		device.icon_name = "audio-headset-bluetooth"
	ports:
		headset-input: Headset (priority 0, latency offset 0 usec, available: yes)
			properties:
				
	active port: <headset-input>

Offline

Board footer

Powered by FluxBB