You are not logged in.

#1 2019-09-17 06:11:15

topcat01
Member
Registered: 2019-09-17
Posts: 3

ipxe.lkrn BIOS TLS issue

Hi, I prepared a USB netboot image following the netboot wiki: https://wiki.archlinux.org/index.php/Netboot
The ipxe.lkrn is from: https://www.archlinux.org/static/netboo … 7b45a.lkrn
The system is BIOS based.

The  ipxe.lkrn image boots successfully but when it tries to access https://www.archlinux.org/releng/netboot/archlinux.ipxe it fails with "Operation not permitted". IPXE shows the error url http://ipxe.org/410de13c which points to a TLS issue (Fatal alert).
Not sure how to proceed. The networking seems to be working fine. Typing route at the ipxe prompt shows an ip address has been assigned. Is there a certificate issue with ipxe.lkrn?

Offline

#2 2019-09-19 06:46:23

PiousMinion
Member
Registered: 2009-07-21
Posts: 12

Re: ipxe.lkrn BIOS TLS issue

I have the same problem with the EFI image.
I've tested on bare metal and a VM.

ipxe.org suggests it may be TLS certificate related.  Perhaps an update to the ipxe image is in order? I have no idea. tongue

Offline

#3 2019-09-19 13:06:06

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,299

Re: ipxe.lkrn BIOS TLS issue

Netboot images are maintained by the release engineering people.

You might want to file  a bug report for "Release Engineering" or post to the arch-releng ML about this.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2019-10-01 22:06:51

topcat01
Member
Registered: 2019-09-17
Posts: 3

Re: ipxe.lkrn BIOS TLS issue

Offline

Board footer

Powered by FluxBB