You are not logged in.

#1 2019-10-06 14:46:08

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 213

Gnome Seahorse HKP/HKPS config bug | gnupg not working with HKPS

It does not seem to be possible to add a HKP key server, the drop-down for type of key server only offers "LDAP key server" and in a fresh Arch Linux installation with Gnome only ldap://keyserver.pgp.com is configured, although the default should be

hkp://pool.sks-keyservers.net
ldap://keyserver.pgp.com

Can someone else confirm that issue?

Last edited by Master One (2019-10-10 03:50:06)

Offline

#2 2019-10-09 12:28:54

TheAifam5
Member
Registered: 2014-11-16
Posts: 7

Re: Gnome Seahorse HKP/HKPS config bug | gnupg not working with HKPS

I can confirm that too. There is no option to add HKP keyservers, only "LDAP Key Server" and custom is available. Providing keyserver in "Custom" does not accept it.

Offline

#3 2019-10-09 13:00:04

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 213

Re: Gnome Seahorse HKP/HKPS config bug | gnupg not working with HKPS

Offline

#4 2019-10-09 15:59:58

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 213

Re: Gnome Seahorse HKP/HKPS config bug | gnupg not working with HKPS

TheAifam5 wrote:

I can confirm that too. There is no option to add HKP keyservers, only "LDAP Key Server" and custom is available. Providing keyserver in "Custom" does not accept it.

Further investigation revealed that the problem is the default configuration only containing ldap://keyserver.pgp.com as configured key server, which makes it impossible to add a hpk server address using the Seahorse configuration GUI.

Inserting a hpk server address using dconf-editor solved that problem.

Once a ldap and hkp address is inserted, it is possible to add more HTTP and LDAP addresses using the Seahorse configuration GUI.

But there is another connected problem with the Arch Linux gnupg package: FS#64072 - [gnupg] Package compiled without HTTPS / HKPS support

Last edited by Master One (2019-10-09 16:02:19)

Offline

#5 2019-10-10 03:45:42

Master One
Member
From: Austria
Registered: 2007-01-21
Posts: 213

Re: Gnome Seahorse HKP/HKPS config bug | gnupg not working with HKPS

Master One wrote:

But there is another connected problem with the Arch Linux gnupg package: FS#64072 - [gnupg] Package compiled without HTTPS / HKPS support

Well, that issue has been closed with the statement that gnupg is correctly compiled with HTTPS / HKPS support, nevertheless it's not working, which makes me assume it can only be an upstream issue. Not sure what to do now, I have no access to https://dev.gnupg.org (yet).

The problem can easily be reproduced:

gpg2 --keyserver hkp://keys.openpgp.org --search-keys {any email address}

works as expected, but

gpg2 --keyserver hkps://keys.openpgp.org --search-keys {any email address}

just hangs without error message (but works as expected on another machine running an older version of Ubuntu MATE).

Offline

Board footer

Powered by FluxBB