You are not logged in.

#1 2019-10-09 20:40:34

Kallestofeles
Member
Registered: 2016-02-23
Posts: 10

[SOLVED] Newer kernels: ccp - SEV: failed to get status

Greetings,
I recently upgraded my PC setup and ended up with the following configuration:
Motherboard: ASUS Strix x470-f
CPU: Ryzen 3700X
GPU: 2080Ti
DE: Gnome3

The trouble I have had for about a month now, is that I cannot use the mainline Arch kernels as just before the display manager should start, the system gets stuck with the following messages:

8.157104] ccp 0000:21:00.2: sev command 0x4 timed out, disabling PSP
8.157162] ccp 0000:21:00.2: SEV: failed to get status.  Error: 0x0

After digging around, I have found multiple entries regarding the matter, such as this:
https://bbs.archlinux.org/viewtopic.php?id=240718
Currently, the workaround has been to simply use the LTS kernel which has no such issues and I have even built a custom kernel based on the current mainline with the following flag (this also solves the issue for now):

CONFIG_CRYPTO_DEV_SP_PSP=n

But those two methods are just workarounds. I was hoping that the recent firmware updates to the motherboard would fix the matter but to no avail - I have just upgraded to the latest version 5220 bios and the issue persists.

I would like to ask this (as necroing old topics is not ok) - from the linked forum topic, do I understand correctly that the issue lies with AGESA and there is little that can be done on the kernel-side other than to make a temporary workaround (without poking the big man himself)? Or is there something that could be done from the OS/Arch-side which could resolve the matter permanently?

In case any log-files, to help troubleshoot the matter, are needed - I am happy to provide all the help I can, but I am no expert on these kernel module matters.

EDIT:
GPU+DE info added

Last edited by Kallestofeles (2019-10-11 16:52:23)

Offline

#2 2019-10-09 20:56:50

Pse
Member
Registered: 2008-03-15
Posts: 406

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

I don't think those messages are related to your lockup. My system (3600X, X570 Aorus Elite) shows the same messages in dmesg and there are no lockups.

There are lockups related to the 5700XT if you are using one, though, but again, those are unrelated to those messages above.

Offline

#3 2019-10-09 20:57:10

loqs
Member
Registered: 2014-03-06
Posts: 9,228

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

What was the first kernel version with the issue and the newest kernel version you have tried?
Please also post all the kernel messages from an affected  boot.
Edit:
If you boot with the kernel parameter ccp.max_devs =0 does that have any effect?

Last edited by loqs (2019-10-09 21:03:43)

Offline

#4 2019-10-10 15:18:20

Kallestofeles
Member
Registered: 2016-02-23
Posts: 10

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

Thank you for the replies!
I left the machine to boot and it seems that after a minute or two it is actually able to boot with the recent kernels despite the errors - here are the logs from the boots - one from booting with 5.3.5-zen1-1-zen kernel and another one with the ccp.max_devs =0 option set. Unfortunately setting the ccp.max_devs =0 parameter does not affect the error messages nor the boot time.
Journal - https://pastebin.com/By17n6CB
Journal with ccp.max_devs=0 - https://pastebin.com/QAywE2PU
I know I am using the Zen kernel instead of the regular one, but the results are the same with either one.

Updated the initial post to reflect the GPU as well. Not running an AMD card currently, a 2080Ti is the GPU.

The positive side of things is that despite the long boot time, it actually boots successfully in the end and it is my own stupidity to blame here not willing to wait long enough, but the 1-2 minute boot time (probably waiting for a timeout) is still an issue.

Furthermore, the issue started when I upgraded the following packages:

[2019-09-20 15:54] [ALPM] upgraded gnome-desktop (1:3.32.2-1 -> 1:3.34.0-1)
[2019-09-20 15:54] [ALPM] upgraded gnome-session (3.32.0-1 -> 3.34.0-1)
[2019-09-20 15:54] [ALPM] upgraded gnome-settings-daemon (3.32.1-1 -> 3.34.0-1)
[2019-09-20 15:54] [ALPM] upgraded gnome-shell (1:3.32.2+11+g1c6abf378-1 -> 1:3.34.0+94+g3d86e6e79-1)
[2019-09-20 15:54] [ALPM] upgraded gdm (3.32.0+2+g820f90f5-2 -> 3.34.0-2)
[2019-09-20 15:54] [ALPM] upgraded gnome-control-center (3.32.2-1 -> 3.34.0.1+10+g0f8e3f332-1)
[2019-09-20 15:54] [ALPM] upgraded gnome-shell-extensions (3.32.1-1 -> 3.34.0-1)
[2019-09-20 15:54] [ALPM] upgraded gnome-software (3.32.1-1 -> 3.34.0-1)
[2019-09-20 15:54] [ALPM] upgraded linux (5.2.14.arch2-1 -> 5.3.arch1-1)
[2019-09-20 15:54] [ALPM] upgraded linux-zen (5.2.14.zen2-1 -> 5.3.zen1-1)

When I first encountered this, I downgraded all of those packages to revert, yet the issue remained. For the last 2 months I have also been upgrading the BIOS firmware quite frequently due to Zen2 optimizations and I have a bad feeling that the newer Strix x470-f BIOSes are to blame here.

Thank you guys for helping!

Offline

#5 2019-10-10 18:30:54

loqs
Member
Registered: 2014-03-06
Posts: 9,228

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

I missed ccp.max_devs is only available from linux 5.4 instead try ccp.psp_cmd_timeout=1 instead of the default 100 seconds.
There is also ccp.psp_probe_timeout but that defaults to 5.

Offline

#6 2019-10-10 20:59:49

Kallestofeles
Member
Registered: 2016-02-23
Posts: 10

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

loqs wrote:

I missed ccp.max_devs is only available from linux 5.4 instead try ccp.psp_cmd_timeout=1 instead of the default 100 seconds.

Unfortunately the result remains the same.
I dug around and read a bit about SEV. So it is essentially a cryptographic feature of AMD processors to keep the host and virtual machine environments separate as I understand. So I went into BIOS and disabled the SVM (CPU virtualization in Asus' terms) completely - the result was the same but now I got 16 additional errors for each thread saying: "kvm disabled by bios" (which makes sense)
That made me wonder why is the system even loading the kvm stuff - I uninstalled gnome-boxes with qemu and all their dependencies but still it gets stuck waiting for something. I could try blacklisting the whole kvm module, but I wish to use VMs in the future so that option goes out the window.

Offline

#7 2019-10-10 21:12:25

loqs
Member
Registered: 2014-03-06
Posts: 9,228

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

If you boot to a multi-user.target is that faster?
I ask as there appears to be a minute delay with GDM failing.

okt   10 17:54:47 shoemaster kernel: audit: type=1131 audit(1570719287.764:29): pid=1 uid=0 auid=4294967295 ses=4294967295 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? terminal=? res=success'
okt   10 17:55:48 shoemaster systemd[684]: gnome-session-manager@gnome-login.service: State 'stop-sigterm' timed out. Killing.

Offline

#8 2019-10-10 22:42:52

cyberrumor
Member
Registered: 2019-04-21
Posts: 2

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

Hey there guys, same issue here. Been using Arch for a few years now and haven't come across something I couldn't fix in a long time. Basically I have the same SEV errors, but they didn't used to prevent my GUI from loading. Was distro hopping for a while and came back to the issue, so I can't pinpoint exactly when it started happening. I'm using up-to-date gnome stack, but the issue getting to GUI is present with LightDM as well as GDM, and reproducible. Hardware: 1060 6GB, MSI B450I, 16GB 3200 CAS 14, Ryzen 3600. Until I found this thread, I figured it was an issue with either the Nvidia stack or the kernel, so I tried combinations of nvidia, nvidia-dkms, nvidia-390xx on default kernel, as well as nvidia-lts or nvidia-390xx-lts on top of linux-lts. Basically the kernel prints the SEV error and will never drop me to GUI. The gdm or lightdm service depending on which I try say that they started successfully according to # systemctl status lightdm (or gdm). I can always get to a GUI by hopping over to TTY2 and doing # systemctl restart gdm.service, then ctrl+alt+f2, then ctrl+alt+f1. It seems to me that xorg is failing to load on the first try, but on a second try and some encouragement from TTY switching, it finally is able to start on TTY1. Happy to provide logs, configs, or anything else that could help this one get ironed out. Like I said, the SEV error was present before I had an issue getting to GUI, but now it is the last thing printed to console. I suspect SEV error is unrelated. Currently using the 9/25 update from   here, but issue was also present with the 9/02 update.

Offline

#9 2019-10-11 06:30:30

Kallestofeles
Member
Registered: 2016-02-23
Posts: 10

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

loqs wrote:

If you boot to a multi-user.target is that faster?
I ask as there appears to be a minute delay with GDM failing.

Yes, success! With multi-user, the gdm does not start and I am pushed to the regular tty login - when I log in and start gdm manually, it immediately starts and there is no delay.
Do I understand correctly that this indicates a problem with GDM automatic startup using systemd's graphical.target and should be filed in with Gnome team?

Offline

#10 2019-10-11 13:04:48

loqs
Member
Registered: 2014-03-06
Posts: 9,228

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

I would rule out a configuration issue before reporting it upstream.  Is gdm configured to use the Xorg backend?
What is the contents of /etc/X11/xorg.conf ?

Offline

#11 2019-10-11 16:51:34

Kallestofeles
Member
Registered: 2016-02-23
Posts: 10

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

loqs wrote:

I would rule out a configuration issue before reporting it upstream.  Is gdm configured to use the Xorg backend?
What is the contents of /etc/X11/xorg.conf ?

Indeed, it seems that you have cracked the case!
I uncommented the line...

#WaylandEnable=false

... in /etc/gdm/custom.conf and the system boots up instantly without any delays. Thank you so much!
I guess either gnome is pushing wayland more and more, OR nvidia is making changes to its drivers which meddle with how wayland has outright failed before and now gives a longer timeout.

In any case, I shall mark the thread as solved as all is working exactly as expected now.
Thank you again loqs so much for taking your time and helping to get this case resolved! I hope that this helps someone else out there as well experiencing these issues with Gnome and nvidia.

Offline

#12 2019-10-11 17:37:47

cyberrumor
Member
Registered: 2019-04-21
Posts: 2

Re: [SOLVED] Newer kernels: ccp - SEV: failed to get status

Hey guys, just a quick follow up from my end. I was able to solve the blackscreen issues by combining nvidia-390xx-lts with linux-lts afterall. I must have had a broken xorg.conf or something when I tried it the first few times. Not really sure why the new driver that officially supports my 1060 doesn't work, but the 390 driver for older cards than my own works alright. Very fishy haha.

Offline

Board footer

Powered by FluxBB