You are not logged in.

#1 2019-10-10 21:25:15

gluder
Member
Registered: 2019-10-10
Posts: 5

Arch Linux (on iMAC 2007) working properly (but black screen)

Hello there

I used for few months Arch Linux on my iMac (mid 2007) without any problem at all. Two days ago I updated my box (pacman -Syu) and since then no matter what I have a black screen at boot and after, no logo, no cursor, nothing!

Anyway I can ssh (and VNC) easily to my box and there is nothing relevant in the journal as far as I can see. Everything works perfectly, but screen is 'dead'. Of course I tried another live distro and the screen works perfecly, so it is not a hardware issue.

I mkinitcpio, tried LTS kernel, uninstalled virtualbox, disabled all the KMS with nomodeset, force vga=xxx settings, but there is no chance I can have my screen back.

Do you guys have any tips for this pls? Thanks

Last edited by gluder (2019-10-10 21:34:19)

Offline

#2 2019-10-10 21:34:12

Swiggles
Member
Registered: 2014-08-02
Posts: 260

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

I don't know if I can help, but I think it would be very important to actually share your journal and pacman log.

Did you try to rollback to the previous kernel and drivers?

Offline

#3 2019-10-10 22:27:12

gluder
Member
Registered: 2019-10-10
Posts: 5

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

Here it is

Journal: https://pastebin.com/pzEZVCmJ
Pacman Log: https://pastebin.com/kaLWzg5U

I did not rollback because machine is in production (Samba AD client) and rather avoid messing things up more.

Offline

#4 2019-10-11 00:33:32

loqs
Member
Registered: 2014-03-06
Posts: 9,054

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

The journal you posted is only for the user session.  To access the system journal a user must be root or a member of one the groups:  systemd-journal, adm or  wheel.
Please also do not use journaltl -x when posting outputs.

Offline

#5 2019-10-11 10:04:06

gluder
Member
Registered: 2019-10-10
Posts: 5

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

My bad, sorry! Too much used to sudo

Here it is again: https://pastebin.com/hN7VXmJX

Offline

#6 2019-10-11 12:33:15

loqs
Member
Registered: 2014-03-06
Posts: 9,054

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

Can you please post the journals for a boot under linux 5.3.1.arch1-1 and linux 5.3.4-arch1-1.
I am assuming 5.3.1.arch1-1 was the kernel without the issue.

Offline

#7 2019-10-11 14:56:54

gluder
Member
Registered: 2019-10-10
Posts: 5

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

Yes, you are right, and same behavior with 5.3.5 as well:

5.3.1 : https://pastebin.com/1rcq8XVe
5.3.4 : https://pastebin.com/5RBEiHvd
5.3.5 : https://pastebin.com/wtZz1uMS

Thanks again for looking into this!

Offline

#8 2019-10-12 09:39:21

gluder
Member
Registered: 2019-10-10
Posts: 5

Re: Arch Linux (on iMAC 2007) working properly (but black screen)

Btw I just tried to downgrade *only* the kernel only to 5.3.1 and funnily enough I have the same issue: black screen with a system up and running!

Offline

Board footer

Powered by FluxBB