You are not logged in.

#1 2006-08-20 21:27:15

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

mplayer issues

I get the audio playing, but the video seems innaccessible. I get this error msg:

Cannot find the codec matching selected -vo  and video format 0x33564D57

I suppose that -vo means video output? I was trying to play an .asf file and I have codecs installed.

Has anyone resolved this, or found that they have no problem?

Thanks in advance.

Geoff


What the beep was that?

Offline

#2 2006-08-20 21:32:31

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: mplayer issues

Starting to answer my own question, from the term I get:

Trying to force video codec driver family theora...
Requested video codec family [wmv9dmo] (vfm=dmo) not available.
Enable it at compilation.
Requested video codec family [wmvdmo] (vfm=dmo) not available.
Enable it at compilation.
Cannot find codec matching selected -vo and video format 0x33564D57.
Read DOCS/HTML/en/codecs.html!

Looks like I've got to build stuff in at compilation, doesn't it? Plus, Ill follow this through: Read DOCS/HTML/en/codecs.html!

Geoff


What the beep was that?

Offline

#3 2006-08-20 21:38:51

karsten
Member
Registered: 2006-07-14
Posts: 261

Re: mplayer issues

probably because the win32codec package is 32-bit only.

Offline

#4 2006-08-20 22:07:24

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,640

Re: mplayer issues

karsten wrote:

probably because the win32codec package is 32-bit only.

No. But not every 32bit codec work in a 64bit environment.

http://www1.mplayerhq.hu/design7/codecs.html

Offline

#5 2006-08-20 23:05:04

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: mplayer issues

Thanks guys. I've researched a bit and certainly I plonked the .dll codecs into /usr/lib/codecs and rebuilt the package. But... this link gives some solid explanations about Wmv9 and the codecs, which relate to the 0x33564D57 video format.

http://www.ubuntuforums.org/showthread. … 974&page=6

In particular:

Playing back wmv9 files on AMD64 is tricky. On i386 you can use mplayer with the win32 codecs, or the experimental vc-1 codec. However, using AMD64, things get a bit more difficult. It is possible to use the 32bit mplayer package, but it requires that all the libraries that it depends on are also 32bit. Thats why I made a package for you!

The thread is quite extensive and certainly it can be built for ubuntu; and that could be used as a template for arch. Some of those libraries have already been re-used, but this would be a big venture, eh?

Geoff


What the beep was that?

Offline

#6 2006-08-21 01:22:26

gs
Member
From: UK
Registered: 2004-03-06
Posts: 147

Re: mplayer issues

Right on this very page and lower down is this thread: [arch64] and multimedia codecs

http://bbs.archlinux.org/viewtopic.php? … 5ea9447cda

I should have looked for this earlier... sorry, I didn't! But I see there has been some earlier interest in getting mplayer more adapted for arch64, so maybe the above ubuntu thread will be of some use.


What the beep was that?

Offline

Board footer

Powered by FluxBB