You are not logged in.

#1 2019-10-17 12:56:59

Odahviing
Member
Registered: 2019-10-17
Posts: 2

MuPDF stopped working

Hello, this is my first post in the forum, so I'm not quiet sure, if this is the right place to ask smile

As of today, all pdf viewers using `mupdf` stopped working for me with the error `undefined symbol: jbig2_ctx_new`.
I suppose this is because of a recent update of `jbig2dec`. Does anybody have information on this?

Offline

#2 2019-10-17 13:10:40

Vofan
Member
Registered: 2019-01-21
Posts: 58

Re: MuPDF stopped working

I also have this issue. I thought there was something wrong with my tex compiler :-) I'm using zathura; using poppler as the backend with zathura-pdf-poppler works for now. I presume there is a version mismatch or something.

Offline

#3 2019-10-17 13:13:17

Vofan
Member
Registered: 2019-01-21
Posts: 58

Re: MuPDF stopped working

You could maybe try downgrading jbig2dec if this fix is unacceptable to you for now.

I would test it with v.16-1 myself, but I get

error: failed retrieving file 'jbig2dec-0.16-1-x86_64.pkg.tar.xz' from archive.archlinux.org : OpenSSL SSL_connect: SSL_ERROR_SYSCALL in connection to archive.org:443
warning: failed to download https://archive.archlinux.org/packages/j/jbig2dec/jbig2dec-0.16-1-x86_64.pkg.tar.xz
error: 'https://archive.archlinux.org/packages/j/jbig2dec/jbig2dec-0.16-1-x86_64.pkg.tar.xz': download library error

with the downgrade package.

Offline

#4 2019-10-17 13:20:28

Odahviing
Member
Registered: 2019-10-17
Posts: 2

Re: MuPDF stopped working

Thank you very much; I'm also using zathura and changed to the poppler backend for now. In this mailing list, there is also a possible fix in discussion, but I'm not nearly experienced enough to do this myself.

Offline

#5 2019-10-17 14:00:19

Ie0n
Member
Registered: 2019-10-17
Posts: 1

Re: MuPDF stopped working

I'm getting the same issue here, using evince until this gets fixed.

Offline

#6 2019-10-17 15:19:15

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 23,892
Website

Re: MuPDF stopped working

It's fixed in the repos now.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#7 2019-10-23 08:53:16

zash1958
Member
Registered: 2019-10-23
Posts: 3

Re: MuPDF stopped working

Here an other "effect" of this:

My Ricoh Aficio SG3110SFNw refused printing graphics (only text works) after last updates. The following helped:

Downgrade to:

jbig2dec-0.16-1-x86_64.pkg.tar.xz
ghostscript-9.27-2-x86_64.pkg.tar.xz

helped so far. ATM I think this is a bug in jbig2dec ???????

Last edited by zash1958 (2019-10-23 08:54:41)

Offline

#8 2019-10-23 12:03:57

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 23,892
Website

Re: MuPDF stopped working

No, there is no error related to a bug anywhere in this thread.  Mupdf just needed to be rebuilt against the new jbig2dec.  The proper solution was to just update mupdf to the proper version in the repos within a couple hours of this issue first being noted.

If your issue is different, start a different thread.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#9 2020-03-18 00:55:02

cgbarros
Member
Registered: 2017-04-24
Posts: 8

Re: MuPDF stopped working

Hello! Resurrecting this thread. I think this happened again. MuPDF is not loading files.

This is the message I'm getting:

warning: jbig2dec error: incompatible jbig2dec header (0.17) and library (0.18) versions (segment -1)
error: cannot allocate jbig2 globals context
mupdf: warning: Failed to load page.
error: items left on stack in draw device: 1

Offline

#10 2020-03-18 01:04:41

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 23,892
Website

Re: MuPDF stopped working

It works fine here - that error looks more like something is wrong with the PDF, have you tried other pdfs?


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#11 2020-03-18 06:59:59

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: MuPDF stopped working

warning: jbig2dec error: incompatible jbig2dec header (0.17) and library (0.18) versions (segment -1)

https://git.archlinux.org/svntogit/pack … s/jbig2dec

If the header warning is significant to the failure (fair assumption due to the jbig2 related error), mupdf indeed requires recompilation.
ABI incompatibility does not necessarily result in missing symbols.

@cgbarros, does it work when you downgrade jbig2dec to 0.17?

Offline

#12 2020-03-18 13:27:30

cgbarros
Member
Registered: 2017-04-24
Posts: 8

Re: MuPDF stopped working

Trilby wrote:

have you tried other pdfs?

I didn't have before. With other PDFs it worked. This one has scanned pages from a book I own (it's not just text, it's images). Maybe that has something to do with it?

seth wrote:

does it work when you downgrade jbig2dec to 0.17?

Yes. I just downgraded (after trying to open other PDFs, mind you) and now it reads the PDF I was trying to open.

Offline

#14 2020-03-18 14:48:12

battlepanic
Member
Registered: 2009-08-22
Posts: 76

Re: MuPDF stopped working

This appears to be related to jbig2dec recently being bumped from 0.17 to 0.18.  This change breaks mupdf when attempting to display JBIG2-encoded PDF documents.  The mupdf package will need to be rebuilt.  A bug report has been created:

https://bugs.archlinux.org/task/65880

Offline

#15 2020-03-19 18:40:57

cgbarros
Member
Registered: 2017-04-24
Posts: 8

Re: MuPDF stopped working

thanks for the help, guys! Will you confirm when the bug is resolved?

Offline

#16 2020-03-19 20:32:03

seth
Member
Registered: 2012-09-03
Posts: 15,659

Re: MuPDF stopped working

You can subscribe to the bug to get status updates by mail.

Offline

#17 2020-03-20 15:53:48

cgbarros
Member
Registered: 2017-04-24
Posts: 8

Re: MuPDF stopped working

Cool. Will do!

Offline

Board footer

Powered by FluxBB