You are not logged in.

#1 2019-10-26 22:07:19

igglepiggle
Member
Registered: 2019-10-26
Posts: 3

rua upgrade keeps trying to force emacs on me

Got a long term Arch install (4 years, 2 months) here, and recent upgrade broke yaourt (libaplm) which I should have stopped using sooner, apparently. Looked at the options and went with rua.

I've made several attempts to `rua upgrade` but at each point it claims a specific package requires emacs I abort and remove the package and start over, and then another package apparently requires emacs. I'm starting to uninstall packages I'd prefer to keep using now!

Some of the packages which supposedly require emacs: steamcmd  otf-jost ttf-symbola resvg-cairo perl-mojolicious  slowmovideo-git  zita-ajbridge-gui  package-query.

I don't have any actual ideas what could be causing this to pull in emacs as a dependency. There's only some hazy vague notion in the back of my mind but, excuse the pun, I'm a bit rusty these days.

Any pointers or ideas appreciated.

Last edited by igglepiggle (2019-10-26 22:12:07)

Offline

#2 2019-10-26 22:11:38

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,140
Website

Re: rua upgrade keeps trying to force emacs on me

Mod note: moving to AUR Issues.

Please post the full output from a problematic build. Can you reproduce it with regular makepkg?

Last edited by WorMzy (2019-10-26 22:13:06)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2019-10-26 22:26:56

igglepiggle
Member
Registered: 2019-10-26
Posts: 3

Re: rua upgrade keeps trying to force emacs on me

$ rua upgrade
Package                Current       Latest 
brscan4                0.4.7_1-1     0.4.8_1-1 
clamav-unofficial-sigs 5.6.2-4       6.1.1-1 
gnome-vfs              2.24.4-10     2.24.4-11 
golden-cheetah-dev     3.5-1903      3.5-191016 
grip                   3.10.1-1      4.0.0-1 
gtypist                2.9.5-5       2.9.5-6 
gzdoom                 3.5.1-1       4.2.3-1 
ipscan                 3.5.3-1       3.6.1-2 
orbit2                 2.14.19-3     2.14.19-7 
fittotcx-git           r24.39b0b46-1 NOT FOUND, ignored 
gpstk17-bin            1.7-1         NOT FOUND, ignored 
vte                    0.28.2-8      NOT FOUND, ignored 

Do you wish to upgrade them? [O]=ok, [X]=exit. o

In order to install all targets, the following pacman packages will need to be installed:
  emacs

And the following AUR packages will need to be built and installed:
  brscan4
  clamav-unofficial-sigs
  gnome-vfs
  golden-cheetah-dev
  grip
  gtypist
  gzdoom
  ipscan
  orbit2

Proceed? [O]=ok, Ctrl-C=abort. o

Reviewing "/home/igglepiggle/.config/rua/pkg/ipscan". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o
WARNING: your AUR repo is up-to-date.
If you continue, the build directory will be removed and the build will be re-run.
If you don't want that, consider resolving the situation manually,
for example:    rua builddir "/home/igglepiggle/.cache/rua/build/gnome-vfs"


Reviewing "/home/igglepiggle/.config/rua/pkg/gnome-vfs". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o

Reviewing "/home/igglepiggle/.config/rua/pkg/gzdoom". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o

Reviewing "/home/igglepiggle/.config/rua/pkg/gtypist". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o
WARNING: your AUR repo is up-to-date.
If you continue, the build directory will be removed and the build will be re-run.
If you don't want that, consider resolving the situation manually,
for example:    rua builddir "/home/igglepiggle/.cache/rua/build/clamav-unofficial-sigs"


Reviewing "/home/igglepiggle/.config/rua/pkg/clamav-unofficial-sigs". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o

Reviewing "/home/igglepiggle/.config/rua/pkg/golden-cheetah-dev". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o

Reviewing "/home/igglepiggle/.config/rua/pkg/orbit2". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o
WARNING: your AUR repo is up-to-date.
If you continue, the build directory will be removed and the build will be re-run.
If you don't want that, consider resolving the situation manually,
for example:    rua builddir "/home/igglepiggle/.cache/rua/build/brscan4"


Reviewing "/home/igglepiggle/.config/rua/pkg/brscan4". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o

Reviewing "/home/igglepiggle/.config/rua/pkg/grip". 
[S]=run shellcheck on PKGBUILD, [D]=(identical to upstream, empty diff), [T]=run shell to edit/inspect, [O]=ok, use package o
Packages need to be installed:

    pacman -S --asdeps --needed 'emacs'

Enter S to `sudo` install it, or install manually and press M when done. m
Packages need to be installed:

    pacman -S --asdeps --needed 'emacs'

Enter S to `sudo` install it, X to skip installation, or install manually and enter M when done. m
Packages need to be installed:

    pacman -S --asdeps --needed 'emacs'

Enter S to `sudo` install it, X to skip installation, or install manually and enter M when done. x
thread 'main' panicked at 'Failed to remove old build dir "/home/igglepiggle/.cache/rua/build/brscan4", Permission denied (os error 13)', src/action_install.rs:119:5
note: run with `RUST_BACKTRACE=1` environment variable to display a backtrace.

I don't have earlier invocations where I've aborted and then removed a package. I've run the command 3 times just now and each time the packages are upgraded in a different order but it is always the last package which supposedly depends on emacs.

Offline

#4 2019-10-26 22:50:34

loqs
Member
Registered: 2014-03-06
Posts: 9,074

Re: rua upgrade keeps trying to force emacs on me

What is the output if you try and build /home/igglepiggle/.config/rua/pkg/grip with makepkg?

Offline

#5 2019-10-26 22:59:30

igglepiggle
Member
Registered: 2019-10-26
Posts: 3

Re: rua upgrade keeps trying to force emacs on me

It completes without issue.

Last edited by igglepiggle (2019-10-26 23:00:38)

Offline

#6 2019-10-26 23:33:04

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,114
Website

Re: rua upgrade keeps trying to force emacs on me

Read the comments on the rua AUR page: it looks like something of a clusterfuck.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB