You are not logged in.

#1 2019-10-30 11:03:18

PizzicatoAlAparato
Member
Registered: 2018-12-05
Posts: 9

HDMI Audio not working on laptop with output wired to the NVIDIA chip

Hi!
I have an MSI laptop which has the HDMI output wired to its GPU. To make it work with an external monitor I'm running bumblebee and had to follow this guide section to enable it: https://wiki.archlinux.org/index.php/Bu … VIDIA_chip

Video is working great and I'm very happy with it, but I haven't been able to make the sound work through the monitor's speakers. In pavucontrol I get for all HDMI outputs 'unavailable', and some other 'unavailable' and 'unplugged'. Please help!!

I'm not sure what commands output you may need to diagnose the problem. For now I'm sure aplay -l would be useful.

# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: ALC898 Analog [ALC898 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 1: ALC898 Digital [ALC898 Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 7: HDMI 1 [HDMI 1]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 8: HDMI 2 [HDMI 2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 9: HDMI 3 [HDMI 3]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 10: HDMI 4 [HDMI 4]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Thanks a lot!!

Offline

#2 2019-10-30 12:37:06

theodore
Member
Registered: 2008-09-09
Posts: 111

Re: HDMI Audio not working on laptop with output wired to the NVIDIA chip

Try to have a look on my thread here https://bbs.archlinux.org/viewtopic.php?id=248282 and possibly try the command I've tried over there we might be facing the same issue. I haven't managed to solved it yet though, but since I am not using any external speakers over hdmi currently I have left it aside hoping that with any latest nvidia driver update this might be get solved.

Offline

#3 2019-11-04 08:45:12

PizzicatoAlAparato
Member
Registered: 2018-12-05
Posts: 9

Re: HDMI Audio not working on laptop with output wired to the NVIDIA chip

OK, thanks a lot. I haven't had time to get back to this. Once I check it I'll post here any info.

Offline

#4 2019-11-07 09:54:02

PizzicatoAlAparato
Member
Registered: 2018-12-05
Posts: 9

Re: HDMI Audio not working on laptop with output wired to the NVIDIA chip

Hey!
I went over theodore's thread and realized that my problem (for now) is that once the HDMI cable is connected my system stops seeing the Nvidia sound card, as you can see in my first post. I have been looking around and found this post that describes exactly my case, but is not solved: https://bbs.archlinux.org/viewtopic.php?id=197704

Any clues?

EDIT: After restarting, the NVIDIA sound card was showing again, I don't know why it wasn't being detected, but that's working now. I'm getting the same behavior as theodore when testing each of the possible HDMI outputs, no sound at all, but speaker-test command doesn't show any errors.

Last edited by PizzicatoAlAparato (2019-11-07 10:43:43)

Offline

#5 2019-11-07 10:52:56

PizzicatoAlAparato
Member
Registered: 2018-12-05
Posts: 9

Re: HDMI Audio not working on laptop with output wired to the NVIDIA chip

I found some messages in the boot logs that I think are important:

Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event13)
Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) No input driver specified, ignoring this device.
Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) This device may have been added with another device file.
Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event16)
Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) No input driver specified, ignoring this device.
Nov 07 11:05:07 beast /usr/lib/gdm-x-session[868]: (II) This device may have been added with another device file.

This messages are also logged for the intel card HDMI devices.

Last edited by PizzicatoAlAparato (2019-11-07 10:53:38)

Offline

#6 2019-11-07 22:02:21

theodore
Member
Registered: 2008-09-09
Posts: 111

Re: HDMI Audio not working on laptop with output wired to the NVIDIA chip

@PizzicatoAlAparato in my case I am not getting anything related with the nvidia and the HDMI/DP outputs. The only I am getting is related to the Intel:

$ dmesg | grep HDMI
[    0.739196] ACPI: Added _OSI(Linux-Lenovo-NV-HDMI-Audio)
[   19.690510] input: HDA Intel PCH HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input50
[   19.690597] input: HDA Intel PCH HDMI/DP,pcm=7 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input51
[   19.690690] input: HDA Intel PCH HDMI/DP,pcm=8 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input52
[   19.690816] input: HDA Intel PCH HDMI/DP,pcm=9 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input53
[   19.690907] input: HDA Intel PCH HDMI/DP,pcm=10 as /devices/pci0000:00/0000:00:1f.3/sound/card0/input54

also which desktop environment are you using, it seems that you are with gnome, is that correct?
Here I am with kde plasma though I do not think that this would make any difference.

Last edited by theodore (2019-11-07 22:02:44)

Offline

Board footer

Powered by FluxBB