You are not logged in.

#1 2019-11-02 19:30:29

Tétrapyle
Member
Registered: 2014-01-03
Posts: 32

[ALMOST SOLVED] openmw and openscenegraph (34 or not)

Hi there,

Openmw has openscenegraph34 as a dependency.

Scribus has openscenegraph as a dependency.

openscenegraph34 conflicts with openscenegraph.

By the way, openmw-git from the AUR has openscenegraph as a dependency.

I would like to ask: is this the kind of things we're supposed to report as a bug in the Packages section?

Last edited by Tétrapyle (2019-11-10 22:57:12)

Offline

#2 2019-11-03 13:56:32

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,359

Re: [ALMOST SOLVED] openmw and openscenegraph (34 or not)

openscenegraph34 provides openscenegraph, does scribus work with openscenegraph34 installed ?


about openmw-git :
Last Updated:     2017-09-22 13:40

ase1590 commented on 2018-11-19 01:32   

https://gitlab.com/OpenMW/openmw/issues/4692

Until this bug is resolved, OpenMW will need to require OpenSceneGraph 3.4.1

openmw-git users that didn't encounter this bug have been lucky.

The openmw bug has been solved, I've filed a feature request.
https://bugs.archlinux.org/task/64369


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-11-10 22:56:15

Tétrapyle
Member
Registered: 2014-01-03
Posts: 32

Re: [ALMOST SOLVED] openmw and openscenegraph (34 or not)

Thank you Lone_Wolf for pointing this and for filing the feature request!
Scribus didn't launch with openscenegraph34.

The task has just been closed and the package updated to replace openscenegraph34 by openscenegraph. But, well, it actually didn't occur and I presume there's been some mistyping. Anyway, it builds fine by just changing the dependency in the PKGBUILD.

Offline

Board footer

Powered by FluxBB