You are not logged in.

#1 2019-11-04 00:57:17

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 9,855
Website

wiki spam filter doesn't appear to work

I am trying to edit using the AUR template (ie [[AUR|foo]]) but the wiki is challenging me to enter the some shell output as a spam countermeasure.  I did, but it is not accepting it.  Bug report against the wiki?


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#2 2019-11-04 01:02:26

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,317

Re: wiki spam filter doesn't appear to work

Offline

#3 2019-11-04 07:56:22

hfenigma
Member
Registered: 2017-06-29
Posts: 28

Re: wiki spam filter doesn't appear to work

It always says Incorrect or missing CAPTCHA. But I am sure it's filled and correct.

Offline

#4 2019-11-04 07:57:39

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 643

Re: wiki spam filter doesn't appear to work

graysky wrote:

I am trying to edit using the AUR template (ie [[AUR|foo]]) but the wiki is challenging me to enter the some shell output as a spam countermeasure.  I did, but it is not accepting it.  Bug report against the wiki?

This should fix it: https://github.com/archlinux/archwiki/pull/24

Last edited by lahwaacz (2019-11-04 15:41:45)

Offline

#5 2019-11-04 08:04:45

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 643

Re: wiki spam filter doesn't appear to work

hfenigma wrote:

It always says Incorrect or missing CAPTCHA. But I am sure it's filled and correct.

See https://bugs.archlinux.org/task/48395

Last edited by lahwaacz (2019-11-04 15:42:13)

Offline

#6 2019-11-04 08:19:37

hfenigma
Member
Registered: 2017-06-29
Posts: 28

Re: wiki spam filter doesn't appear to work

Thank you very much.

After a few trial and errors, the following worked.

pacman -V | sed 's/5.2.1/5.2.0/' | base32 | head -1

Offline

#7 2019-11-04 08:21:42

hfenigma
Member
Registered: 2017-06-29
Posts: 28

Re: wiki spam filter doesn't appear to work

Maybe the pacman wiki developer should add a pacman hook to remind him to update the CAPTCHA here.

Last edited by hfenigma (2019-11-04 08:32:14)

Offline

#8 2019-11-04 08:37:16

hfenigma
Member
Registered: 2017-06-29
Posts: 28

Re: wiki spam filter doesn't appear to work

And now I never received the confirmation email.

The Mail a confirmation code button gives me

ArchWiki could not send your confirmation mail. Please check your email address for invalid characters.

Mailer returned: Failed to connect to localhost:10027 [SMTP: Failed to connect socket: Connection refused (code: -1, response: )]

Am I unlucky or the wiki infrastructure is a mess now ...

Offline

#9 2019-11-04 10:40:48

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 643

Re: wiki spam filter doesn't appear to work

hfenigma wrote:

Am I unlucky or the wiki infrastructure is a mess now ...

Probably both smile  I'm also not receiving any mails from the wiki since earlier this day...

Offline

#10 2019-11-04 11:26:24

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,798

Re: wiki spam filter doesn't appear to work

Merging with existing topic

Offline

#11 2019-11-04 11:52:34

lahwaacz
Wiki Admin
From: Czech Republic
Registered: 2012-05-29
Posts: 643

Re: wiki spam filter doesn't appear to work

I created a bug report for the email issues: https://bugs.archlinux.org/task/64382

Offline

Board footer

Powered by FluxBB