You are not logged in.

#1 2019-11-08 11:14:56

xerxes_
Member
Registered: 2018-04-29
Posts: 108

[SOLVED] Package auto completion with option don't work in new pacman

I'm sure that before pacman 5.2 package auto completion worked: I mean when I write in shell 'pacman -Ss' and part of name of some package and press 'Tab' key once or twice (if there were more matches) name of package was completed. And now it don't work.

Last edited by xerxes_ (2019-11-08 21:30:34)

Offline

#2 2019-11-08 11:27:39

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,370

Re: [SOLVED] Package auto completion with option don't work in new pacman

On my system completion with -Ss or -Qs doesn't work, but -Qi & -Si do.

Is that the same for you ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2019-11-08 11:34:37

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,904
Website

Re: [SOLVED] Package auto completion with option don't work in new pacman

Edit:  Read post more thoroughly...   -Ss won't complete anything.  How is you shell supposed to know what you are searching for?

Offline

#4 2019-11-08 11:38:52

xse
Member
Registered: 2019-01-08
Posts: 34

Re: [SOLVED] Package auto completion with option don't work in new pacman

Hey,

Do you have https://www.archlinux.org/packages/extr … ompletion/ installed ?

auto completion is a feature from your shell, so i'd be good to know which shell you are using, and how the auto completion is configured.

On my systems for example i use zsh, along with the grml configuration (the same thing used on the installation images). That configuration allows me to get package completion like so:

xse@potato ~ % pacman -Qi t
completing package
tar                      texinfo                  thin-provisioning-tools  tmux                     tre                      tzdata

But if i use zsh without any configuration it won't complete package, it's the same thing for bash, the configuration to complete packages is something you either have to explicitly set in your configuration, either there's already a package to download that set it up in the default bash configuration.


Carefully explaining your problem is half the solution.

Offline

#5 2019-11-08 21:07:48

xerxes_
Member
Registered: 2018-04-29
Posts: 108

Re: [SOLVED] Package auto completion with option don't work in new pacman

I use default shell (so I use bash) with default settings, and I have bash-completion package installed and working.

Indeed pacman with -Ss or -Qs doesn't work, and -Qi & -Si do, but I remember that in pre 5.2 version of pacman I had package completion working also with option -Ss. I used it a lot. Might something had changed with it?

Last edited by xerxes_ (2019-11-08 21:10:57)

Offline

#6 2019-11-08 21:16:18

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,119
Website

Re: [SOLVED] Package auto completion with option don't work in new pacman

Allan wrote:

-Ss won't complete anything.  How is you shell supposed to know what you are searching for?


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#7 2019-11-08 21:26:08

xerxes_
Member
Registered: 2018-04-29
Posts: 108

Re: [SOLVED] Package auto completion with option don't work in new pacman

Alan wrote:

-Ss won't complete anything.  How is you shell supposed to know what you are searching for?

I don't know how it is supposed to know or work, but I remember it worked. But nevermind, at least with options -Si, -Qi, -Ql it works, so it's enough for me. I make thread solved.

Last edited by xerxes_ (2019-11-08 21:47:08)

Offline

Board footer

Powered by FluxBB