You are not logged in.

#1 2019-11-10 21:41:54

astrionn
Member
Registered: 2019-10-17
Posts: 4

[SOLVED] No bootable device on uefi boot

Hello there,

I had to redo my boot layout since I discovered in the wiki that the bios firmware of my device is full of bugs - the recommendation is to use UEFI.(https://wiki.archlinux.org/index.php/Ac … E11_Series)
I tried setting up uefi boot but i get the error message 'no bootable device' on boot.

I have attached fdisk output, fstab and grub.cfg , please let me know if I need to provide more info!

Edit: The solution was to use the --removable flag when running the grub install command

I added the output of 

efibootmgr -v

while chrooted :

BootCurrent: 0000
Timeout: 2 seconds
BootOrder: 2001,2002,2003
Boot0000* USB HDD: KingstonDataTraveler G3	PciRoot(0x0)/Pci(0x14,0x0)/USB(0,0)/HD(1,MBR,0x65cc13ea,0xa4,0x20000)RC
Boot0001* GRUB	HD(1,GPT,42062336-e8ce-a843-bd67-32ce1ff34026,0x800,0x100000)/File(\EFI\GRUB\grubx64.efi)
Boot2001* EFI USB Device	RC
Boot2002* EFI DVD/CDROM	RC
Boot2003* EFI Network	RC

See the outut of

fdisk -l /dev/sda

:

Disk /dev/sda: 465.78 GiB, 500107862016 bytes, 976773168 sectors
Disk model: ST500LT012-1DG14
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: C33C2531-EB4D-FF41-9A8B-68AEF6D78E90

Device        Start       End   Sectors   Size Type
/dev/sda1      2048   1050623   1048576   512M EFI System
/dev/sda2   1050624  68159487  67108864    32G Linux root (x86-64)
/dev/sda3  68159488  84936703  16777216     8G Linux swap
/dev/sda4  84936704 976773134 891836431 425.3G Linux filesystem

See my fstab:

# /dev/sda2
UUID=97c5219d-45ee-44c8-bee1-917b9527dde6	/         	ext4      	rw,relatime	0 1

# /dev/sda1
UUID=AD09-88FF      	/boot/efi 	vfat      	rw,relatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,utf8,errors=remount-ro	0 2

# /dev/sda4
UUID=3556658d-232c-47c8-b32b-ed4b38d85b86	/data     	ext4      	rw,relatime	0 2

# /dev/sda3
UUID=ba176f20-05bf-4124-a67a-ee2931491a9f	none      	swap      	defaults  	0 0

See my grub.cfg :

#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#

### BEGIN /etc/grub.d/00_header ###
insmod part_gpt
insmod part_msdos
if [ -s $prefix/grubenv ]; then
  load_env
fi
if [ "${next_entry}" ] ; then
   set default="${next_entry}"
   set next_entry=
   save_env next_entry
   set boot_once=true
else
   set default="0"
fi

if [ x"${feature_menuentry_id}" = xy ]; then
  menuentry_id_option="--id"
else
  menuentry_id_option=""
fi

export menuentry_id_option

if [ "${prev_saved_entry}" ]; then
  set saved_entry="${prev_saved_entry}"
  save_env saved_entry
  set prev_saved_entry=
  save_env prev_saved_entry
  set boot_once=true
fi

function savedefault {
  if [ -z "${boot_once}" ]; then
    saved_entry="${chosen}"
    save_env saved_entry
  fi
}

function load_video {
  if [ x$feature_all_video_module = xy ]; then
    insmod all_video
  else
    insmod efi_gop
    insmod efi_uga
    insmod ieee1275_fb
    insmod vbe
    insmod vga
    insmod video_bochs
    insmod video_cirrus
  fi
}

if [ x$feature_default_font_path = xy ] ; then
   font=unicode
else
insmod part_gpt
insmod ext2
set root='hd0,gpt2'
if [ x$feature_platform_search_hint = xy ]; then
  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  97c5219d-45ee-44c8-bee1-917b9527dde6
else
  search --no-floppy --fs-uuid --set=root 97c5219d-45ee-44c8-bee1-917b9527dde6
fi
    font="/usr/share/grub/unicode.pf2"
fi

if loadfont $font ; then
  set gfxmode=auto
  load_video
  insmod gfxterm
  set locale_dir=$prefix/locale
  set lang=en_US
  insmod gettext
fi
terminal_input console
terminal_output gfxterm
if [ x$feature_timeout_style = xy ] ; then
  set timeout_style=menu
  set timeout=5
# Fallback normal timeout code in case the timeout_style feature is
# unavailable.
else
  set timeout=5
fi
### END /etc/grub.d/00_header ###

### BEGIN /etc/grub.d/10_linux ###
menuentry 'Arch Linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-simple-97c5219d-45ee-44c8-bee1-917b9527dde6' {
	load_video
	set gfxpayload=keep
	insmod gzio
	insmod part_gpt
	insmod ext2
	set root='hd0,gpt2'
	if [ x$feature_platform_search_hint = xy ]; then
	  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  97c5219d-45ee-44c8-bee1-917b9527dde6
	else
	  search --no-floppy --fs-uuid --set=root 97c5219d-45ee-44c8-bee1-917b9527dde6
	fi
	echo	'Loading Linux linux ...'
	linux	/boot/vmlinuz-linux root=UUID=97c5219d-45ee-44c8-bee1-917b9527dde6 rw  loglevel=3 quiet
	echo	'Loading initial ramdisk ...'
	initrd	/boot/initramfs-linux.img
}
submenu 'Advanced options for Arch Linux' $menuentry_id_option 'gnulinux-advanced-97c5219d-45ee-44c8-bee1-917b9527dde6' {
	menuentry 'Arch Linux, with Linux linux' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-advanced-97c5219d-45ee-44c8-bee1-917b9527dde6' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  97c5219d-45ee-44c8-bee1-917b9527dde6
		else
		  search --no-floppy --fs-uuid --set=root 97c5219d-45ee-44c8-bee1-917b9527dde6
		fi
		echo	'Loading Linux linux ...'
		linux	/boot/vmlinuz-linux root=UUID=97c5219d-45ee-44c8-bee1-917b9527dde6 rw  loglevel=3 quiet
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initramfs-linux.img
	}
	menuentry 'Arch Linux, with Linux linux (fallback initramfs)' --class arch --class gnu-linux --class gnu --class os $menuentry_id_option 'gnulinux-linux-fallback-97c5219d-45ee-44c8-bee1-917b9527dde6' {
		load_video
		set gfxpayload=keep
		insmod gzio
		insmod part_gpt
		insmod ext2
		set root='hd0,gpt2'
		if [ x$feature_platform_search_hint = xy ]; then
		  search --no-floppy --fs-uuid --set=root --hint-ieee1275='ieee1275//disk@0,gpt2' --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-baremetal=ahci0,gpt2  97c5219d-45ee-44c8-bee1-917b9527dde6
		else
		  search --no-floppy --fs-uuid --set=root 97c5219d-45ee-44c8-bee1-917b9527dde6
		fi
		echo	'Loading Linux linux ...'
		linux	/boot/vmlinuz-linux root=UUID=97c5219d-45ee-44c8-bee1-917b9527dde6 rw  loglevel=3 quiet
		echo	'Loading initial ramdisk ...'
		initrd	/boot/initramfs-linux-fallback.img
	}
}

### END /etc/grub.d/10_linux ###

### BEGIN /etc/grub.d/20_linux_xen ###
### END /etc/grub.d/20_linux_xen ###

### BEGIN /etc/grub.d/30_os-prober ###
### END /etc/grub.d/30_os-prober ###

### BEGIN /etc/grub.d/40_custom ###
# This file provides an easy way to add custom menu entries.  Simply type the
# menu entries you want to add after this comment.  Be careful not to change
# the 'exec tail' line above.
### END /etc/grub.d/40_custom ###

### BEGIN /etc/grub.d/41_custom ###
if [ -f  ${config_directory}/custom.cfg ]; then
  source ${config_directory}/custom.cfg
elif [ -z "${config_directory}" -a -f  $prefix/custom.cfg ]; then
  source $prefix/custom.cfg;
fi
### END /etc/grub.d/41_custom ###

Last edited by astrionn (2019-11-11 07:41:08)

Offline

#2 2019-11-11 01:34:23

jonno2002
Member
Registered: 2016-11-21
Posts: 75

Re: [SOLVED] No bootable device on uefi boot

did you follow this correctly: https://wiki.archlinux.org/index.php/GRUB#UEFI_systems

did you make sure the efi partition was mounted when you installed the efi bootloader

also sometimes using the --removable flag helps as it puts the bootloader in esp/EFI/BOOT/BOOTX64.EFI which seems to work better in my experience

Offline

#3 2019-11-11 01:56:49

kermit63
Member
Registered: 2018-07-04
Posts: 12

Re: [SOLVED] No bootable device on uefi boot

please add the output of "efibootmgr -v" to the original post.

Offline

#4 2019-11-11 07:28:12

astrionn
Member
Registered: 2019-10-17
Posts: 4

Re: [SOLVED] No bootable device on uefi boot

I have added efibootmgr -v output

Last edited by astrionn (2019-11-11 07:29:08)

Offline

#5 2019-11-11 07:40:04

astrionn
Member
Registered: 2019-10-17
Posts: 4

Re: [SOLVED] No bootable device on uefi boot

jonno2002 wrote:

did you follow this correctly: https://wiki.archlinux.org/index.php/GRUB#UEFI_systems

did you make sure the efi partition was mounted when you installed the efi bootloader

also sometimes using the --removable flag helps as it puts the bootloader in esp/EFI/BOOT/BOOTX64.EFI which seems to work better in my experience

I'm pretty sure I did.
I mounted it to /boot/efi of /mnt which is my sda2.

But hey the removable flag worked ! ty

Offline

Board footer

Powered by FluxBB