You are not logged in.

#1 2019-11-15 05:20:51

nemonik
Member
Registered: 2019-11-15
Posts: 10

[Solved] python3.8 update and now pip broke

 
➜  ~ sudo pacman -Q python-pip
python-pip 19.2.3-3

➜  ~ sudo pacman -Q python    
python 3.8.0-1

➜  ~ sudo pacman -Syu                                           
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib-testing is up to date
 archlinuxfr is up to date
:: Starting full system upgrade...
 there is nothing to do


➜  ~ pip list
Traceback (most recent call last):
  File "/usr/bin/pip", line 11, in <module>
    load_entry_point('pip==19.2.3', 'console_scripts', 'pip')()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 489, in load_entry_point
    return get_distribution(dist).load_entry_point(group, name)
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2852, in load_entry_point
    return ep.load()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2443, in load
    return self.resolve()
  File "/usr/lib/python3.8/site-packages/pkg_resources/__init__.py", line 2449, in resolve
    module = __import__(self.module_name, fromlist=['__name__'], level=0)
  File "/usr/lib/python3.8/site-packages/pip/_internal/__init__.py", line 40, in <module>
    from pip._internal.cli.autocompletion import autocomplete
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/autocompletion.py", line 8, in <module>
    from pip._internal.cli.main_parser import create_main_parser
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/main_parser.py", line 7, in <module>
    from pip._internal.cli import cmdoptions
  File "/usr/lib/python3.8/site-packages/pip/_internal/cli/cmdoptions.py", line 24, in <module>
    from pip._internal.models.search_scope import SearchScope
  File "/usr/lib/python3.8/site-packages/pip/_internal/models/search_scope.py", line 11, in <module>
    from pip._internal.utils.misc import normalize_path, redact_password_from_url
  File "/usr/lib/python3.8/site-packages/pip/_internal/utils/misc.py", line 24, in <module>
    from pip._vendor.retrying import retry  # type: ignore
ModuleNotFoundError: No module named 'pip._vendor.retrying'

Anyone else seeing this?

The non-obvious solution -- Well, at least initially upfront to me and therefore the reason why I asked for help. -- turns out to be

pacman -S $(pacman -Qqo /usr/lib/python3.8/)

To query for what packages own (i.e., change the contents of) the path /usr/lib/python3.8/ (For me with a 2 day old install, this was 117 packages.) and then synchronize these packages thereby removing problem.

I also removed unneeded multilib-test repo and archfr repos by commenting them the first and deleting the second out of my pacman.conf and then executing

pacman -Suu

to synchronize enabling both upgrades and down grades.  This one is a bit more unobvious to me, but this is the command the documentation tells you to do.

Thank you to those who responded graciously  offering their assistance.

Last edited by nemonik (2019-11-16 05:02:38)

Offline

#2 2019-11-15 08:53:31

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: [Solved] python3.8 update and now pip broke

Please use [ code ] [ /code ] tags for pasting outputs.

type -a pip

Last edited by V1del (2019-11-15 08:53:43)

Offline

#3 2019-11-15 11:09:47

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,455

Re: [Solved] python3.8 update and now pip broke

core is up to date
extra is up to date
community is up to date
multilib-testing is up to date
archlinuxfr is up to date

your pacman.conf repo-list shows atleast 2 issues that could cause big problems :

- archlinuxfr - yaourt stopped being maintained several years ago, what do you need from archlinuxfr repo ?

- You only have multilib-testing enabled and not the other testing repos, that is a very bad idea.
Check the colored box at https://wiki.archlinux.org/index.php/Of … positories


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#4 2019-11-15 12:34:26

Kwelity
Member
Registered: 2019-11-15
Posts: 2

Re: [Solved] python3.8 update and now pip broke

I'm also seeing the same error.

I'm not using archlinuxfr nor mutlitib-testing though.

Offline

#5 2019-11-15 12:54:52

ritze
Member
Registered: 2012-11-10
Posts: 8

Re: [Solved] python3.8 update and now pip broke

Same error for me after updating.

type -a pip:

pip is /bin/pip
pip is /usr/bin/pip

pacman -Syu:

 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date

Offline

#6 2019-11-15 13:28:48

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: [Solved] python3.8 update and now pip broke

Are any of you holding back python-msgpack for some reason? Don't do that. Otherwise

python -c 'import pip._vendor.cachecontrol; print(repr(pip._vendor.cachecontrol))'

you might want to look through some things posted here: https://www.reddit.com/r/archlinux/comm … ositories/

Also general disclaimer, do not ever install pip packages system wide and doubly so if the package in question already exists as a pacman package, you will break something.

Offline

#7 2019-11-15 14:00:59

ritze
Member
Registered: 2012-11-10
Posts: 8

Re: [Solved] python3.8 update and now pip broke

V1del wrote:

you might want to look through some things posted here: https://www.reddit.com/r/archlinux/comm … ositories/

That's it! I've a private python library which I configured with python-setuptools, build a package and installed it through pacman. I had to rebuild the pacman package.

Thanks a lot.

Offline

#8 2019-11-15 15:22:24

FirefighterBlu3
Member
Registered: 2015-02-27
Posts: 10

Re: [Solved] python3.8 update and now pip broke

reinstall the python-retrying package, you'll likely need to reinstall the python-progress and more, look at the /usr/lib/python3.8/site-packages/pip/_vendor/__init__.py file for hints

when something gets installed and it appears to still break, load up idle and try to import it by hand to see what secondary module is breaking the original import

aka, python-html5lib will depend on python-webencodings

Last edited by FirefighterBlu3 (2019-11-15 15:25:11)

Offline

#9 2019-11-15 16:40:14

Kwelity
Member
Registered: 2019-11-15
Posts: 2

Re: [Solved] python3.8 update and now pip broke

V1del wrote:

you might want to look through some things posted here: https://www.reddit.com/r/archlinux/comm … ositories/

Also general disclaimer, do not ever install pip packages system wide and doubly so if the package in question already exists as a pacman package, you will break something.

yay -S $(yay -Qqo /usr/lib/python3.8/)

fixed it for me.

Thanks!

Offline

#10 2019-11-15 18:05:10

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

@V1del i'm using code markup now... markdown is a habit.

@Lone_Wolf the link you provided had guidance for disDisabling testing repositories

If you enabled testing repositories, but later on decided to disable them, you should:

Remove (comment out) them from /etc/pacman.conf
Perform a pacman -Syuu to "rollback" your updates from these repositories.
The second item is optional, but keep it in mind if you notice any problems.abling the testing repos if no longer needed... Well, I don't need them

but the

pacman -Syuu

fails with

➜  ~ sudo pacman -Syuu
[sudo] password for nemonik: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: failed to update multilib-testing (no servers configured for repository)
error: failed to synchronize all databases

any idea how to fix?

this didn't work either

➜  ~ sudo pacman -Sc  
Packages to keep:
  All locally installed packages

Cache directory: /var/cache/pacman/pkg/
:: Do you want to remove all other packages from cache? [Y/n] y
removing old packages from cache...

Database directory: /var/lib/pacman/
:: Do you want to remove unused repositories? [Y/n] y
removing unused sync repositories...
➜  ~ sudo pacman -Syu 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: failed to update multilib-testing (no servers configured for repository)
error: failed to synchronize all databases

nor did

➜  ~ ls /var/lib/pacman/sync 
community.db  community.files  core.db  core.files  extra.db  extra.files  multilib-testing.db  multilib-testing.files
➜  ~ sudo mv /var/lib/pacman/sync/multilib-testing.db /tmp/.
➜  ~ sudo mv /var/lib/pacman/sync/multilib-testing.files /tmp/. 
➜  ~ sudo pacman -Syu                                       
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: failed to update multilib-testing (no servers configured for repository)
error: failed to synchronize all databases

Last edited by nemonik (2019-11-15 18:12:43)

Offline

#11 2019-11-15 18:16:25

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,495

Re: [Solved] python3.8 update and now pip broke

You need to comment out the entire section - the [multilib-testing] line as well.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#12 2019-11-15 18:38:09

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

i did.

[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

i think i read too much into the docs... the second command is in fact optional and you have to do a system update like so

➜  ~ sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (5) dhcpcd-8.1.2-1  docker-1:19.03.5-1  ghostscript-9.50-2  libreoffice-fresh-6.3.3-1  python-astroid-2.3.3-1

Total Download Size:   179.37 MiB
Total Installed Size:  626.54 MiB
Net Upgrade Size:       18.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 dhcpcd-8.1.2-1-x86_64                        170.2 KiB   164 KiB/s 00:01 [##########################################] 100%
 ghostscript-9.50-2-x86_64                     12.6 MiB   285 KiB/s 00:45 [##########################################] 100%

i think and this looks like it will resolve things once complete.

Last edited by nemonik (2019-11-15 18:38:57)

Offline

#13 2019-11-15 18:45:48

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

And nope

➜  ~ sudo pacman -Su
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (5) dhcpcd-8.1.2-1  docker-1:19.03.5-1  ghostscript-9.50-2  libreoffice-fresh-6.3.3-1  python-astroid-2.3.3-1

Total Download Size:   179.37 MiB
Total Installed Size:  626.54 MiB
Net Upgrade Size:       18.01 MiB

:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 dhcpcd-8.1.2-1-x86_64                        170.2 KiB   164 KiB/s 00:01 [##########################################] 100%
 ghostscript-9.50-2-x86_64                     12.6 MiB   285 KiB/s 00:45 [##########################################] 100%
 libreoffice-fresh-6.3.3-1-x86_64             129.5 MiB   236 KiB/s 09:21 [##########################################] 100%
 python-astroid-2.3.3-1-any                   268.1 KiB   494 KiB/s 00:01 [##########################################] 100%
 docker-1:19.03.5-1-x86_64                     36.8 MiB   334 KiB/s 01:53 [##########################################] 100%
(5/5) checking keys in keyring                                            [##########################################] 100%
(5/5) checking package integrity                                          [##########################################] 100%
(5/5) loading package files                                               [##########################################] 100%
(5/5) checking for file conflicts                                         [##########################################] 100%
(5/5) checking available disk space                                       [##########################################] 100%
:: Processing package changes...
(1/5) upgrading dhcpcd                                                    [##########################################] 100%
(2/5) upgrading docker                                                    [##########################################] 100%
(3/5) upgrading ghostscript                                               [##########################################] 100%
(4/5) upgrading libreoffice-fresh                                         [##########################################] 100%
(5/5) upgrading python-astroid                                            [##########################################] 100%
:: Running post-transaction hooks...
(1/7) Creating system user accounts...
(2/7) Reloading system manager configuration...
(3/7) Reloading device manager configuration...
(4/7) Arming ConditionNeedsUpdate...
(5/7) Updating icon theme caches...
(6/7) Updating the desktop file MIME type cache...
(7/7) Updating the MIME type database...
➜  ~ sudo pacman -Suy
[sudo] password for mjwalsh: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
error: failed to update multilib-testing (no servers configured for repository)
error: failed to synchronize all databases

odd the auto acknowledge

-y

would break it

Last edited by nemonik (2019-11-15 18:47:01)

Offline

#14 2019-11-15 18:55:18

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

my mirrorlist was generated from https://www.archlinux.org/mirrorlist/ fir my region.

Offline

#15 2019-11-15 19:11:50

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,495

Re: [Solved] python3.8 update and now pip broke

nemonik wrote:

i did.

[multilib-testing]
#Include = /etc/pacman.d/mirrorlist

You clearly didn't. I repeat - you need to comment out the [multilib-testing] line as well.

And yes, you do need to run a....

pacman -Syuu

No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#16 2019-11-15 21:52:04

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

Dooh.  Thank you.

Offline

#17 2019-11-15 23:15:41

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

yay -S $(yay -Qqo /usr/lib/python3.8/)

Fixed my problem too... I had yay installed.

Offline

#18 2019-11-16 00:40:47

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,395
Website

Re: [Solved] python3.8 update and now pip broke

This is ... absolutely ... f****ing absurd.

Yay is completely irrelevant in that command.  That should be just the following:

pacman -S $(pacman -Qqo /usr/lib/python3.8/)

Yay just happens to be a pacman wrapper, so that is precisely what it does when you enter the yay command.  If you do not understand this - and if even for a split second you thought 'yay' might actually be needed to follow that solution - then stop using yay immediately.

Last edited by Trilby (2019-11-16 00:41:16)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#19 2019-11-16 04:16:23

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

@Trilby I am two days into Arch after getting it installed with a dual boot with win 10 and grub.  Just two days. The gist of your message makes complete sense on reflection, but your delivery on a newbie forum is lacking.

Offline

#20 2019-11-16 04:21:19

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,395
Website

Re: [Solved] python3.8 update and now pip broke

If you have stopped using yay (or any aur helper for now), then consider the discomfort stemming from my delivery like the discomfort of being forcefully and abruptly shoved out of the way of oncoming traffic.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#21 2019-11-16 04:22:45

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

If anything it taught me.

Offline

#22 2019-11-16 04:23:30

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,157
Website

Re: [Solved] python3.8 update and now pip broke

nemonik wrote:

@Trilby I am two days into Arch after getting it installed with a dual boot with win 10 and grub.  Just two days. The gist of your message makes complete sense on reflection, but your delivery on a newbie forum is lacking.

You didn't post in Newbie Corner. You posted in the pacman forum, which is the Arch package manager.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#23 2019-11-16 04:27:09

nemonik
Member
Registered: 2019-11-15
Posts: 10

Re: [Solved] python3.8 update and now pip broke

I see, that makes your delivery okay then.  Again, you have taught me something. Tip of the hat to you dear sir.

Offline

#24 2019-11-16 04:30:09

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,157
Website

Re: [Solved] python3.8 update and now pip broke

Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB