You are not logged in.

#1 2019-11-16 11:00:04

xunil36
Member
Registered: 2017-03-12
Posts: 19

libglvnd, lib32-libglvnd: Errors occurred, no packages were upgraded.

When trying to update, I get the following error message:

Can anyone help me resolving this? Thanks!

Packages (2) lib32-libglvnd-1.2.0-3  libglvnd-1.2.0-5

Total Download Size:   0.45 MiB
Total Installed Size:  4.71 MiB
Net Upgrade Size:      1.99 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 libglvnd-1.2.0-5-x86_64                                                                                           307.2 KiB  3.61 MiB/s 00:00 [#######################################################################################] 100%
 lib32-libglvnd-1.2.0-3-x86_64                                                                                     153.1 KiB  37.4 MiB/s 00:00 [#######################################################################################] 100%
(2/2) checking keys in keyring                                                                                                                 [#######################################################################################] 100%
(2/2) checking package integrity                                                                                                               [#######################################################################################] 100%
(2/2) loading package files                                                                                                                    [#######################################################################################] 100%
(2/2) checking for file conflicts                                                                                                              [#######################################################################################] 100%
error: failed to commit transaction (conflicting files)
libglvnd: /usr/include/EGL/egl.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/EGL/eglext.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/EGL/eglplatform.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GL/gl.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GL/glcorearb.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GL/glext.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GL/glx.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GL/glxext.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES2/gl2.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES2/gl2ext.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES2/gl2platform.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES3/gl3.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES3/gl31.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES3/gl32.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/GLES3/gl3platform.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/include/KHR/khrplatform.h exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/lib/pkgconfig/egl.pc exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/lib/pkgconfig/gl.pc exists in filesystem (owned by mesa-noglvnd)
libglvnd: /usr/lib/pkgconfig/glesv2.pc exists in filesystem (owned by mesa-noglvnd)
lib32-libglvnd: /usr/lib32/pkgconfig/egl.pc exists in filesystem (owned by lib32-mesa-noglvnd)
lib32-libglvnd: /usr/lib32/pkgconfig/gl.pc exists in filesystem (owned by lib32-mesa-noglvnd)
lib32-libglvnd: /usr/lib32/pkgconfig/glesv2.pc exists in filesystem (owned by lib32-mesa-noglvnd)
Errors occurred, no packages were upgraded.

Offline

#2 2019-11-16 12:22:00

xerxes_
Member
Registered: 2018-04-29
Posts: 135

Re: libglvnd, lib32-libglvnd: Errors occurred, no packages were upgraded.

Offline

#3 2019-11-16 12:29:55

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,455

Re: libglvnd, lib32-libglvnd: Errors occurred, no packages were upgraded.

libglvnd: /usr/include/EGL/egl.h exists in filesystem (owned by mesa-noglvnd)

AUR mesa-noglvnd can't be coexist with libglvnd (it should probably conflict libglvnd ) .

In order to use libglvnd you would have to replace mesa-noglvnd with extra/mesa .

Why do you use mesa-noglvnd ?


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB