You are not logged in.

#1 2019-11-14 22:27:10

Danya
Member
Registered: 2019-11-14
Posts: 7

[SOLVED] icu-65.1-2 upgrade prevents gdm from loading

After doing a Syu today I was greeted with a black screen on reboot instead of gdm. I can still ctl-alt-f2 and login as usual. Downgrading icu-65.1-2 to icu-64.2-1 resolves this issue. The issues was recreated on a different laptop.

Last edited by Danya (2019-11-16 16:44:19)

Offline

#2 2019-11-15 09:15:31

ayekat
Member
Registered: 2011-01-17
Posts: 1,359
Website

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

What's the output of this?

pacman -Qm

{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#3 2019-11-15 11:34:43

hifi25nl
Member
Registered: 2011-05-07
Posts: 240
Website

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

I have the same problem, black screen on reboot after updating icu. sddm service failed.
Downgrading to icu-64.2-1 did resolve the problem.

I am re-trying now a full update and I have this error:

/usr/bin/update-mime-database: error while loading shared libraries: libicuuc.so.64: cannot open shared object file: No such file or directory
error: command failed to execute correctly

Offline

#4 2019-11-15 12:51:36

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

re Ayekat

The command "pacman -Qm" returns nothing on laptop B and on Laptop A it returns the following:

t4kcommon 0.1.1-4
tuxmath 2.0.3-1

Some background that may help.

I have a limited amount of gigabytes that I can download per month and so I transfer downloaded packages from the /var/cache/pacman/pkg directory between laptops. The last time I did it I also transferred the db files found in /var/lib/pacman/sync directory form Laptop A to Laptop B. The install on both laptops are relatively new; about a week.

Also note that on one of the laptops (laptop A)  when I logged in through the command prompt on tty2 I observed the same libicuuc error message member hifi25nl mentions in his comment

Offline

#5 2019-11-15 13:23:45

ayekat
Member
Registered: 2011-01-17
Posts: 1,359
Website

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

Alright, looking at the package build dates for shared-mime-info (2019-10-30), gdm (2019-10-07) and sddm (2019-03-31), it looks like the new libicu has been pushed to the repos without any of those depending packages getting a rebuild.

In my books, that's a bug, but I'm not authorised to decide what's a bug and what isn't, so I'll let someone else chime in here. Turns out (after checking with lddtree instead of just ldd, as suggested below) that these packages do not directly depend on libicuuc.so.

Last edited by ayekat (2019-11-15 15:05:21)


{,META,RE}PKGBUILDSpacman-hacks (includes makemetapkg and remakepkg) │ dotfiles

Offline

#6 2019-11-15 13:34:11

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,330

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

Since nothing in those packages is linked to icu, no, it's not a bug.

For anyone seeing problems like this, install the pax-utils package and check the problem binary with lddtree. See where the actual problem is. It's almost always a partial update or something installed outside of the Arch repos.

Last edited by Scimmia (2019-11-15 13:38:23)

Online

#7 2019-11-15 13:37:51

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

The common dependency for shared-mime-info is libxml2 which has a dep on icu which got rebuilt.

pacman -Q libxml2
lddtree /usr/bin/update-mime-database #Needs pax-utils

maybe also share your pacman logs and double and triple check your mirrors.

Offline

#8 2019-11-15 13:39:12

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

re Ayekat.

Thank you for looking into it and for your time.
As a side note, I enjoyed reading your latest article from your website. I look forward to reading more of them.

Thanks Again,

Danny

Offline

#9 2019-11-15 13:52:24

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

re V1del and Scimmia

I'll see if I can do what you suggest later on today and get back to you. Thanks.

Last edited by Danya (2019-11-15 14:28:31)

Offline

#10 2019-11-15 15:27:13

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

re ayekay

A quick correction for now. I previously stated that "I observed the same libicuuc error message member hifi25nl mentions in his comment."  This is not accurate. My error was a little different. I got:

"flatpak: error while loading shared libraries: libicuuc.so.64: cannot open shared object file: No such file or directory"

Running lddtree on flatpak after upgrading icu gives me the following snippet
"
. . .

libxml2.so.2 => /usr/lib/libxml2.so.2
        libicuuc.so.64 => None
. . .
"

Is that anything useful?

Last edited by Danya (2019-11-15 16:05:53)

Offline

#11 2019-11-15 16:05:27

hifi25nl
Member
Registered: 2011-05-07
Posts: 240
Website

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

This is the output of lddtree for sddm:

lddtree /usr/bin/sddm
/usr/bin/sddm (interpreter => /lib64/ld-linux-x86-64.so.2)
    libQt5DBus.so.5 => /usr/lib/libQt5DBus.so.5
        libpthread.so.0 => /usr/lib/libpthread.so.0
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3
    libQt5Qml.so.5 => /usr/lib/libQt5Qml.so.5
        libdl.so.2 => /usr/lib/libdl.so.2
        libm.so.6 => /usr/lib/libm.so.6
    libsystemd.so.0 => /usr/lib/libsystemd.so.0
        librt.so.1 => /usr/lib/librt.so.1
        liblzma.so.5 => /usr/lib/liblzma.so.5
        liblz4.so.1 => /usr/lib/liblz4.so.1
        libgcrypt.so.20 => /usr/lib/libgcrypt.so.20
            libgpg-error.so.0 => /usr/lib/libgpg-error.so.0
    libQt5Network.so.5 => /usr/lib/libQt5Network.so.5
        libz.so.1 => /usr/lib/libz.so.1
        libssl.so.1.1 => /usr/lib/libssl.so.1.1
        libcrypto.so.1.1 => /usr/lib/libcrypto.so.1.1
    libQt5Core.so.5 => /usr/lib/libQt5Core.so.5
        libicui18n.so.64 => /usr/lib/libicui18n.so.64
        libicuuc.so.64 => /usr/lib/libicuuc.so.64
            libicudata.so.64 => /usr/lib/libicudata.so.64
        libpcre2-16.so.0 => /usr/lib/libpcre2-16.so.0
        libdouble-conversion.so.3 => /usr/lib/libdouble-conversion.so.3
        libzstd.so.1 => /usr/lib/libzstd.so.1
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0
            libpcre.so.1 => /usr/lib/libpcre.so.1
    libstdc++.so.6 => /usr/lib/libstdc++.so.6
    libgcc_s.so.1 => /usr/lib/libgcc_s.so.1
    libc.so.6 => /usr/lib/libc.so.6

Offline

#12 2019-11-15 16:15:54

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

You have to post that from the broken setup for it to actually be conclusive, but anyway: both qt5-base and libxml2 have received updated packages, pay attention during the update (you did run a -Syu did you?)  you should get 5.13.1-2 and 2.9.9-6 respectively. If you don't, your mirrors are broken, pick one close to your location, a reasonable delay time, and a completion of 100%

Last edited by V1del (2019-11-15 16:20:00)

Offline

#13 2019-11-15 16:42:16

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

re V1del

Yes the snippet is from the  broken setup and I ran -Syu several times  but my libxml2 package is still on 2.9.9-3.   I'll check my mirrors.

Last edited by Danya (2019-11-15 16:43:02)

Offline

#14 2019-11-15 18:14:05

Danya
Member
Registered: 2019-11-14
Posts: 7

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

Yes, after changing mirrors and running Syu again I now have 135 packages that need to be upgraded, including libxml2. Thanks everybody here for your guidance and assistance.

Danny

Offline

#15 2019-11-16 12:45:08

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,455

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

Danya wrote:

I have a limited amount of gigabytes that I can download per month and so I transfer downloaded packages from the /var/cache/pacman/pkg directory between laptops.

There may be better solutions, I suggest you read https://wiki.archlinux.org/index.php/Pa … cman_cache


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#16 2019-11-16 12:58:23

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: [SOLVED] icu-65.1-2 upgrade prevents gdm from loading

@Danya yes your command was correct, mine was refering to hifi25nl , sorry if you thought this was referring to your post. Please mark the topic as [SOLVED] by editing the title in your first post: https://wiki.archlinux.org/index.php/Co … ow_to_post

Offline

Board footer

Powered by FluxBB