You are not logged in.

#1 2019-11-11 17:47:03

Beuman
Member
Registered: 2018-06-10
Posts: 8

[SOLVED] Compile Unreal Engine with older clang version

Hello there.

I cannot compile unreal engine from the AUR. I'm having an issue saying that I'm using 9.0.0 version and that I should use the 8.0.0

Is there a way to downgrade that package, or install another older version and explicitly ask to use that version instead during compilation ?

Thanks in advance

Last edited by Beuman (2019-12-05 04:09:43)

Offline

#2 2019-11-11 18:00:39

progandy
Member
Registered: 2012-05-17
Posts: 3,597

Re: [SOLVED] Compile Unreal Engine with older clang version

You should read the comments.
https://aur.archlinux.org/packages/unre … ent-711910

Otherwise you can take the clang6 PKGBUILD from the AUR and modify it for clang7, then modify the unreal engine pkgbuild so that it uses this version.

Last edited by progandy (2019-11-11 18:02:57)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#3 2019-11-17 05:18:42

Beuman
Member
Registered: 2018-06-10
Posts: 8

Re: [SOLVED] Compile Unreal Engine with older clang version

Thanks
I followed instructions here successfully :

https://wiki.unrealengine.com/Building_ … Arch_Linux

Offline

#4 2019-11-17 14:35:39

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 2,852

Re: [SOLVED] Compile Unreal Engine with older clang version

Please remember to mark your thread [SOLVED] (edit the title of your first post).

Offline

Board footer

Powered by FluxBB