You are not logged in.

#1 2019-09-21 03:13:07

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Hi, not sure if this is the place to ask about this, sorry in advance if it isn't.

After last update (which included Linux kernel) and reboot the fan seems to don't stop. This is what checked until now:

[dell@arch ~]$ uname -a
Linux arch 5.3.0-arch1-1-ARCH #1 SMP PREEMPT Mon Sep 16 03:29:01 UTC 2019 x86_64 GNU/Linux

[dell@arch ~]$ systemctl status fancontrol.service 
● fancontrol.service - Start fan control, if configured
   Loaded: loaded (/usr/lib/systemd/system/fancontrol.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Sat 2019-09-21 00:12:39 -03; 16s ago
           └─ ConditionFileNotEmpty=/etc/fancontrol was not met

sep 20 23:35:16 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:35:16 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.
sep 20 23:35:19 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:35:21 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:35:21 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.
sep 20 23:35:36 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:36:18 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:49:50 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 20 23:56:20 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.
sep 21 00:12:39 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.

[dell@arch ~]$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +68.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +68.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +67.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +67.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +67.0°C  (high = +86.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +74.0°C  (crit = +100.0°C)
temp2:        +74.0°C  (crit = +100.0°C)

nouveau-pci-0100
Adapter: PCI adapter
GPU core:     +0.98 V  (min =  +0.83 V, max =  +0.98 V)
temp1:        +69.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

System is essentially idle.

What should I do?

Thanks a lot.

Offline

#2 2019-09-21 07:36:11

d_fajardo
Member
Registered: 2017-07-28
Posts: 516

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

This seems to me a fairly high idle temp. Have you checked what processes are using the cpu on idle?

Offline

#3 2019-09-21 13:45:47

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

I have the same discrete GPU as you (GeForce GT 540M) and I can confirm that after upgrade to kernel 5.3 this GPU isn't powered down on idle anymore. It runs all the time and the temps are higher because of that. I think this is a kernel bug.

Last edited by Prymoo (2019-09-21 13:51:44)

Offline

#4 2019-09-22 01:48:24

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Can confirm that downgrading kernel seems to momentarily fix the temperature and noise/fan problem.

This was the situation with linux-5.3.arch1-1:

[dell@arch ~]$ systemctl status fancontrol.service 
● fancontrol.service - Start fan control, if configured
   Loaded: loaded (/usr/lib/systemd/system/fancontrol.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Sat 2019-09-21 19:28:28 -03; 1h 29min ago

sep 21 19:28:28 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.
sep 21 19:30:32 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.
sep 21 19:30:33 arch systemd[1]: /usr/lib/systemd/system/fancontrol.service:8: PIDFile= references a path below legacy directory /var/run/, updating /var/run/fancontrol.pid → /run/fancontrol.pid; please update the unit file accordingly.

[dell@arch ~]$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +71.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +71.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +68.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +68.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +68.0°C  (high = +86.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +74.0°C  (crit = +100.0°C)
temp2:        +74.0°C  (crit = +100.0°C)

nouveau-pci-0100
Adapter: PCI adapter
GPU core:     +0.98 V  (min =  +0.83 V, max =  +0.98 V)
temp1:        +72.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

Now, after,

[dell@arch ~]$ sudo pacman -U https://archive.archlinux.org/packages/l/linux/linux-5.2.14.arch2-1-x86_64.pkg.tar.xz

, and reboot, the temperature have lower values (under similar system load):

[dell@arch ~]$ sensors
nouveau-pci-0100
Adapter: PCI adapter
GPU core:     -0.02 V  (min =  +0.83 V, max =  +0.98 V)
temp1:         -0.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +54.0°C  (crit = +100.0°C)
temp2:        +54.0°C  (crit = +100.0°C)

coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +52.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +51.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +51.0°C  (high = +86.0°C, crit = +100.0°C)

But I don't know what should I do (if anything) about the fan:

[dell@arch ~]$ systemctl status fancontrol.service
● fancontrol.service - Start fan control, if configured
   Loaded: loaded (/usr/lib/systemd/system/fancontrol.service; enabled; vendor preset: disabled)
   Active: inactive (dead)
Condition: start condition failed at Sat 2019-09-21 20:59:39 -03; 1h 4min ago
           └─ ConditionFileNotEmpty=/etc/fancontrol was not met

sep 21 20:59:39 arch systemd[1]: Condition check resulted in Start fan control, if configured being skipped.

And during boot I had a warning so checked:

[dell@arch ~]$ systemctl status systemd-modules-load.service
● systemd-modules-load.service - Load Kernel Modules
   Loaded: loaded (/usr/lib/systemd/system/systemd-modules-load.service; static; vendor preset: disabled)
   Active: failed (Result: exit-code) since Sat 2019-09-21 20:59:29 -03; 1h 6min ago
     Docs: man:systemd-modules-load.service(8)
           man:modules-load.d(5)
  Process: 548 ExecStart=/usr/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE)
 Main PID: 548 (code=exited, status=1/FAILURE)

sep 21 20:59:17 arch systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
sep 21 20:59:17 arch systemd[1]: Failed to start Load Kernel Modules.
sep 21 20:59:26 arch systemd[1]: Starting Load Kernel Modules...
sep 21 20:59:26 arch systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
sep 21 20:59:26 arch systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
sep 21 20:59:26 arch systemd[1]: Failed to start Load Kernel Modules.
sep 21 20:59:29 arch systemd[1]: Starting Load Kernel Modules...
sep 21 20:59:29 arch systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1/FAILURE
sep 21 20:59:29 arch systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'.
sep 21 20:59:29 arch systemd[1]: Failed to start Load Kernel Modules.

Have no problem to wait for next/fixed kernel, but I really would thank any indication about what to do (if anything) about last two things (fancontrol.service status and systemd-modules-load.service status).

Thanks a lot again.

Offline

#5 2019-09-22 02:44:20

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Prymoo wrote:

I have the same discrete GPU as you (GeForce GT 540M) and I can confirm that after upgrade to kernel 5.3 this GPU isn't powered down on idle anymore. It runs all the time and the temps are higher because of that. I think this is a kernel bug.

Just in case, from 'sudo lshw':

*-display
                description: VGA compatible controller
                product: GF108M [GeForce GT 525M]
                vendor: NVIDIA Corporation
                physical id: 0
                bus info: pci@0000:01:00.0
                version: a1
                width: 64 bits
                clock: 33MHz
                capabilities: pm msi pciexpress vga_controller bus_master cap_list rom
                configuration: driver=nouveau latency=0
                resources: irq:42 memory:f0000000-f0ffffff memory:c0000000-cfffffff memory:d0000000-d1ffffff ioport:3000(size=128) memory:f1000000-f107ffff
        *-display
             description: VGA compatible controller
             product: 2nd Generation Core Processor Family Integrated Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 09
             width: 64 bits
             clock: 33MHz
             capabilities: msi pm vga_controller bus_master cap_list rom
             configuration: driver=i915 latency=0
             resources: irq:43 memory:f1400000-f17fffff memory:e0000000-efffffff ioport:4000(size=64) memory:c0000-dffff

Offline

#6 2019-09-22 08:12:59

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Check the contents of the VGA Switcheroo status file - after upgrade to 5.3 on my machine it looks like this (GPU stays active all the time):

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch

0:IGD:+:Pwr:0000:00:02.0
1:DIS-Audio: :DynPwr:0000:01:00.1
2:DIS: :DynPwr:0000:01:00.0

When running previous/LTS kernel, GPU is correctly put to sleep on idle:

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch

0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

I think this is the root cause of higher temperature and fan noise.

Offline

#7 2019-09-23 02:50:50

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

This is my situation right now:

[root@arch dell]# uname -a
Linux arch 5.2.14-arch2-1-ARCH #1 SMP PREEMPT Thu Sep 12 10:42:38 UTC 2019 x86_64 GNU/Linux
[root@arch dell]# cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

I just checked and there's already a 'linux-5.3.1.arch1-1' package available through 'pacman -Syu'.
Anyone know if this issue is fixed in it?
I'll try to test it soon.

Offline

#8 2019-09-23 09:02:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 7,973

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Offline

#9 2019-09-24 19:50:47

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

'linux 5.3.1.arch1-1' didn't solve the issue for me - system is still running hotter because of always-enabled discrete GPU.

Offline

#10 2019-09-26 17:48:23

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

I investigated a little bit and this is what I found.

Because of this commit (which was pulled in linux 5.3) there is now a new HDMI audio device on my machine.

lspci on linux-5.2.14.arch2-1:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

lspci on linux-5.3.1.arch1-1:

00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 04)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
01:00.0 3D controller: NVIDIA Corporation GF108M [GeForce GT 540M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)                                     <- NEW HDMI AUDIO DEVICE
02:00.0 Network controller: Broadcom Inc. and subsidiaries BCM4313 802.11bgn Wireless Network Adapter (rev 01)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)

This new audio device is picked up by snd_hda_intel module and configured to be disabled on idle by vga_switcheroo:

[    5.788154] snd_hda_intel 0000:00:1b.0: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    5.788395] snd_hda_intel 0000:01:00.1: enabling device (0000 -> 0002)
[    5.788494] snd_hda_intel 0000:01:00.1: Disabling MSI
[    5.788505] snd_hda_intel 0000:01:00.1: Handle vga_switcheroo audio client

Unfortunately this isn't working properly - HDMI audio device and dGPU are active all the time:

[root@plaptop ~]# cat /sys/kernel/debug/vgaswitcheroo/switch 
0:IGD:+:Pwr:0000:00:02.0
1:DIS-Audio: :DynPwr:0000:01:00.1
2:DIS: :DynPwr:0000:01:00.0

If I manually remove HDMI audio device, vga_switcheroo works fine again and dGPU is powered off properly.

[root@plaptop ~]# echo 1 > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/remove

[root@plaptop ~]# cat /sys/kernel/debug/vgaswitcheroo/switch 
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

@riveravaldez: Please, check if you're having simmilar issue. I think we should file a bug upstream.

Last edited by Prymoo (2019-09-26 18:19:32)

Offline

#11 2019-10-02 11:53:34

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

For anyone having similar issues - temporary workaround is to disable nvidia HDA using udev rule:

# Remove NVIDIA Audio devices, if present
ACTION=="add", SUBSYSTEM=="pci", ATTR{vendor}=="0x10de", ATTR{class}=="0x040300", ATTR{remove}="1"

source: http://download.nvidia.com/XFree86/Linu … sAndW6426e

Issue is currently investigated upstream: https://bugs.freedesktop.org/show_bug.cgi?id=75985

Offline

#12 2019-10-13 21:52:48

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Sorry for the delay.

This is the situation with kernel 5.3.5-arch1-1:

$ uname -a
Linux arch 5.3.5-arch1-1-ARCH #1 SMP PREEMPT Mon Oct 7 19:03:08 UTC 2019 x86_64 GNU/Linux

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: :DynPwr:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: :DynPwr:0000:01:00.0

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +69.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +69.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +67.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +68.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +66.0°C  (high = +86.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +64.0°C  (crit = +100.0°C)
temp2:        +64.0°C  (crit = +100.0°C)

nouveau-pci-0100
Adapter: PCI adapter
GPU core:     +0.98 V  (min =  +0.83 V, max =  +0.98 V)
temp1:        +73.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

The new line on lspci is:

01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev a1)

Temperature and fan noise keep high (and maybe going up).

Then I issued:

$ sudo echo 1 > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/remove

And this was the result:

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynPwr:0000:01:00.0

But nothing changed.

$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +72.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +72.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +69.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +69.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +66.0°C  (high = +86.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +74.0°C  (crit = +100.0°C)
temp2:        +74.0°C  (crit = +100.0°C)

nouveau-pci-0100
Adapter: PCI adapter
GPU core:     +0.98 V  (min =  +0.83 V, max =  +0.98 V)
temp1:        +75.0°C  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

So, I reinstalled kernel 5.2.14-arch2-1:

$ sudo pacman -U https://archive.archlinux.org/packages/l/linux/linux-5.2.14.arch2-1-x86_64.pkg.tar.xz
[sudo] password for dell: 
cargando los paquetes...
advertencia: revertiendo el paquete linux a una versión anterior (5.3.5.arch1-1 => 5.2.14.arch2-1)
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (1) linux-5.2.14.arch2-1

Tamaño total de la instalación:  77,68 MiB
Tamaño neto tras actualizar:    -1,14 MiB

:: ¿Continuar con la instalación? [S/n] 
(1/1) comprobando las claves del depósito          [######################] 100%
(1/1) verificando la integridad de los paquetes    [######################] 100%
(1/1) cargando los archivos de los paquetes        [######################] 100%
(1/1) comprobando conflictos entre archivos        [######################] 100%
(1/1) comprobando el espacio disponible en el ...  [######################] 100%
:: Procesando los cambios de los paquetes...
(1/1) desactualizando linux                        [######################] 100%
:: Ejecutando los «hooks» de posinstalación...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating linux module dependencies...
(3/3) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.2.14-arch2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
  -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
==> Starting build: 5.2.14-arch2-1-ARCH
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
==> WARNING: Possibly missing firmware for module: wd719x
==> WARNING: Possibly missing firmware for module: aic94xx
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
==> Image generation successful

And issued:

$ systemctl reboot

Which seemed to fail in some way, because instead of reboot it powered off the laptop.

I booted again and had a message of "failed to start Load kernel modules" or something similar, but the equipment went fine.

This was on dmesg:

acpi_call: version magic '5.3.5-arch1-1-ARCH SMP preempt mod_unload ' should be '5.2.14-arch2-1-ARCH SMP preempt mod_unload '

Don't know if relevant.

And this is my situation right now (updated system except for the kernel):

$ uname -a
Linux arch 5.2.14-arch2-1-ARCH #1 SMP PREEMPT Thu Sep 12 10:42:38 UTC 2019 x86_64 GNU/Linux

$ sudo pacman -Syu
[dell@arch ~]$ sudo pacman -Syu
[sudo] password for dell: 
:: Sincronizando las bases de datos de los paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
:: Iniciando actualización completa del sistema...
resolviendo dependencias...
buscando conflictos entre paquetes...

Paquetes (1) linux-5.3.5.arch1-1

Tamaño total de la instalación:  78,82 MiB
Tamaño neto tras actualizar:     1,14 MiB

:: ¿Continuar con la instalación? [S/n] n

$ lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:IGD:+:Pwr:0000:00:02.0
1:DIS: :DynOff:0000:01:00.0

Since the temperature didn't went down after the "echo 1 > .../remove" I assumed that that action didn't solved my problem, so didn't tested the last temporary workaround. Should I?

Right now everything seems to be working fine with the 5.2.14-arch2-1 kernel. Temperature seems normal.
This is really serious issue. The laptop can't be used with the newest kernel.
Thanks a lot.

Offline

#13 2019-10-15 22:39:52

R0AR
Member
Registered: 2018-12-25
Posts: 3

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

The problem still remains for linux-5.3.6-arch1-1
I have the exact problem and as a result, I'm stuck on linux-5.2.14.arch2-1
I have an HP-OMEN 15-ce001ne which has NVIDIA and Intel GPUs. I've been using this guide (under UPDATE AND NEW SOLUTION) to disable/enable NVIDIA GPU with bumblebee. Since 5.3.5, It seems like the NVIDIA GPU remains ON sometimes after boot which should not happen.
powertop show 2 important lines in 'Device stats':

100.0%        PCI Device: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile]
100.0%        PCI Device: NVIDIA Corporation GP107GL High Definition Audio Controller

Calling disableGPU script (from the guide) after boot will successfully power down the first one. But 'NVIDIA High Definition Audio Controller' was not present on linux-5.2.14.arch2-1 and it will not be disabled. I'm assuming that is the culprit which is keeping the laptop around 10°C hotter on idle!

Just wanted to update people who had the same problem. I'm gonna downgrade again to 5.2.14.arch2-1 until the problem is fixed.

Offline

#14 2019-10-28 16:29:10

kjozsa
Member
Registered: 2008-06-05
Posts: 119

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Hi, HP ZBook Studio user here fighting the same issue. Just a quick note:

[root@manta ~]# lspci | grep Audio
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
01:00.1 Audio device: NVIDIA Corporation Device 0fbc (rev a1)
[root@manta ~]# sudo echo 1 > /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.1/remove
[root@manta ~]# lspci | grep Audio
00:1f.3 Audio device: Intel Corporation CM238 HD Audio Controller (rev 31)
[root@manta ~]# 

and the fan stopped immediately smile

Offline

#15 2019-11-03 12:08:34

Prymoo
Member
Registered: 2015-04-28
Posts: 13

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Issue should be fixed in linux 5.3.8 - see this commit.

Also, make sure that power management control for NVIDIA HDA is set to "auto" and if it's not, set it with this command:

echo "auto" > /sys/bus/pci/devices/0000:01:00.1/power/control

Offline

#16 2019-11-12 21:58:47

riveravaldez
Member
Registered: 2016-11-18
Posts: 8

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

Hi, thanks a lot for all the help.

After check:

[dell@arch ~]$ cat /sys/bus/pci/devices/0000\:01\:00.1/power/control
auto

Upgraded the kernel:

[dell@arch ~]$ uname -a
Linux arch 5.3.10-arch1-1 #1 SMP PREEMPT Sun, 10 Nov 2019 11:29:38 +0000 x86_64 GNU/Linux

And issue seems solved - at least for now ;)

[dell@arch ~]$ sensors
coretemp-isa-0000
Adapter: ISA adapter
Package id 0:  +54.0°C  (high = +86.0°C, crit = +100.0°C)
Core 0:        +54.0°C  (high = +86.0°C, crit = +100.0°C)
Core 1:        +50.0°C  (high = +86.0°C, crit = +100.0°C)
Core 2:        +53.0°C  (high = +86.0°C, crit = +100.0°C)
Core 3:        +51.0°C  (high = +86.0°C, crit = +100.0°C)

acpitz-acpi-0
Adapter: ACPI interface
temp1:        +54.0°C  (crit = +100.0°C)
temp2:        +54.0°C  (crit = +100.0°C)

nouveau-pci-0100
Adapter: PCI adapter
GPU core:         N/A  (min =  +0.83 V, max =  +0.98 V)
temp1:            N/A  (high = +95.0°C, hyst =  +3.0°C)
                       (crit = +105.0°C, hyst =  +5.0°C)
                       (emerg = +135.0°C, hyst =  +5.0°C)

That was the usual temperature.

Also:

[dell@arch ~]$ sudo cat /sys/kernel/debug/vgaswitcheroo/switch
0:DIS-Audio: :DynOff:0000:01:00.1
1:IGD:+:Pwr:0000:00:02.0
2:DIS: :DynOff:0000:01:00.0

[dell@arch ~]$ lspci 
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM67 Express Chipset LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port Mobile SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108M [GeForce GT 525M] (rev a1)
01:00.1 Audio device: NVIDIA Corporation GF108 High Definition Audio Controller (rev ff)
03:00.0 Network controller: Intel Corporation Centrino Wireless-N 1030 [Rainbow Peak] (rev 34)
04:00.0 USB controller: NEC Corporation uPD720200 USB 3.0 Host Controller (rev 04)
06:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)

[dell@arch ~]$ sudo pacman -Syu
:: Sincronizando las bases de datos de los paquetes...
 core está actualizado
 extra está actualizado
 community está actualizado
:: Iniciando actualización completa del sistema...
...el sistema ya está actualizado.

Actual situation. System fully updated.

Any other info I could provide?
Should I add '[SOLVED]' to the subject?

Best regards!

Last edited by riveravaldez (2019-11-12 22:01:24)

Offline

#17 2019-11-12 23:09:10

R0AR
Member
Registered: 2018-12-25
Posts: 3

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

I have upgraded to 5.3.10-arch1-1 but the problem remains. NVIDIA still not getting automatically off and HDA remains 100%. I'm afraid that's not all. Even blacklisting snd_hda_intel which completely removes sound from the system and disables NVIDIA HDA doesn't fix the temperature issue.

My problem is probably this:

And the NVIDIA HDA is just a bonus problem.
I don't know if you should mark this SOLVED or not. It clearly works for some people.

Offline

#18 2019-11-18 19:35:12

ilcaap
Member
Registered: 2019-11-18
Posts: 1

Re: Fan doesn't stop on Dell XPS L502X after kernel-upgrade

English is not my native language, so please forgive me for my mistakes.

I had the same problem since I have done a full system update two days ago. I use HP 820 G2 and before I updated system I was able to use it about 6-7 hours on my standard daily tasks. After a system update I wasn't able even to achieve 6 hours on medium brightness when idle. I just have downgraded my kernel and I have to say that it is better now, but still not as good as it was before. I checked powertop output before and after kernel downgrade and idle power usage dropped from about 7-8 W to 5.5 with about 15% stronger backlight set. i7z still shows temperatures about 2 degrees higher than before the update, but I think my story may help you make a decision whether to mark it as solve or not.

If someone has to much time and want to read about my experience with other laptops and battery behaviours:
About three years before i had bought my first laptop - second hand Lenovo Thinkpad T430. I was using Windows 7 that time and I bought a bigger battery, which let it run even 9 hours without charging. I started using Arch at the beginning of 2018. Everything was working great except two parts: Trackpoint (it worked but about 4 times worse than under Windows) and battery (life). I was able to use it out of socket for about 6 hours (2/3 time of Windows running), but every month it was worse. For about 2 months I was using Dell Inspiron 5557 (which still works) and it has opposite battery life behaviour - it runs about 10% longer under Arch than under Windows 8 or 8.1. It was both heavy laptops (especially Thinkpad) and I have decided to buy new. I never used other laptops, I wanted something about 12-13 inches (or maybe 14 if it isn't heavy).
I have bought Lenovo X240 or X250. It got it with Windows 10 installed and after about 4 hours of use, I decided to install Arch on it. Immediately after installed booted, a fan started to run on I think 2500 rpm. I was disappointed because even after I installed all the stuff available on Linux to make it run normally I wasn't able to restore silence and temperatures. Even after I have booted Windows 10 (it was second hard drive I removed before reinstallation) laptop still was running on idle 45 degrees with continuous fan work. Showed by OS expected battery life dropped from 8 to 5 hours. I decided to give it back to the shop.
A week later I bought my current laptop - said HP 820 G2 - and the situation was the nearly same (but good enough I decided to use it for some time). I was using Win 10 for a few hours and after installing Arch I got higher temperatures and louder work but thankfully not when idle but when I use youtube, facebook etc. I set max cpu frequency to about 1.6 GHz and it work fine for me. Before I bought this HP, I was using my friend's HP 820 G1 with the worst specs but comparable build, motherboard etc. I didn't installed Arch on it because I have it already installed on my drive so I put this drive inside and it was working great for about 2 weeks. After this time I have to give it back so I put there original Win 10 drive and it still works well. I didn't notice anything like a louder fan or shorter battery life (it was even about 10% longer - like in Dell Inspiron I mentioned before).
I am not a specialist but for me, it looks like there is a serious problem (or more than one?) with hardware in some laptops (or maybe in all of them) or in Linux kernel/installer of Arch.

Offline

Board footer

Powered by FluxBB