You are not logged in.

#1 2019-11-22 18:38:54

rokidakota
Member
Registered: 2014-11-22
Posts: 24

No USB ports working after update

Hi,

My laptop has 4 USB ports. I plug a mouse, a keyboard and a MIDI controller, but non of them work today.

`usb-devices` and `lsusb` always show the internal USB devices (two hubs and a webcam) no matter what I plug into the USB ports.

If I do

journalctl -b | grep usb

I get

Nov 22 19:06:28 xxx kernel: usbcore: registered new interface driver usbfs
Nov 22 19:06:28 xxx kernel: usbcore: registered new interface driver hub
Nov 22 19:06:28 xxx kernel: usbcore: registered new device driver usb
Nov 22 19:06:28 xxx kernel: usbcore: registered new interface driver usbserial_generic
Nov 22 19:06:28 xxx kernel: usbserial: USB Serial support registered for generic
Nov 22 19:06:28 xxx kernel: usb usb1: New USB device found, idVendor=1d6b, idProduct=0002, bcdDevice= 5.03
Nov 22 19:06:28 xxx kernel: usb usb1: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Nov 22 19:06:28 xxx kernel: usb usb1: Product: xHCI Host Controller
Nov 22 19:06:28 xxx kernel: usb usb1: Manufacturer: Linux 5.3.12-arch1-1 xhci-hcd
Nov 22 19:06:28 xxx kernel: usb usb1: SerialNumber: 0000:00:14.0
Nov 22 19:06:28 xxx kernel: usb usb2: New USB device found, idVendor=1d6b, idProduct=0003, bcdDevice= 5.03
Nov 22 19:06:28 xxx kernel: usb usb2: New USB device strings: Mfr=3, Product=2, SerialNumber=1
Nov 22 19:06:28 xxx kernel: usb usb2: Product: xHCI Host Controller
Nov 22 19:06:28 xxx kernel: usb usb2: Manufacturer: Linux 5.3.12-arch1-1 xhci-hcd
Nov 22 19:06:28 xxx kernel: usb usb2: SerialNumber: 0000:00:14.0
Nov 22 19:06:28 xxx kernel: usb 1-9: new full-speed USB device number 2 using xhci_hcd
Nov 22 19:06:28 xxx kernel: usb 1-9: device descriptor read/64, error -71
Nov 22 19:06:33 xxx kernel: usb 1-9: device descriptor read/64, error -110
Nov 22 19:06:33 xxx kernel: usb 1-9: new full-speed USB device number 3 using xhci_hcd
Nov 22 19:06:33 xxx kernel: usb 1-9: device descriptor read/64, error -71
Nov 22 19:06:33 xxx kernel: usb 1-9: device descriptor read/64, error -71
Nov 22 19:06:34 xxx kernel: usb usb1-port9: attempt power cycle
Nov 22 19:06:34 xxx kernel: usb 1-9: new full-speed USB device number 4 using xhci_hcd
Nov 22 19:06:34 xxx kernel: usb 1-9: Device not responding to setup address.
Nov 22 19:06:34 xxx kernel: usb 1-9: Device not responding to setup address.
Nov 22 19:06:35 xxx kernel: usb 1-9: device not accepting address 4, error -71
Nov 22 19:06:35 xxx kernel: usb 1-9: new full-speed USB device number 5 using xhci_hcd
Nov 22 19:06:35 xxx kernel: usb 1-9: Device not responding to setup address.
Nov 22 19:06:35 xxx kernel: usb 1-9: Device not responding to setup address.
Nov 22 19:06:35 xxx kernel: usb 1-9: device not accepting address 5, error -71
Nov 22 19:06:35 xxx kernel: usb usb1-port9: unable to enumerate USB device
Nov 22 19:06:35 xxx kernel: usb 1-12: new high-speed USB device number 6 using xhci_hcd
Nov 22 19:06:35 xxx kernel: usb 1-12: New USB device found, idVendor=04f2, idProduct=b3b4, bcdDevice=83.66
Nov 22 19:06:35 xxx kernel: usb 1-12: New USB device strings: Mfr=3, Product=1, SerialNumber=2
Nov 22 19:06:35 xxx kernel: usb 1-12: Product: FJ Camera
Nov 22 19:06:35 xxx kernel: usb 1-12: Manufacturer: Chicony Electronics Co.,Ltd.
Nov 22 19:06:35 xxx kernel: usb 1-12: SerialNumber: 0x0001
Nov 22 19:06:36 xxx mtp-probe[4136]: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-12"
Nov 22 19:06:36 xxx kernel: input: FJ Camera: FJ Camera as /devices/pci0000:00/0000:00:14.0/usb1/1-12/1-12:1.0/input/input26
Nov 22 19:06:36 xxx kernel: usbcore: registered new interface driver uvcvideo
Nov 22 19:06:36 xxx mtp-probe[4260]: checking bus 1, device 6: "/sys/devices/pci0000:00/0000:00:14.0/usb1/1-12"

Any ideas what I can try?

Thanks!

Offline

#2 2019-11-22 20:40:39

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 28,157
Website

Re: No USB ports working after update

Please paste the output of `uname -r && pacman -Q linux`


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#3 2019-11-22 20:55:05

rokidakota
Member
Registered: 2014-11-22
Posts: 24

Re: No USB ports working after update

Thank you for writing. Very odd: it suddenly works!

I did restart the computer 3 times before posting above (power off & on), in case there was some microcode install pending or something else. It did not help.

Now 2 hours later at home, I started the laptop, it rebooted by itself before completing the process
(I didn't get to see if there were any messages on the screen) and now it works as expected.

I'll still check in the office if it's related to using an external monitor connected via DisplayPort at work. That's the only difference I can think of.

Offline

Board footer

Powered by FluxBB