You are not logged in.

#1 2004-03-16 03:25:49

intrinsic
Member
Registered: 2004-03-16
Posts: 21

Fonts in KDE 3.2

I just installed AL 0.6 and the fonts in KDE are not being anti-aliased.
Could this have something to do with a missing xft package?
I already have the freetype module enabled in my xf86config.
Where am i going wrong?

Offline

#2 2004-03-16 08:40:43

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Fonts in KDE 3.2

[damir@Asteraceae /]$ more /etc/fonts/local.conf
<?xml version="1.0"?> 
 <!DOCTYPE fontconfig SYSTEM "fonts.dtd"> 
 <!-- /etc/fonts.conf file to configure system font access --> 
 <fontconfig> 
         <match target="font"> 
            <edit name="antialias" mode="assign"><bool>true</bool></edit> 
             
       <edit name="hinting" mode="assign"><bool>false</bool></edit> 
     
         </match> 
         <match target="pattern"> 
                 <edit name="dpi" mode="assign"><double>132</double></edit> 
         </match> 
         <!--  Dongs  --> 
 
         <alias> 
                 <family>serif</family> 
                 <prefer> 
                         <family>Bitstream Vera Serif</family> 
                 </prefer> 
         </alias> 
         <alias> 
                 <family>sans-serif</family> 
                 <prefer> 
                         <family>Bitstream Vera Sans</family> 
                 </prefer> 
         </alias> 
         <alias> 
                 <family>monospace</family> 
                 <prefer> 
                         <family>Bitstream Vera Sans Mono</family> 
                 </prefer> 
         </alias> 
         
 <dir>/usr/local/share/fonts</dir>
 <dir>/usr/share/fonts</dir>
 <dir>/usr/X11R6/lib/X11/fonts</dir>
 </fontconfig>
[damir@Asteraceae /]$ 

do you have something like this?


The impossible missions are the only ones which succeed.

Offline

#3 2004-03-16 08:42:15

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Fonts in KDE 3.2

... and additionally you have to enable aa in kde:

[Control Center]-[Appeareance & ..]-[Fonts]


The impossible missions are the only ones which succeed.

Offline

#4 2004-03-16 08:44:03

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Fonts in KDE 3.2

and make sure:

<match target="pattern"> 
                  <edit name="dpi" mode="assign"><double>132</double></edit> 
</match>

is set to your resolution from the monitor (mine is 132dots/inch ... often it is 75dpi ... it's important to size the fonts right)

you can get this number by measuring the physical size and then compute it against the resolution you are using


The impossible missions are the only ones which succeed.

Offline

#5 2004-04-01 06:42:35

Mindaugas
Member
From: Ireland
Registered: 2004-03-25
Posts: 95

Re: Fonts in KDE 3.2

dp I see only:
[mind@deimas mind]$ more /etc/fonts/local.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--
  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
</fontconfig>

What I need to do?
Just change that file? Or something else ?

Mindaugas

Offline

#6 2004-04-04 23:10:06

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: Fonts in KDE 3.2

Mindaugas wrote:

dp I see only:
[mind@deimas mind]$ more /etc/fonts/local.conf
<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--
  Enable sub-pixel rendering
        <match target="font">
                <test qual="all" name="rgba">
                        <const>unknown</const>
                </test>
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
</fontconfig>

What I need to do?
Just change that file? Or something else ?

Mindaugas

yes, change the file simply ... but make sure you have bitstream vera installed and set the dpi-number right (it's telling how big the text should be)


The impossible missions are the only ones which succeed.

Offline

Board footer

Powered by FluxBB