You are not logged in.

#1 2019-11-24 21:17:20

kinru
Member
From: East Coast USA
Registered: 2019-03-23
Posts: 33

[Partially Solved] War Thunder, sound and/or network unavailable.

I recently decided to re-download War Thunder on Steam. So I install and it downloads the launcher. In the launcher, the game downloaded and launched fine when I clicked 'play'. Everything loaded properly, except for sound. In the games settings, the sound output says "NoSound Driver" which I think is strange, why shouldn't it use JACK for its audio? No other programs on my system have this problem.

Some Clarification: I use JACK for my audio and it works fine. I use the output (in Cadence) "hw:Generic,0 [ALC887-VD Analog]" which is my motherboard's internal sound card. For my input, i.e. my microphone I use the input (in Cadence) "hw:CODEC,0 [USB Audio]" which is my external audio interface.

.asoundrc configuration (automatically configured by Cadence for JACK)

When I run

steam

and launch War Thunder WITHOUT forcing any compatibility tool here is the output. (This is where all loads perfectly, but with missing sound. I can even join a game with this.)


When I run

steam

and set War Thunder to use "Steam Linux Runtime" and then launch it, here is the output. Besides this, once the launcher updates and the files validate, there is an error popup

Couldn't update Launcher in /home/ben/.local/share/Steam/steamapps/common/War Thunder

. I continue anyway and it shows "Connecting to Server" until it gives me "Connection Error 81110013 Failed to load player profile" and this link. When I close the message, it is shown indefinitely "Connecting to the Server" so there appears to be some network error. No sound plays in this instance, either.



When I run

steam

and set War Thunder to use "Proton 11-", but it say it is missing the executable. I decide to uncheck the box, therefore setting no particular compatibility tool. The launcher starts up no problem. However, when I start the game, it opens but crashes when connecting to the server. the output from steam in console
Here's the latest log file from ~/.steam/steam/steamapps/common/War Thunder/.gaijin_launcher_logs
Here's the latest log file from ~/.steam/steam/steamapps/common/War Thunder/.start_app_logs

Following the first workaround in https://wiki.archlinux.org/index.php/St … dio_issues didn't seem to do anything.

When I run

steam

and set War Thunder to use "Steam Linux Runtime" and then launch it, here is the output]. Besides this, once the launcher updates and the files validate, there is an error popup

Couldn't update Launcher in /home/ben/.local/share/Steam/steamapps/common/War Thunder

. I continue anyway and it shows "Connecting to Server" until it gives me "Connection Error 81110013 Failed to load player profile" and this link. When I close the message, it is shown indefinitely "Connecting to the Server" so there appears to be some network error. No sound plays in this instance, either.

This changed once I restarted JACK and made sure that the snd-aloop module was working. I got it loaded and restarted the launcher. It was able to launch the same way as the above quote but the sound played. Sadly, the above error still occurred. So ultimately the issue is the network while the game is set to use "Steam Linux Runtime". When it is not set to use it, I can actually get in game albeit with no sound.

Line 44 in https://pastebin.com/Ni526Qdc says

** (steam:6298): WARNING **: 13:59:12.442: Could not initialize NMClient /org/freedesktop/NetworkManager: The name org.freedesktop.NetworkManager was not provided by any .service files

I think this might be some issue with NetworkManager.

 pacman -Qs networkmanager

returns

local/libnm 1.20.6-1
    NetworkManager client library

Also on the steam troubleshooting article, what is LD_PRELOAD and where can I configure it?


I will post logs or configs if they are needed to solve or diagnose the problem, since I am unsure what to do now.

Last edited by kinru (2019-11-25 01:47:29)

Offline

#2 2019-11-25 01:35:24

kinru
Member
From: East Coast USA
Registered: 2019-03-23
Posts: 33

Re: [Partially Solved] War Thunder, sound and/or network unavailable.

I have some updates:

I have followed all the workarounds mentioned in https://wiki.archlinux.org/index.php/St … dio_issues but audio still does not work (without specifying to use the Steam Linux Runtime). With the Runtime enabled, however, connecting to the servers fails.

ALSA lib pcm_dmix.c:1089:(snd_pcm_dmix_open) unable to open slave

is the error I want to fix. With this I believe audio would work.

Secondly, I have tested and videos in the steam client successfully play with audio, soo ?????
Does that mean that all libs that are needed are loaded, but War Thunder has an issue?

Offline

#3 2019-11-25 01:47:04

kinru
Member
From: East Coast USA
Registered: 2019-03-23
Posts: 33

Re: [Partially Solved] War Thunder, sound and/or network unavailable.

I think this might be solved. I deleted my .asoundrc and didn't regenerate it with cadence. I can play multiple streams of audio at once. Should I open a new topic for using JACK with this, or is it impossible? For now, I will write [Partially Solved]

Offline

Board footer

Powered by FluxBB