You are not logged in.

#1 2019-11-30 09:22:51

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

[solved]punctuations rotated

some of the punctuations, like ()!?, are rotated in chrome or wps.
as in the pic:
p2575538033.webp
279806022269fc8734cfda422fbc53ed962ac9f8.jpg
Does any one know what the problem is?

Last edited by jxt_hbtm (2019-11-30 15:03:51)

Offline

#2 2019-11-30 12:34:19

seth
Member
Registered: 2012-09-03
Posts: 13,104

Re: [solved]punctuations rotated

Broken image link.

Offline

#3 2019-11-30 13:03:40

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

seth wrote:

Broken image link.

can you see it now?

Offline

#4 2019-11-30 14:59:01

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

fixed when I add to file /etc/environment the following lines:

LANG=en_US.UTF-8
LC_ALL=en_US.UTF-8

Offline

#5 2019-11-30 15:01:07

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,395
Website

Re: [solved]punctuations rotated

Those belong in locale.conf, not environment.  Your locale is broken - you'll likely run into other problems until you fix it properly.

Did you skip some steps in installing this system?  Which guide did you follow for your install?

Last edited by Trilby (2019-11-30 15:01:50)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#6 2019-11-30 15:15:05

seth
Member
Registered: 2012-09-03
Posts: 13,104

Re: [solved]punctuations rotated

It's stunning enough that the locale can cause this and it's for sure a bug.
Is your default locale some asian or so w/ the potential for vertical text?

Offline

#7 2019-11-30 16:05:01

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

Trilby wrote:

Those belong in locale.conf, not environment.  Your locale is broken - you'll likely run into other problems until you fix it properly.

Did you skip some steps in installing this system?  Which guide did you follow for your install?

I already have LANG in locale.conf,  I JUST added LC_ALL into locale.conf and removed them from environment, now the punctuations are rotated again.
here's my config files:

[jxt@archlinux ~]$ cat /etc/environment 
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
#LC_ALL=en_US.UTF-8
#LANG=en_US.UTF-8
XMODIFIERS=@im=fcitx
[jxt@archlinux ~]$ cat /etc/locale.conf 
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
[jxt@archlinux ~]$ 

Offline

#8 2019-11-30 16:07:56

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

I followed the wiki's installation guide.

Offline

#9 2019-11-30 16:13:25

seth
Member
Registered: 2012-09-03
Posts: 13,104

Re: [solved]punctuations rotated

XMODIFIERS=@im=fcitx

So safe to say you're from some vertical text location?
What's teh output of "locale" w/o the entry in /etc/environment ?

Offline

#10 2019-11-30 16:14:04

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

I tried it again. Now I have LANG/LC_ALL in both the environment and the locale.conf , and problem is fixed.
Seems like LANG must be put in environment.

Offline

#11 2019-11-30 16:16:14

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

seth wrote:
XMODIFIERS=@im=fcitx

So safe to say you're from some vertical text location?
What's teh output of "locale" w/o the entry in /etc/environment ?

[jxt@archlinux ~]$ locale
LANG=mn_CN.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8
[jxt@archlinux ~]$ cat /etc/environment 
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
XMODIFIERS=@im=fcitx
[jxt@archlinux ~]$ cat /etc/locale.conf
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
[jxt@archlinux ~]$

Offline

#12 2019-11-30 16:21:43

seth
Member
Registered: 2012-09-03
Posts: 13,104

Re: [solved]punctuations rotated

Something™ in your session overrides $LANG to mn_CN.UTF-8 …

Offline

#13 2019-11-30 16:38:12

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

more:

[jxt@archlinux ~]$ cat /etc/environment 
#
# This file is parsed by pam_env module
#
# Syntax: simple "KEY=VAL" pairs on separate lines
#
#LC_ALL=en_US.UTF-8
#LANG=en_US.UTF-8
XMODIFIERS=@im=fcitx
[jxt@archlinux ~]$ cat /etc/locale.conf
LC_ALL=en_US.UTF-8
LANG=en_US.UTF-8
[jxt@archlinux ~]$ locale
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=mn_CN.UTF-8
LC_CTYPE="mn_CN.UTF-8"
LC_NUMERIC="mn_CN.UTF-8"
LC_TIME="mn_CN.UTF-8"
LC_COLLATE="mn_CN.UTF-8"
LC_MONETARY="mn_CN.UTF-8"
LC_MESSAGES="mn_CN.UTF-8"
LC_PAPER="mn_CN.UTF-8"
LC_NAME="mn_CN.UTF-8"
LC_ADDRESS="mn_CN.UTF-8"
LC_TELEPHONE="mn_CN.UTF-8"
LC_MEASUREMENT="mn_CN.UTF-8"
LC_IDENTIFICATION="mn_CN.UTF-8"
LC_ALL=

Offline

#14 2019-11-30 16:41:17

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

I never set mn_CN.UTF-8, where does it come from?

I'll just keep LANG and LC_ALL in /etc/environment, until someone give a new solution.

Last edited by jxt_hbtm (2019-11-30 17:09:06)

Offline

#15 2019-11-30 16:50:49

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 22,395
Website

Re: [solved]punctuations rotated

Please see the wiki: https://wiki.archlinux.org/index.php/Locale

Post the output of each of the following:

locale -a
grep -v '^#' /etc/locale.gen
localectl

And are you from some vertical text location?  Have you intentionally setup fcitx?

Last edited by Trilby (2019-11-30 16:52:25)


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#16 2019-11-30 17:13:45

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

[jxt@archlinux share]$ locale -a
C
en_US.utf8
POSIX
zh_CN.utf8
zh_HK.utf8
[jxt@archlinux share]$ grep -v '^#' /etc/locale.gen
en_US.UTF-8 UTF-8  
zh_CN.UTF-8 UTF-8  
zh_HK.UTF-8 UTF-8  
[jxt@archlinux share]$ localectl
   System Locale: LANG=en_US.UTF-8
       VC Keymap: n/a
      X11 Layout: n/a

I installed Chinese input method

Last edited by jxt_hbtm (2019-11-30 17:21:23)

Offline

#17 2019-11-30 17:38:46

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

seth wrote:

Something™ in your session overrides $LANG to mn_CN.UTF-8 …

found it, but I don't know why

[jxt@archlinux .config]$ cat plasma-localerc
[Formats]
LANG=mn_CN.UTF-8

[Translations]
LANGUAGE=zh_CN
[jxt@archlinux .config]$ cat /home/jxt/.config/plasma-locale-settings.sh 
# Generated script, do not edit
# Exports language-format specific env vars from startkde.
# This script has been generated from kcmshell5 formats.
# It will automatically be overwritten from there.
export LANG=mn_CN.UTF-8
export LANGUAGE=zh_CN

Last edited by jxt_hbtm (2019-11-30 17:41:13)

Offline

#18 2019-11-30 20:31:50

seth
Member
Registered: 2012-09-03
Posts: 13,104

Re: [solved]punctuations rotated

Probably the locale settings in systemsettings. Somewhere you probably said "mongolia" and the consequence was this entry.
(While in some other place you must have said "mandarin")

Offline

#19 2019-12-01 04:05:31

jxt_hbtm
Member
Registered: 2019-11-30
Posts: 12

Re: [solved]punctuations rotated

seth wrote:

Probably the locale settings in systemsettings. Somewhere you probably said "mongolia" and the consequence was this entry.
(While in some other place you must have said "mandarin")

exactly! I found it in Regional settings - Formats and changed it to en_US. Now everything's right. Thank you guys!

Offline

Board footer

Powered by FluxBB