You are not logged in.

#1 2019-12-01 02:26:49

Pinetrapezoid
Member
Registered: 2019-12-01
Posts: 2

Changing deep suspend variant doesn't apply on boot

Hi, I am following the Suspend section of this wiki article. My issue is that even after adding

 GRUB_CMDLINE_LINUX_DEFAULT="mem_sleep_default=deep"

to my grub file my deep suspend variant is still s2idle on boot as

 cat /sys/power/mem_sleep 

returns

 [s2idle] deep

Here is how my grub file looks like at this moment

# GRUB boot loader configuration

GRUB_DEFAULT=0
GRUB_TIMEOUT=5
GRUB_DISTRIBUTOR="Arch"
GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet"
#Better suspend variant
GRUB_CMDLINE_LINUX_DEFAULT="mem_sleep_default=deep"
GRUB_CMDLINE_LINUX=""

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices
#GRUB_ENABLE_CRYPTODISK=y

# Set to 'countdown' or 'hidden' to change timeout behavior,
# press ESC key to display menu.
GRUB_TIMEOUT_STYLE=menu

# Uncomment to use basic console
GRUB_TERMINAL_INPUT=console

# Uncomment to disable graphical terminal
#GRUB_TERMINAL_OUTPUT=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
GRUB_GFXMODE=auto

# Uncomment to allow the kernel use the same resolution used by grub
GRUB_GFXPAYLOAD_LINUX=keep

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
GRUB_DISABLE_RECOVERY=true

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.
#GRUB_COLOR_NORMAL="light-blue/black"
#GRUB_COLOR_HIGHLIGHT="light-cyan/blue"

# Uncomment one of them for the gfx desired, a image background or a gfxtheme
#GRUB_BACKGROUND="/path/to/wallpaper"
#GRUB_THEME="/path/to/gfxtheme"

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"

# Uncomment to make GRUB remember the last selection. This requires
# setting 'GRUB_DEFAULT=saved' above.
#GRUB_SAVEDEFAULT="true"

I would greatly appreciate some help on this issue!

Offline

#2 2019-12-01 03:11:54

loqs
Member
Registered: 2014-03-06
Posts: 9,234

Re: Changing deep suspend variant doesn't apply on boot

Welcome to the arch linux forums Pinetrapezoid.
Does the output of `cat /proc/cmdline` contain mem_sleep_default=deep ?

Offline

#3 2019-12-01 03:33:43

kermit63
Member
Registered: 2018-07-04
Posts: 12

Re: Changing deep suspend variant doesn't apply on boot

try appending "mem_sleep_default=deep" to the original GRUB_CMDLINE_LINUX_DEFAULT="loglevel=3 quiet" instead of addling a 2nd GRUB_CMDLINE_LINUX_DEFAULT.

Offline

#4 2019-12-01 12:59:47

xerxes_
Member
Registered: 2018-04-29
Posts: 135

Re: Changing deep suspend variant doesn't apply on boot

@Pinetrapezoid

Do what kermit63 wrote and then do 'sudo grub-mkconfig -o /boot/grub/grub.cfg'

Offline

#5 2019-12-01 16:11:20

Pinetrapezoid
Member
Registered: 2019-12-01
Posts: 2

Re: Changing deep suspend variant doesn't apply on boot

xerxes_ wrote:

@Pinetrapezoid

Do what kermit63 wrote and then do 'sudo grub-mkconfig -o /boot/grub/grub.cfg'

Thank you this fixed it!

Offline

Board footer

Powered by FluxBB