You are not logged in.

#1 2019-12-02 19:13:44

BitterCelt
Member
Registered: 2017-02-08
Posts: 12

Primus fatal error

I've been trying to deal with the issues highlighted in this thread https://bbs.archlinux.org/viewtopic.php?id=250660, and whatever changes I've made with the packages I'd ended up with issues with bumblebee. I'm currently getting this:

primus: fatal: Bumblebee daemon reported: error: [XORG] (EE) [drm] Failed to open DRM device for pci:0000:01:00.0: -19

... whenever I run primusrun glxgears

Offline

#2 2019-12-02 20:00:33

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,003

Re: Primus fatal error

BitterCelt wrote:

... whatever changes I've made with the packages I'd ended up with issues with bumblebee.

Well what did you do exactly? We don't sit in front of your system and we haven't done the changes to your system.

I'm hazarding a guess that you tried to downgrade. If you've downgraded just the nvidia packages you will have set up an nvidia package that isn't built against the current kernel. The easiest way to fix this, if you indeed intend to have the nvidia packages downgraded but the kernel updated, would be to instead use nvidia-dkms of the version you tried to downgrade to, along with nvidia-utils lib32-nvidia-utils libxnvctrl and nvidia-settings.

Online

Board footer

Powered by FluxBB