You are not logged in.

#1 2019-12-03 15:27:44

the_pumpkin_man
Member
Registered: 2018-11-21
Posts: 9

os-prober detecting no OS / GRUB making mistakes in entry

So, I followed the wiki for installing an encrypted with LVM on LUKS and a separate unencrypted /boot on an USB key. So everything is working for this system. The problem is with GRUB and os-prober as the title says.

I have actually 4 systems on my computer, they are all working :
- My fresh installed Arch Linux as described above (1)
- An old Arch Linux system, my main system, unencrypted, just the basic install with GNOME (2)
- Kali Linux (3)
- Windows 10 (4)

When I used the GRUB from (2) before I had my new Arch Linux system, everything worked. os-prober was able to detect (3) and (4), and no problem with GRUB.
Now, Im trying to use the GRUB from (1), because it would be complicated to detect (1) with (2) and I want (1) to be my main system. But os-prober doesnt find anything. So I tried to make it detect the OSs by mounting them, what I did, so it detected them. But after installing GRUB and launching (2), it froze. The problem was at the initrd line of the /boot/grub/grub.cfg on the USB key (remember, my /boot is on the key). It was only

initrd /boot/intel-ucode.img

, but should be

initrd /boot/intel-ucode.img /boot/initramfs-linux-lts.img

. After manually editing grub.cfg to change this, it finally worked. But I have two questions :
- How can I make os-prober work ? Is it not working because my /boot is on an USB stick ?
- How can I make GRUB work for Arch Linux ? (I actually didnt tried to launch Windows or Kali Linux)

Thanks in advance for reading all this and for your help wink

Offline

Board footer

Powered by FluxBB