You are not logged in.
I'm confused about the doc of systemctl and unit man pages as a noob. As I'm in need to start transmission-daemon on startup and run it as my user account instead of the default user transmission, I wrote a unit file called transmission_user.service.
[Unit]
Description=Running transmission-daemon on startup
[Service]
User=myUserName
Group=transmission
ExecStart=transmission-daemon
ExecStop=pkill -3 transmission-daemon
[Install]
WantedBy=multi-user.targetI tried with this unit file with sudo systemctl start transmission_user.service but transmission failed to start. systemctl status transmission_user.service shows the detail which I can't figure out and need someone to help, plz.
* transmission_user.service - Running transmission-daemon on startup
Loaded: loaded (/etc/systemd/system/transmission_user.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Tue 2020-01-07 11:16:17 HKT; 2min 27s ago
Process: 4780 ExecStart=/usr/bin/transmission-daemon (code=exited, status=0/SUCCESS)
Process: 4785 ExecStop=/usr/bin/pkill -3 transmission-daemon (code=exited, status=1/FAILURE)
Main PID: 4780 (code=exited, status=0/SUCCESS)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: DHT Generating new id (tr-dht.c:311)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: Using settings from "/home/myUserName/.config/transmission-daemon" (daemon.c:528)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: Saved "/home/myUserName/.config/transmission-daemon/settings.json" (variant.c:1266)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: Saved "/home/myUserName/.config/transmission-daemon/settings.json" (variant.c:1266)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: DHT Not saving nodes, DHT not ready (tr-dht.c:359)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: Port Forwarding Stopped (port-forwarding.c:180)
Jan 07 11:16:17 myHostName transmission-daemon[4782]: Closing session
Jan 07 11:16:17 myHostName systemd[1]: transmission_user.service: Failed with result 'exit-code'.Added
If I comment out the "ExecStop" line in the unit file, transmission-daemon actually works and can be accessed from webUI. However, systemctl status transmission_user.service still says the service is inactive and shows the following:
* transmission_user.service - Running transmission-daemon on startup
Loaded: loaded (/etc/systemd/system/transmission_user.service; disabled; vendor preset: disabled)
Active: inactive (dead)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: RPC Server Adding address to whitelist: 192.168.1.* (rpc-server.c:971)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:1213)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: RPC Server Whitelist enabled (rpc-server.c:1217)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: DHT Generating new id (tr-dht.c:311)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: Using settings from "/home/myUserName/.config/transmission-daemon" (daemon.c:528)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: Saved "/home/myUserName/.config/transmission-daemon/settings.json" (variant.c:1266)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: Saved "/home/myUserName/.config/transmission-daemon/settings.json" (variant.c:1266)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: DHT Not saving nodes, DHT not ready (tr-dht.c:359)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: Port Forwarding Stopped (port-forwarding.c:180)
Jan 07 11:38:41 myHostName transmission-daemon[5247]: Closing sessionOffline
Offline