You are not logged in.

#1 2019-10-14 03:48:33

FatCheques1
Member
Registered: 2019-10-14
Posts: 2

Enabling VirGL for QEMU breaks display

Despite following all the information on the Arch Wiki I'm unable to get guest OpenGL acceleration to work for QEMU. I get no video output on boot when it's enabed, without virgl enabled everything works fine.

Command when running with GTK display, virgl disabed:

qemu-system-x86_64 -enable-kvm -m 2048 -vga virtio -display gtk -cdrom livecd.iso

Works fine.

Command when running with GTK display, virgl enabled:

qemu-system-x86_64 -enable-kvm -m 2048 -vga virtio -display gtk,gl=on -cdrom livecd.iso

No display output (black screen), no error messages.

Command when running with SPICE display, virgl disabled:

qemu-system-x86_64 -enable-kvm -m 2048 -vga virtio -spice unix,addr=/tmp/spice.sock,disable-ticketing -cdrom livecd.iso

Works fine.

Command when running with SPICE display, virgl enabled:

qemu-system-x86_64 -enable-kvm -m 2048 -vga virtio -spice unix,addr=/tmp/spice.sock,disable-ticketing,gl=on -cdrom livecd.iso

No display output (black screen) on spice client, QEMU gives error message: "qemu-system-x86_64: warning: Spice: dcc.c:664:dcc_push_monitors_config: monitors_config is NULL".

Anything I'm missing? According to all information I can find this should work fine.

Offline

#2 2019-10-14 08:50:55

Omar007
Member
Registered: 2015-04-09
Posts: 335

Re: Enabling VirGL for QEMU breaks display

FatCheques1 wrote:

virgl disabed:

FatCheques1 wrote:

-vga virtio

From what I can tell you're using VirGL in every single one of those commands (-vga virtio = virgl) but the ones that fail are the ones where you try to enable the OpenGL context in the device (-device ..,gl=on).

What image are you trying to boot and what kernel and mesa version does that contain?

Offline

#3 2019-10-14 17:38:27

liewkj
Member
Registered: 2019-07-08
Posts: 107

Re: Enabling VirGL for QEMU breaks display

I am a frequent and avid user of QEMU. I run source compiled QEMU-4.1.0 on fully updated and upstream ArchLinux. I have VirGL working with or without enabling OpenGL context for Ubuntu 16.04LTS, Debian Stretch and ArchLinux32 guests.

Offline

#4 2019-10-14 21:45:37

anatolik
Developer
Registered: 2012-09-27
Posts: 443

Re: Enabling VirGL for QEMU breaks display

liewkj wrote:

I run source compiled QEMU-4.1.0 on fully updated and upstream ArchLinux

Does VirGL work for binary package on your side as well?

And btw what is the reason you use source-compiled QEMU? Do you miss some features in Arch QEMU package?

Offline

#5 2019-10-15 06:26:00

FatCheques1
Member
Registered: 2019-10-14
Posts: 2

Re: Enabling VirGL for QEMU breaks display

Omar007 wrote:
FatCheques1 wrote:

virgl disabed:

FatCheques1 wrote:

-vga virtio

From what I can tell you're using VirGL in every single one of those commands (-vga virtio = virgl) but the ones that fail are the ones where you try to enable the OpenGL context in the device (-device ..,gl=on).

What image are you trying to boot and what kernel and mesa version does that contain?

I've been testing with Live CDs of Debian stable (kernel 4.19, mesa 18.3.6) and Linux Mint (kernel 4.15, mesa 19.0.2), I've also tried with a Debian Testing install (kernel 5.2, mesa 19.2.1). All with the same results.

When booted without the opengl context I get no virgl acceleration, glxinfo just shows llvmpipe. I assumed it was needed?

Offline

#6 2019-10-15 06:30:08

liewkj
Member
Registered: 2019-07-08
Posts: 107

Re: Enabling VirGL for QEMU breaks display

FatCheques1 wrote:

When booted without the opengl context I get no virgl acceleration, glxinfo just shows llvmpipe. I assumed it was needed?

Yes, you will need "-display sdl,gl=on" or "-display gtk,gl=on to enable VirGL OpenGL acceleration in Linux guests.

Offline

#7 2020-01-08 05:50:02

mariojuniorjp
Member
Registered: 2014-07-06
Posts: 16

Re: Enabling VirGL for QEMU breaks display

liewkj wrote:
FatCheques1 wrote:

When booted without the opengl context I get no virgl acceleration, glxinfo just shows llvmpipe. I assumed it was needed?

Yes, you will need "-display sdl,gl=on" or "-display gtk,gl=on to enable VirGL OpenGL acceleration in Linux guests.

How to put this on virt-manager? I trying to put on display spice and video virtio but doesn't work. Virt-manager automatically delete this.

Offline

Board footer

Powered by FluxBB