You are not logged in.

#1 2020-01-08 22:58:47

pattyo
Member
Registered: 2016-07-13
Posts: 8

"error: missing source file" when pushing package

Hi,

I've got a PKGBUILD which I'm trying to publish. It requires a source file to be manually downloaded which I have as a local:// in the source array.

The AUR git hook is rejecting it with a missing source file error.

What's the correct way for specifying an external dependency like this?

The error:

remote: error: The following error occurred when parsing commit
remote: error: 7100fe94d995b2f3a714dcd308eefe88945a5121:
remote: error: missing source file: TRACE32_R_2019_02_000108303.tar.xz
remote: error: hook declined to update refs/heads/master
To aur:trace32.git
 ! [remote rejected] 9448fd71a995e183830ba031be2fa4517f94b987 -> master (hook declined)
error: failed to push some refs to 'aur:trace32.git'

The PKGBUILD:

pkgname=trace32
pkgver=2019_09_000114442
pkgrel=1
pkgdesc="Lauterbach TRACE32 - REQUIRES MANUAL DOWNLOAD"
arch=(x86_64)
url="https://www.lauterbach.com/"
source=(local://TRACE32_R_$pkgver.tar.xz file://install.sh)
md5sums=(79bf3e82128097281caa16acf952f8e6 afce9a50619896f769c88a8cee144749)
depends=(openmotif libjpeg6-turbo qt4)
options=(!strip)

package()
{
	"$srcdir"/install.sh "$srcdir"/setup_linux.sh "$pkgdir"/opt/t32
	# cd "$pkgdir"/opt/t32 && unzip -o /path/to/update.zip 
	install -dm755 "$pkgdir"/etc/udev/rules.d
	install -m 644 "$srcdir"/files/bin/pc_linux64/udev.conf/kernel_starting_4.14/10-lauterbach.rules "$pkgdir"/etc/udev/rules.d
	sed -i "s#$pkgdir##g" "$pkgdir"/opt/t32/config_*.t32
	sed -i 's#"/home/$USER/t32"#/opt/t32#' "$pkgdir"/opt/t32/bin/pc_linux64/t32_start.sh
	sed -i 's#/var/tmp#/opt/t32/tmp#' "$pkgdir"/opt/t32/bin/pc_linux64/t32_start.sh
	install -dm755 "$pkgdir"/usr/bin
	cd "$pkgdir"/opt/t32/bin/pc_linux64 && for f in t32*; do ln -s /opt/t32/bin/pc_linux64/"$f" "$pkgdir"/usr/bin; done
}

Thanks,

Patrick

Offline

#2 2020-01-08 23:03:55

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,682

Re: "error: missing source file" when pushing package

Look at the specific commit it's referencing. Do you have local:// in that commit?

Offline

#3 2020-01-08 23:06:54

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,796
Website

Re: "error: missing source file" when pushing package

All commits need to be correct when you push to the AUR. You'll need to fix any commits that are not AUR-compliant. See, e.g. https://wiki.archlinux.org/index.php/Git#Undoing_things

Side note: you don't need to specify "file://" for files that do exist.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#4 2020-01-08 23:18:41

pattyo
Member
Registered: 2016-07-13
Posts: 8

Re: "error: missing source file" when pushing package

Oh, I see.

It's a previous commit that's causing the problem. Thanks!!

Patrick

Offline

#5 2020-01-09 08:21:10

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 811
Website

Re: "error: missing source file" when pushing package

I am unsure as to whether the policy regarding AUR packages changed. But some time ago there was a rule to not include source code within the AUR repository apart from trivial scripts or downstream patches. But surely not an entire xz'ed source code archive.
https://aur.archlinux.org/packages/trace32

Last edited by schard (2020-01-09 08:24:14)

Offline

#6 2020-01-09 08:23:51

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,682

Re: "error: missing source file" when pushing package

He's not. Read again.

Offline

#7 2020-01-09 08:25:45

schard
Member
From: Hannover
Registered: 2016-05-06
Posts: 811
Website

Re: "error: missing source file" when pushing package

Oops. I skipped that manual download part. My bad.

Last edited by schard (2020-01-09 08:26:15)

Offline

#8 2020-01-09 11:08:37

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,796
Website

Re: "error: missing source file" when pushing package

Please remember to mark your thread as solved, pattyo.

https://wiki.archlinux.org/index.php/Co … ow_to_post

Mod note: Moving to AUR Issues


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

Board footer

Powered by FluxBB