You are not logged in.

#1 2020-01-10 23:28:43

zerophase
Member
Registered: 2015-09-03
Posts: 193

Which locale files does Steam require?

Previously, in my pacman.conf I had

NoExtract = usr/share/locale/* usr/share/X11/locale/* usr/share/i18n/locales/*

That caused issues with Steam not allowing text input in games or the UI. Does anyone know which locales Steam requires, or how to track the ones down it expects?

Offline

#2 2020-01-10 23:31:20

Head_on_a_Stick
Member
From: London
Registered: 2014-02-20
Posts: 5,093
Website

Offline

#3 2020-01-11 00:51:10

zerophase
Member
Registered: 2015-09-03
Posts: 193

Re: Which locale files does Steam require?

Oh, I have that generated. The issue is with not installing locale files extracted from packages.

Here's the issue on github

Offline

#4 2020-01-11 10:09:52

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 8,382

Re: Which locale files does Steam require?

Well the same logic applies, you must allow en_US.UTF-8 (in addition to whatever else you use) and "C" as the standard locale that should be present everywhere, see incidentally this thread which is likely the issue you see: https://bbs.archlinux.org/viewtopic.php?id=250866

Offline

Board footer

Powered by FluxBB