You are not logged in.

#1 2020-01-09 22:10:25

d_fajardo
Member
Registered: 2017-07-28
Posts: 720

'introspection typelib not found' error when running ladi-system-log

I am getting this error when I run ladi-system-log:

/usr/lib/python2.7/site-packages/laditools/gtk/a2jmenu.py:20: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk
Traceback (most recent call last):
  File "/usr/bin/ladi-system-log", line 41, in <module>
    from gi.repository import Vte
  File "/usr/lib/python2.7/site-packages/gi/importer.py", line 133, in load_module
    'introspection typelib not found' % namespace)
ImportError: cannot import name Vte, introspection typelib not found

Looks like a gtk issue. I do have python2-gobject installed.
Any way to debug this error?

Offline

#2 2020-01-11 14:50:52

berbae
Member
From: France
Registered: 2007-02-12
Posts: 1,297

Re: 'introspection typelib not found' error when running ladi-system-log

Hello
Do you have the vte3 0.58.3-1 package installed?
It contains '/usr/lib/girepository-1.0/Vte-2.91.typelib' introspection file.

In what package is the 'ladi-systemd-log' tool? I don't find it; maybe it misses a vte dependency.

Offline

#3 2020-01-13 16:36:01

d_fajardo
Member
Registered: 2017-07-28
Posts: 720

Re: 'introspection typelib not found' error when running ladi-system-log

Thanks barbae. It's ladi-system-log not ladi-systemd-log. It was automatically installed when I installed ladi-tools.
In the end I discovered the all the logs are visible in Cadence so I have no need for vte.

Offline

Board footer

Powered by FluxBB