You are not logged in.

#1 2020-01-23 08:08:33

OrigBitmancer
Member
Registered: 2019-01-22
Posts: 103

[SOLVED] Revert from Thunderbird v68.x to v60.8 issues

I am in the process of reverting Thunderbird. The "features" from the upgrades have ruined my experience.
First, after doing "downgrader thunderbird" and downgrading the language pack, I get the following:

 ~>  thunderbird
XPCOMGlueLoad error for file /usr/lib/thunderbird/libxul.so:
libicui18n.so.64: cannot open shared object file: No such file or directory
Couldn't load XPCOM.

Backtracking through the file system,

~>which thunderbird 
/usr/bin/thunderbird

then

 ~>cat /usr/bin/thunderbird
#!/bin/sh
exec /usr/lib/thunderbird/thunderbird "$@"

which links in dynamic modules as

 ~>ldd /usr/lib/thunderbird/thunderbird
        linux-vdso.so.1 (0x00007ffd011fa000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f495b627000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f495b622000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007f495b438000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007f495b41e000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007f495b257000)
        /lib64/ld-linux-x86-64.so.2 => /usr/lib64/ld-linux-x86-64.so.2 (0x00007f495b701000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007f495b111000)

and

 ~>ldd /usr/lib/thunderbird/libxul.so
        linux-vdso.so.1 (0x00007ffcc43a9000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007f727d2e2000)
        libldap60.so => not found
        libprldap60.so => not found
        libmozsandbox.so => not found
        liblgpllibs.so => not found
        libmozgtk.so => not found
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007f727d2db000)
        libplds4.so => /usr/lib/libplds4.so (0x00007f727d2d6000)
        libplc4.so => /usr/lib/libplc4.so (0x00007f727d2cf000)
        libnspr4.so => /usr/lib/libnspr4.so (0x00007f727d28d000)
        libffi.so.6 => /usr/lib/libffi.so.6 (0x00007f727d282000)
        libicui18n.so.64 => not found
        libicuuc.so.64 => not found

after which it finds the rest of the shared libraries.

How do I track down which packages make these "not found" libraries? If I know whence they are built, maybe I can downgrader them as well.

Of course, it would be better to make a static library of TB60.8, and I am trying that in parallel....

Last edited by OrigBitmancer (2020-01-24 00:21:19)

Offline

#2 2020-01-23 08:26:47

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 9,139

Re: [SOLVED] Revert from Thunderbird v68.x to v60.8 issues

https://wiki.archlinux.org/index.php/Sy … nsupported

Don't even think about downgrading other libraries, you will break your system. Get the PKGBUILD for the old version of thunderbird and rebuild it locally: https://wiki.archlinux.org/index.php/Arch_Build_System if that is too costly/taxing then indeed make a static build, or try a bin release from Mozilla or try the relevant AUR package, as it happens there's: https://aur.archlinux.org/packages/thunderbird-60-bin

Offline

#3 2020-01-23 14:30:23

Mr.Elendig
#archlinux@freenode channel op
From: The intertubes
Registered: 2004-11-07
Posts: 4,016

Re: [SOLVED] Revert from Thunderbird v68.x to v60.8 issues

Or grab a standalone version from upstream and stuff it in $HOME.

Edit: I hope you are aware of the security implications of running an old unsupported thunderbird.

Last edited by Mr.Elendig (2020-01-23 14:31:44)


Evil #archlinux@freenode channel op and general support dude.
. files on github, Screenshots, Random pics and the rest

Offline

#4 2020-01-23 20:21:21

OrigBitmancer
Member
Registered: 2019-01-22
Posts: 103

Re: [SOLVED] Revert from Thunderbird v68.x to v60.8 issues

I am building this for a single user: me.

I check all links before clicking. I should read up on security fixes. “Standalone version from upstream” is where?

Thank you both for appropriate warnings. I will look at the AUR v60 package. Much appreciated.

Edit: THE AUR package is working a treat. THANKS.

Last edited by OrigBitmancer (2020-01-24 00:20:39)

Offline

Board footer

Powered by FluxBB