You are not logged in.
When I put the ro option on my root partition in /etc/fstab, I get the authentication failure error next time I try to login.
I've see that other people have this problem as well.
How do I make my root partition read only on startup while still being able to log in?
It would also be helpful if anyone knows why this happens, and if there are specific directories that must be writable on boot or something.
Offline
The Internet...read it.
Offline
Solved it by mounting /var as tmpfs.
So I guess systemd-logind needs files in /var to be writable at boot.
Don't know which files though.
If I did, then I could mount just those as tmpfs and not the entire /var directory.
Offline
You could use audit to monitor /var.
Edit:
At a guess you could try changing the account entry for pam_tally2.so in /etc/pam.d/system-login to
account required pam_tally2.so onerr=succeedLast edited by loqs (2020-01-28 19:34:18)
Offline