You are not logged in.

#1 2020-01-24 20:47:16

kangoo2097
Member
Registered: 2013-04-22
Posts: 6

p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Hey,

The update of p11-kit to 0.23.19-1 appears to affect the flatpak version of Spotify. If using p11-kit 0.23.19-1, my flatpaked Spotify client is no longer able to download album covers and playlists. More importantly, it is also no longer able to play music except if the song is already cached. Downgrading p11-kit to its previous version (0.23.18.1-2) solves this issue. I also tried downgrading the Spotify flatpak, which had little effect on the issue. Interestingly, the AUR version of Spotify does not appear to be affected.

I would like to understand what is causing this. As the p11-kit upgrade has no effect on the AUR version of Spotify, I don't think that this is an issue with the Spotify client itself. I started wondering if such problems be caused by the "Freedesktop Platform" / org.freedesktop.Platform flatpak being or becoming, in this case, incompatible with the underlying OS.

Thanks to anyone who can enlighten me wink.

Offline

#2 2020-01-25 12:25:08

megaclever
Member
Registered: 2019-03-10
Posts: 1

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Hi kangoo2097,

how do you find out that p11-kit is the issue? I have searched all the logs. Have downgraded p11 inkl ca-certs and now everthing works. Will test again once there is  a new p11 version.

THX and KR

Offline

#3 2020-01-25 13:06:39

progandy
Member
Registered: 2012-05-17
Posts: 3,686

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

As far as I know, flatpak uses a p11-kit server on the host to forward the certificate database to a client inside the flatpak sandbox. Maybe something in the wire format or the way the server has to be started is incompatible?


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#4 2020-01-25 14:43:04

kangoo2097
Member
Registered: 2013-04-22
Posts: 6

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

@megaclever
When I ran into the issue, the Spotify flatpak got an update and there were also some Arch packages updated at the same time. First, I was suspecting the updated flatpak to be the culprit, but as downgrading it did not have any effect, I started to check what other packages got updated. Fortunately, it weren't that many, so it was relatively to figure out which one it was. You can see in /var/log/pacman.log which packages got updated recently. For downgrading a flatpak, you can use the instructions given here https://docs.flatpak.org/en/latest/tips-and-tricks.html.

@progandy
Thanks for your answer. I didn't know that this is the way how flatpaks communicate with the OS. Maybe I'm just blind, but in my opinion it's relatively hard to find any information on how flatpaks integrate with the OS, Do you have any links?

Offline

#5 2020-01-25 14:56:45

progandy
Member
Registered: 2012-05-17
Posts: 3,686

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Ii think you have to look through github issues and the source code for more information...
https://github.com/flatpak/flatpak/issues/2721
https://github.com/flatpak/flatpak/pull/1757

Last edited by progandy (2020-01-25 15:03:26)


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#6 2020-01-25 16:11:51

hiciu
Member
Registered: 2010-08-11
Posts: 83

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

I'm having the same issue, no network connection with flatpaked Spotify and Slack, downgrading p11-kit has fixed it:

[2020-01-25T17:04:43+0100] [ALPM] downgraded p11-kit (0.23.19-1 -> 0.23.17-2)
[2020-01-25T17:04:44+0100] [ALPM] downgraded nss (3.49.2-1 -> 3.47.1-5)
[2020-01-25T17:04:44+0100] [ALPM] downgraded ca-certificates-utils (20181109-3 -> 20181109-2)
[2020-01-25T17:04:44+0100] [ALPM] downgraded ca-certificates-mozilla (3.49.2-1 -> 3.47.1-5)

Offline

#7 2020-01-26 12:22:09

monban
Member
Registered: 2020-01-26
Posts: 3

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Same problem here, ANY flatpak package that uses certificates is seems unable to validate to a trusted root. This includes Steam, Midori browser, Discord, etc.. I haven't tried downgrading yet, hoping for a quick fix (and I don't use flatpak apps every day so it's not a high priority for me right now).

Offline

#8 2020-01-26 19:46:15

jbob
Member
Registered: 2009-04-04
Posts: 3

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Same here, with Steam, Midori, Mattermost, Eolie.

Chrome works for some reason though, but this https://github.com/flatpak/flatpak/issu … -519628059 comment from a somewhat unrelated ticket implies that it can depende on multiple things (OpenSSL vs. GnuTLS vs. GLib sockets)


Please note that English is not my mother tongue.

Offline

#9 2020-01-27 06:02:45

monban
Member
Registered: 2020-01-26
Posts: 3

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

This issue is also being tracked / discussed on the Steam Flatpak Github.

Offline

#10 2020-01-30 05:56:25

monban
Member
Registered: 2020-01-26
Posts: 3

Re: p11-kit 0.23.19 causes issues for the flatpak version of Spotify

Quick update for anyone still having this issue, p11-kit 0.23.20-2 fixes the problem. It's currently in testing, so it should be moved to stable within the next few days. If you desperately need Discord / Steam / Spotify / Midori / etc. working right away, I have tested downloading the Testing version of the package and installing it with

pacman -U p11-kit-0.23.20-2-x86_64.pkg.tar.zst

it doesn't (seem to) cause any problems. Of course this is not recommended, so if you do it on your system and it breaks please don't blame me. If you wish to play it safe just wait a few days and you'll have it in Stable.

Offline

Board footer

Powered by FluxBB