You are not logged in.

#26 2020-01-20 09:40:26

ruggero.pintus
Member
Registered: 2020-01-20
Posts: 1

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

I had the same problem and the procedure suggested by dictummortuum #9 worked with the nvidia drivers 440.44-12.

Today, I have updated the nvidia driver to the version 440.44-13...and I got again the same problem.

I tried to install nvidia-utils-beta (as proposed by funnypigrun #15), but it didn't help.

I have Linux 5.4.12-arch1-1.
I don't have xf86-video-intel installed.

dictummortuum wrote:

Well, here's what worked for me:

- Installed latest nvidia-utils (important to do first, because it will update the file to be copied below)
- cp /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf /etc/X11/xorg.conf.d
- (for me, maybe not for other people) Edit /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and add the line 'Option "PrimaryGPU" "yes"' in it.
- sudo mkinitcpio -P (assuming that you've enabled the nvidia modules, as per the archlinux nvidia guide)
- reboot

Offline

#27 2020-01-20 09:45:38

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,201

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

If you have nvidia 440.44-13 and kernel 5.4.12 that means you have a module mismatch. Your kernel should be 5.4.13 with that nvidia version.

There are two components at play here, the change discussed in this thread only was relevant for configuration that was part of nvidia-utils. If you fixed that, either manually or doing (a not really reccomended, hold back/change of nvidia-utils) then this issue is "fixed". It cannot possibly resurface on plain nvidia package updates. But plain nvidia updates should usually be accompanied with a kernel update, otherwise your kernel module is out of date. To avoid mirror/packaging issues you could also opt for nvidia-dkms, which will mandate that the module is rebuilt for all kernels installed and will thus have increased installation time during pacman updates.

Online

#28 2020-01-20 22:35:09

Haystack
Member
Registered: 2019-01-16
Posts: 6

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

flatiron wrote:
dictummortuum wrote:

Well, here's what worked for me:

- Installed latest nvidia-utils (important to do first, because it will update the file to be copied below)
- cp /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf /etc/X11/xorg.conf.d
- (for me, maybe not for other people) Edit /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and add the line 'Option "PrimaryGPU" "yes"' in it.
- sudo mkinitcpio -P (assuming that you've enabled the nvidia modules, as per the archlinux nvidia guide)
- reboot

this worked perfect for me as well.  i can't believe this hasn't been announced as a breaking change.  i would think everyone with a laptop and a nvidia gpu would be affected....

Absolutely agreed.. It is not even easy to find these things in the forum because the forum site is so annoying to use... I'm subscribed to arch-announce and if this was on there it would've prevented me from just wasting my evening trying to figure out why my laptop's performance is so bad right now. This was affecting me for quite a while without me even realising that my dGPU wasn't even being used.

EDIT: This also caused me a bunch of inexplicable changes in display density across various applications. There's no way I could've guessed that it was caused by my dGPU no longer being used...

Last edited by Haystack (2020-01-20 22:43:57)

Offline

#29 2020-02-03 15:01:47

kyak
Member
Registered: 2012-01-20
Posts: 24

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

@grazzolini I really wonder what was you rationale when you decided that this was not worth a news item.

As you can see, this change has broken external monitor set up for several people. I was unlucky enough to find it out in front of the customer.

Offline

#30 2020-02-08 04:41:33

brad87
Member
Registered: 2016-03-07
Posts: 5

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

Is there any fix for this yet, I feel like the workaround has introduced a couple new bugs to my setup, especially when waking from sleep, or waking monitors on gdm login page.

Offline

#31 2020-02-08 09:08:59

seth
Member
Registered: 2012-09-03
Posts: 17,302

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

Which "workaround"? The suggestions in this thread merely restore that status quo ante.

Maybe you were originally running on the intel chip and now switched to the nvidia one?
Please elaborate on your setup: hardware, outputs, their connections, whether you configured GDM to run on Xorg and the nature of the "new bugs to my setup".

Offline

#32 2020-02-08 13:31:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,201

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

Also please open a new thread about any new/or resurfacing issues instead of misusing this one.

The problem and fix here is clearly defined, anything "new" that happens is unlikely to have a direct relation to this.

Last edited by V1del (2020-02-08 13:31:48)

Online

#33 2020-03-17 11:52:34

whoamiv2
Member
Registered: 2020-02-20
Posts: 1

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

dictummortuum wrote:

Well, here's what worked for me:

- Installed latest nvidia-utils (important to do first, because it will update the file to be copied below)
- cp /usr/share/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf /etc/X11/xorg.conf.d
- (for me, maybe not for other people) Edit /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf and add the line 'Option "PrimaryGPU" "yes"' in it.
- sudo mkinitcpio -P (assuming that you've enabled the nvidia modules, as per the archlinux nvidia guide)
- reboot

Installing nvidia-utils and adding 'Option "PrimaryGPU" "yes"' to etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf worked for me. Life saver. Thanks a lot!

Offline

#34 2020-06-03 18:00:20

finswimmer
Member
Registered: 2012-06-05
Posts: 9

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

Installing nvidia-utils and adding 'Option "PrimaryGPU" "yes"' to etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf worked for me.

This works for me now for monthes, but suddenly my external monitor on the display port (which uses the nvidia graphics card) isn't detect anymore. sad

Any ideas?

Offline

#35 2020-06-03 22:40:12

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 11,201

Re: Doesn't detect my external monitor after update to nvidia 440.44.8

Open a new thread, post your config and xorg.log and dmesg, there have not been any changes that would have an inherent effect on this behaviour.

Closing this old thread now.

Online

Board footer

Powered by FluxBB