You are not logged in.

#1 2019-03-01 07:36:37

hillbicks
Member
Registered: 2014-03-14
Posts: 14

[Kodi 18 standalone] How to disable display timeout/screensaver?

Hey everyone,

yesterday I updated my arch install to kodi 18. Since this update, although I'm not sure if the update to 18 is the reason or some other package, I'm having a problem with the display timeout or screensaver turning on.

kodi is started as standalone via systemd, meaning

/usr/bin/xinit /usr/bin/kodi-standalone -- :0 -nolisten tcp vt1

Following this wiki article I created /etc/X11/xorg.conf.d/10-monitor.conf with the following content:

Section "Extensions"
    Option      "DPMS" "Disable"
EndSection

but that hasn't made any difference so far.

Using the ExecStartPost section in the systemd file to use xset s off results in kodi not starting at all, since the display can not be found.

Using /etc/X11/xinit/xinitrc to set xset s off didn't work either, nor using ~/.xinitrc

So, if anyone has any tips for me, I would appreciate it.

Offline

#2 2019-03-01 09:30:18

graysky
Wiki Maintainer
From: :wq
Registered: 2008-12-01
Posts: 10,074
Website

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

I am confused by the title of your post.... running with the standalone service that uses an unprivileged user, the only screensaver you should have running would be one you defined in Kodi itself if any.  I assume this is not the case for you.  I recommend that you verifiy this behavior with a new Kodi profile, ie rename /vat/lib/kodi/ and create a new one with the correct permissions.  If you still find the behavior to happen, something else powersaving wise is likely at work.

You provided no hardware details.  Recommend you post in the Kodi forum and supply a Kodi debug log per their help policy.


CPU-optimized Linux-ck packages @ Repo-ck  • AUR packagesZsh and other configs

Offline

#3 2019-03-01 21:48:25

TheSgtBilko
Member
Registered: 2013-08-13
Posts: 57

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

@OP

On my system the update to KODI 18 Leia disabled the builtin "screensaver" in KODI. After that the TV would go into sleep when KODI was idling (not playing content). After enabling the "dim" screensaver add-on in KODI settings all was working as before update.

Offline

#4 2019-03-20 14:55:23

zynex
Member
Registered: 2019-03-20
Posts: 3

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

I actually have the same issue after upgrading to v18. After about 5 min it seems the signal turns of to my Onkyo receiver (where to projector is connected). This does however not happens when something is playing. Tried a clean profile to, but same happens. So it must be something within Kodi v18 (since v17 didn't do it).

Offline

#5 2019-03-26 18:40:36

imagames
Member
Registered: 2019-03-26
Posts: 1

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

I have the same problem since updating to Kodi 18, and it is very annoying.
No such problem was visible with v17.

On my installation the screensaver dim plugin is not disabled and seems to be effective after 3 minutes.
But after 10 minutes of inactivity, the screen goes completely blank.

When the screen goes blank, I completely loose control on the kodi instance with my remote.
The only workaround I found so far is to restart the kodi standalone service from the command line.

I tried the /etc/X11/xorg.conf.d/10-monitor.conf method, and also the  /etc/X11/xinit/xinitrc method, but none of them worked.

Offline

#6 2019-03-26 20:36:25

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,476

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

Kodi should have a setting for this, why search for crude workarounds when you can simply set it within kodi itself, does the setting not work?

Last edited by V1del (2019-03-26 20:40:05)

Offline

#7 2019-05-13 17:52:19

jsauer
Member
Registered: 2017-02-24
Posts: 2

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

No, in Kodi v18 "Leia" is a bug, that internal DPMS Setings does not work.

Offline

#8 2020-02-05 18:59:21

cinatic
Member
Registered: 2013-01-27
Posts: 12

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

did someone found a solution for it?

Offline

#9 2020-02-05 19:23:02

cinatic
Member
Registered: 2013-01-27
Posts: 12

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

i disabled DPMS as described in our wiki https://wiki.archlinux.org/index.php/Di … _Signaling and this worked for me

Offline

#10 2020-02-05 19:25:33

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,956
Website

Re: [Kodi 18 standalone] How to disable display timeout/screensaver?

Please don't necrobump. If this is still an issue (and https://bbs.archlinux.org/viewtopic.php … 8#p1834358 didn't help) please open a new topic.

https://wiki.archlinux.org/index.php/Co … bumping%22

Closing.

EDIT: Thank you for sharing your solution. If this information is missing from the wiki, please consider adding it.

Last edited by WorMzy (2020-02-05 19:27:05)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Online

Board footer

Powered by FluxBB