You are not logged in.

#1 2020-02-05 21:39:11

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

[SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Both Arch and zen kernels. I can no longer build kernel modules (dkms) including nvidia, it87 or virtualbox-host-modules. It's taken me an age to get back to a desktop boot (LXDM now fails to start X complaining about a missing fonts.directory, but starting xfce4 directly gets me here).

Right now, I have nvidia and the other kernel modules removed. If I try to install the dkms packages, I get

Error! Bad return status for module build on kernel: 5.5.2-arch2-1 (x86_64)

The same error, suitably modified for it87 and virtualbox, and both Arch and zen kernels.

I've tried downgrading the kernels, dkms packages, gcc and related packages that were are a part of the update, and I'm getting nowhere. I'm stumped!!

Ideas?

EDIT: This would appear to be relevant:

cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so
cc1: error: incompatible gcc/plugin versions
cc1: error: fail to initialize plugin ./scripts/gcc-plugins/structleak_plugin.so

EDIT 2

is this a sufficient mismatch:

gcc -v
Using built-in specs.
COLLECT_GCC=gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-pc-linux-gnu/9.2.1/lto-wrapper
Target: x86_64-pc-linux-gnu
Configured with: /build/gcc/src/gcc/configure --prefix=/usr --libdir=/usr/lib --libexecdir=/usr/lib --mandir=/usr/share/man --infodir=/usr/share/info --with-pkgversion='Arch Linux 9.2.1+20200130-2' --with-bugurl=https://bugs.archlinux.org/ --enable-languages=c,c++,ada,fortran,go,lto,objc,obj-c++,d --enable-shared --enable-threads=posix --with-system-zlib --with-isl --enable-__cxa_atexit --disable-libunwind-exceptions --enable-clocale=gnu --disable-libstdcxx-pch --disable-libssp --enable-gnu-unique-object --enable-linker-build-id --enable-lto --enable-plugin --enable-install-libiberty --with-linker-hash-style=gnu --enable-gnu-indirect-function --enable-multilib --disable-werror --enable-checking=release --enable-default-pie --enable-default-ssp --enable-cet=auto gdc_include_dir=/usr/include/dlang/gdc
Thread model: posix
gcc version 9.2.1 20200130 (Arch Linux 9.2.1+20200130-2)

?

EDIT 3:

Apparently it is. Downgrading gcc, gcc-libs, gcc-d and gcc-fortran to 20200130-1 has enabled the modules to build and LXDM to start as normal. Should I be posting a bug report somewhere?

Last edited by Roken (2020-02-06 19:10:08)


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#2 2020-02-05 21:51:55

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,871
Website

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Please change your topic title to one that actually describes your issue.

https://wiki.archlinux.org/index.php/Co … ow_to_post


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-02-05 22:09:36

loqs
Member
Registered: 2014-03-06
Posts: 11,221

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

https://git.archlinux.org/svntogit/pack … c4bda2c787
kernels were rebuilt for the new toolchain to prevent this issue but you did not update the kernel.

Offline

#4 2020-02-05 22:17:17

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

I did update the kernel, and I downgraded it again (which failed to resolve) so upgraded again. It seems the kernel (both Arch and zen) are built with -1, whilst gcc is built with -3.

@Wormzy - what would you like it to say - it's quite accurate from my perspective.

EDIT: For clarity - my only way in was chroot, and when I did get back to a "working" system. it was TTY only.

If this is a matter of repo sync, fine, though I don't do partial upgrades unless absolutely necessary, and I certainly haven't today.

Last edited by Roken (2020-02-05 22:19:03)


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#5 2020-02-05 22:32:40

loqs
Member
Registered: 2014-03-06
Posts: 11,221

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

5.5.2.arch2-1 is built with gcc-9.2.1+20200130-1 so the kernel needs another rebuild for 9.2.1+20200130-2

Last edited by loqs (2020-02-05 22:34:30)

Offline

#6 2020-02-05 22:34:02

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Exactly my point

gcc is up to 20200130-3, which breaks it all.

Last edited by Roken (2020-02-05 22:35:26)


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#7 2020-02-05 22:35:49

loqs
Member
Registered: 2014-03-06
Posts: 11,221

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Yes post a bug against linux asking for another rebuild assuming gcc will not be rebuilt again.

Offline

#8 2020-02-05 22:36:05

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

loqs wrote:

5.5.2.arch2-1 is built with gcc-9.2.1+20200130-1 so the kernel needs another rebuild for 9.2.1+20200130-2

Nope - 20200130-3


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#9 2020-02-05 22:37:20

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,871
Website

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Roken wrote:

@Wormzy - what would you like it to say

Something that describes actually your issue without any of the dramatics. If you are an actual corpse, then you have bigger problems than being unable to compile kernel modules.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#10 2020-02-05 22:38:08

loqs
Member
Registered: 2014-03-06
Posts: 11,221

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Offline

#11 2020-02-05 22:44:58

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

WorMzy wrote:
Roken wrote:

@Wormzy - what would you like it to say

Something that describes actually your issue without any of the dramatics. If you are an actual corpse, then you have bigger problems than being unable to compile kernel modules.

Since, when I posted, I had spent two hours just trying to get a working system, it was accurate. Now I've figured out the problem, edited.

Happy, now?

EDIT: And I would be quite happy being dead with iZombie smile

Last edited by Roken (2020-02-05 22:46:19)


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#12 2020-02-05 22:48:59

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

My error. I was looking through my cache - gcc7 was -3. I should really clear it out.

My apologies.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

#13 2020-02-05 22:52:41

loqs
Member
Registered: 2014-03-06
Posts: 11,221

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

Roken wrote:

My error. I was looking through my cache - gcc7 was -3. I should really clear it out.

My apologies.

No problem and my apologies for assuming you had not updated the kernel.

Offline

#14 2020-02-06 19:09:43

Roken
Member
From: UK
Registered: 2012-01-16
Posts: 1,077

Re: [SOLVED] Kernel 5.5.2 is built with the wrong version of gcc

I'll mark this issue as solved, but there's another. I've opened a separate thread.


[img=Speedtest]http://www.speedtest.net/my-result/5145583518[/img]

Ryzen 1800x 8 core/16 thread - GTX 1070 8Gb, Asus ROG STRIX B350-F, 16Gb Corsair DDR4, Cooler Master N300 chassis, 6 HD (1 NvME PCI, 2SSD, 3Spinners) + 1 x optical.
Linux user #545703

Offline

Board footer

Powered by FluxBB