You are not logged in.

#1 2020-02-07 08:31:47

SunnyFlopper
Member
Registered: 2020-02-02
Posts: 7

[SOLVED] .py error: the following arguments are required

New to linux & trying to run program "theharvester" & keep getting this error

$ theharvester

*******************************************************************
*  _   _                                            _             *
* | |_| |__   ___    /\  /\__ _ _ ____   _____  ___| |_ ___ _ __  *
* | __|  _ \ / _ \  / /_/ / _` | '__\ \ / / _ \/ __| __/ _ \ '__| *
* | |_| | | |  __/ / __  / (_| | |   \ V /  __/\__ \ ||  __/ |    *
*  \__|_| |_|\___| \/ /_/ \__,_|_|    \_/ \___||___/\__\___|_|    *
*                                                                 *
* theHarvester 3.1.1dev3                                          *
* Coded by Christian Martorella                                   *
* Edge-Security Research                                          *
* cmartorella@edge-security.com                                   *
*                                                                 *
*******************************************************************


usage: theHarvester.py [-h] -d DOMAIN [-l LIMIT] [-S START] [-g] [-p] [-s] [-v] [-e DNS_SERVER] [-t DNS_TLD] [-n] [-c]
                                      [-f FILENAME] [-b SOURCE]
theHarvester.py: error: the following arguments are required: -d/--domain

The program then closes itself & brings me back to the terminal

Last edited by SunnyFlopper (2020-02-08 09:35:15)

Offline

#2 2020-02-07 08:55:10

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,397
Website

Re: [SOLVED] .py error: the following arguments are required

And? That is a pretty clear error message.

What is your question?

Out of interest, how did you install this application?

Mod note: moving to AUR Issues


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-02-07 09:00:03

SunnyFlopper
Member
Registered: 2020-02-02
Posts: 7

Re: [SOLVED] .py error: the following arguments are required

Thanks for the reply. The problem is that I don't know how to proceed, i know it may be stupid but idk what the error means.

I installed the program with yay

Offline

#4 2020-02-07 09:11:56

SunnyFlopper
Member
Registered: 2020-02-02
Posts: 7

Re: [SOLVED] .py error: the following arguments are required

I did forget to mention, Idk if it was the right thing to try but I tried to run the program as "theharvester -d" & "theharvester --domain" but it gave me a different error

theHarvester.py: error: argument -d/--domain: expected one argument

Last edited by SunnyFlopper (2020-02-07 09:13:17)

Offline

#5 2020-02-07 11:08:54

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,706

Re: [SOLVED] .py error: the following arguments are required

run theharvester -h .

If that doesn't help, do a search with theharvester and example as keywords.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

Board footer

Powered by FluxBB