You are not logged in.

#1 2020-02-09 21:49:06

Registered: 2015-07-24
Posts: 9

loadkeys fails in 2020.02.01 installation live environment?


I'm running the 2020.02.01 live installation environment.

I've found that loadkeys 2.2.0 included in the environment is apparently
not working the way I expect.  For instance, if I do

    # cd /usr/share/kbd/keymaps/i386/qwerty/
    (decompress and edit a copy of as
    # loadkeys us-ctrl_capslock
    can't open 'qwerty-layout', because kbdfile already opened: ../include/

Similarly, 'loadkeys us' gives the same error.

I believe this is new since the last time I tried this.  It seems to be related to the
use of the line

    include "qwerty-layout"

in  loadkeys does not complain with some of the other keymaps such as which lack
this line.   Is there a way to tell 'loadkeys' to 'start from scratch' so that the (re-)inclusion of
qwerty-layout will not bother it?  Neither the '-c' nor '-s' options seems to do the trick.
Alternatively, is there another way to write the file so that it works either incrementally or 'from scratch'?

For a temporary effect I can comment out all of the 'include' lines in
that were in, but I presume that would not work for persistent saving of the edited file.


#2 2020-09-09 22:21:02

From: Finland
Registered: 2007-02-11
Posts: 11

Re: loadkeys fails in 2020.02.01 installation live environment?

Make sure you don't have syntax errors in the map files.


#3 2020-09-09 22:26:13

Forum Moderator
Registered: 2012-01-15
Posts: 3,531

Re: loadkeys fails in 2020.02.01 installation live environment?

This thread refers to an iso from February. The OP has not been here since April. I am going to close this now -- dank, if you come back and are still having problems with the current iso, please open a new thread.

"The prettier the user interface, and the fewer odd replies the system allows you to make, the dumber you once appeared in the mind of the designer." -- Ellen Ullman
How to post


Board footer

Powered by FluxBB