You are not logged in.

#1 2017-02-22 14:53:47

Registered: 2012-03-20
Posts: 32

[SOLVED] Problem with Parcellite (core dumped)


After changing the settings in parcellite today (v1.2.1-2) it crashed and ever since was not able to start up. The failure looked somehow like:

$ parcellite 
Flag 0x0001, status 0, EXIT 1 STAT 0
some text magic! Assume no history.
Attempt to unlock mutex that was not locked
Aborted (core dumped)

A reboot as well as removing and reinstalling did not work. After googling around I found no solution but lucky enough had btrfs with snapper enabled. So the only difference between the working and the not working version was the history file for parcellite missing. Restored the file to


and parcellite just started up flawlessly. I guess an empty file would also do it (chmod 640 <file> / chown whoami:whoami <file>)

Maybe that helps someone with the same or similar troubles smile


#2 2020-02-12 02:35:03

Registered: 2014-08-30
Posts: 11

Re: [SOLVED] Problem with Parcellite (core dumped)

Thanks bro. I met the same problem. But simply changed "history" file do not work for my situation. So I remove the whole directory($HOME/.local/share/parcellite), and the app work again.


#3 2020-02-12 08:20:54

Forum Moderator
Registered: 2012-10-16
Posts: 8,712

Re: [SOLVED] Problem with Parcellite (core dumped)

Glad to hear, however please don't necro bump 3 year old topics.



Board footer

Powered by FluxBB