You are not logged in.

#1 2019-12-14 13:56:52

rianquinn
Member
Registered: 2019-08-20
Posts: 7

Drag and Drop not working in Gnome

I am having issues with Drag and Drop in Gnome, and I am not sure how to even go about debugging this. Drag and Drop in Nautilus works fine. But if I drag a file from Firefox into Nautilus, it works the first time and then stops. Once that happens, I can not longer drag anything from Firefox (not even links). Its like drag just stops working completely (in Firefox). Nautilus continues to work fine within itself. I also cannot drag files from Nautilus into VSCode. VSCode appears to be attempting to accept the drop (the window changes color like it normally would). But when I drop, nothing happens. Drag and Drop to Gedit works without an issue as well, so it seems to be limited to drag and drop between Gnome apps and non-gnome apps.

Any thoughts? Is there a log somewhere I can look at? Am I missing some package or service? I basically just installed the gnome group, with firefox and some fonts and was able to repro.

Offline

#2 2019-12-14 13:59:07

rianquinn
Member
Registered: 2019-08-20
Posts: 7

Re: Drag and Drop not working in Gnome

Also... I did the same testing on Fedora 31 with the same versions of Firefox, VSCode and Gnome and everything works fine. This seems to be specific to Arch and my install of it.

Offline

#3 2019-12-14 14:57:28

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 451

Re: Drag and Drop not working in Gnome

It's not just you. I use GNOME on Wayland and I also noticed that recently I have been unable to drag files from Nautilus and drop in to Chromium, e.g. dropping a file onto an email to attach it. Previously has been working fine and still works fine if I use GNOME on Xorg.

Last edited by bulletmark (2019-12-14 14:58:47)

Offline

#4 2019-12-14 16:25:56

rianquinn
Member
Registered: 2019-08-20
Posts: 7

Re: Drag and Drop not working in Gnome

That's not at all what I wanted to here

Offline

#5 2020-01-06 03:17:53

sudoer
Member
Registered: 2019-03-05
Posts: 6

Re: Drag and Drop not working in Gnome

So, is the solution to this to use Xorg instead of wayland?

Offline

#6 2020-01-09 15:07:38

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,053

Re: Drag and Drop not working in Gnome

levin reported wrote:

yes. drag and drop works fine on Xorg .

The same problem puzzles me for more than a month, becasue I run wayland...

Leviin:  If you are wondering where your post went, I think you meant to reply rather than report....


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#7 2020-01-09 22:05:19

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 451

Re: Drag and Drop not working in Gnome

Please go and add a vote on this bug.

Offline

#8 2020-01-12 02:59:39

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 451

Re: Drag and Drop not working in Gnome

@rianquinn, you raised a bug on GNOME gitlab about this issue but the title is flawed so can you please fix it?

Offline

#9 2020-02-14 01:12:50

bulletmark
Member
From: Brisbane, Australia
Registered: 2013-10-22
Posts: 451

Re: Drag and Drop not working in Gnome

According to the bug, this was not to be fixed until mutter 3.34.4 but it seems to be fixed on Arch now, presumably since mutter update 3.34.3+14+g59e9b073a-1 -> 3.34.3+30+g4959ae8bc-1 about 10 days ago. So I am not sure why we have the fix, but thanks somebody!

Last edited by bulletmark (2020-02-14 01:13:10)

Offline

Board footer

Powered by FluxBB