You are not logged in.

#1 2020-02-15 23:58:26

digitalone
Member
Registered: 2011-08-19
Posts: 278

Locale settings are not applied and Plasma is interfering

Today I noticed that PulseEffects is not shown in Italian anymore, but in English.  That occurred after Plasma and glib update, but I don't know which one is the culprit.

I have:

[***]$ locale -a
C
it_IT.utf8
POSIX
[***]$ locale
LANG=it_IT.UTF-8
LC_CTYPE="it_IT.UTF-8"
LC_NUMERIC="it_IT.UTF-8"
LC_TIME="it_IT.UTF-8"
LC_COLLATE="it_IT.UTF-8"
LC_MONETARY="it_IT.UTF-8"
LC_MESSAGES="it_IT.UTF-8"
LC_PAPER="it_IT.UTF-8"
LC_NAME="it_IT.UTF-8"
LC_ADDRESS="it_IT.UTF-8"
LC_TELEPHONE="it_IT.UTF-8"
LC_MEASUREMENT="it_IT.UTF-8"
LC_IDENTIFICATION="it_IT.UTF-8"
LC_ALL=
[***]$ localectl
   System Locale: LANG=it_IT.UTF-8
       VC Keymap: it
      X11 Layout: n/a

LANG=it_IT.UTF-8 in /etc/locale.conf and it_IT.UTF-8 UTF-8 decommented in /etc/locale.gen.

But only PulseEffects is in English. Even if I start it with

LANG=it_IT.UTF-8 pulseeffects

Anyway, playing with locale, I noticed that Plasma is applying options in systemsetting5, overriding what's set in /etc/locale.conf. In fact, if C is set in systemsettings5, locale command shows all C, not it_IT.UTF-8.

So I set Italian in systemsettings5, but PulseEffects is still in English.

Maybe Plasma is interfering in a bad way and it cannot apply Italian locale in PulseEffects. I'm out of options, don't know what to do.

Offline

#2 2020-02-16 00:53:45

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 725

Re: Locale settings are not applied and Plasma is interfering

Plasma indeed overrides locale settings by running the scrips in ~/.config/plasma-locale-settings.sh on session start.
Reason being that since Qt5, Qt uses locales as defined by ICU standard (libicu), not those that are provided by GNU C library (glibc). And since Plasma translations are based on QLocale, you can imagine how well it goes when locale codes differ between standards (I believe that ICU knows only about it locale, but not about it_IT).

Online

#3 2020-02-16 01:00:35

digitalone
Member
Registered: 2011-08-19
Posts: 278

Re: Locale settings are not applied and Plasma is interfering

Xabre wrote:

Plasma indeed overrides locale settings by running the scrips in ~/.config/plasma-locale-settings.sh on session start.
Reason being that since Qt5, Qt uses locales as defined by ICU standard (libicu), not those that are provided by GNU C library (glibc). And since Plasma translations are based on QLocale, you can imagine how well it goes when locale codes differ between standards (I believe that ICU knows only about it locale, but not about it_IT).

I don't have that script, already deleted months ago just because it was messing with PulseEffects.

And PulseEffects is following locale by glibc.

So now the question is: can I do something to stop Plasma interfering and keeping PulseEffects in Italian?

Last edited by digitalone (2020-02-16 01:01:09)

Offline

#4 2020-02-16 10:36:29

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 10,407

Re: Locale settings are not applied and Plasma is interfering

if you start it in a terminal is there any output regarding what it does with locale? FWIW my PulseEffects is in german as expected. I really don't think that this is inherently a plasma issue. Or do you have plasma configured in english but want pulseeffects explicitly in italian?

Offline

#5 2020-02-16 16:09:55

digitalone
Member
Registered: 2011-08-19
Posts: 278

Re: Locale settings are not applied and Plasma is interfering

V1del wrote:

if you start it in a terminal is there any output regarding what it does with locale? FWIW my PulseEffects is in german as expected. I really don't think that this is inherently a plasma issue. Or do you have plasma configured in english but want pulseeffects explicitly in italian?

Nothing reported in terminal.

Your pulseeffects is in German, but try to apply new settings in GTK section inside systemsettings5, especially the default GTK3 theme. Reboot and you will see that PulseEffects will be always started in English.

Already tried on my laptop and another one. I resolved deleting all Plasma configuration files under $HOME/.config and after rebooting PulseEffects is in Italian, but this time I won't apply GTK settings since it will break again.

It's a Plasma issue, as usual after an update.

Last edited by digitalone (2020-02-16 17:19:42)

Offline

#6 2020-02-16 19:24:37

digitalone
Member
Registered: 2011-08-19
Posts: 278

Re: Locale settings are not applied and Plasma is interfering

Reproduced on another system.

PulseEffects in Italian. Apply GTK theme in systemsettings5. Reboot, PulseEffects in English.

Delete all Plasma config files. Reboot, PulseEffects correctly in Italian.

Offline

Board footer

Powered by FluxBB