You are not logged in.

#1 2020-02-19 18:10:53

zw963
Member
Registered: 2018-06-18
Posts: 108

pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

Following is the command which i run today:

pacman -Syu
pacman -Qdttq | sudo pacman -Rns -

After this time update, beyond compare 4.3.3 crashed only when open
text compare panel. (it working when open folder compare panel, but
will crash when open text compare)

I know maybe this is a unexpected behavior should not be assure by arch linux.
and mostly should be fixed by scootersoftware(https://www.scootersoftware.com/)
but, anyway, i report here too.

Following is maybe useful crash log:

BcVersion: 4.3.3 (pro build 24545)
BcExe: /home/public/Dropbox/linux/utils/bc3/bin.real.4/BCompare
BcSettings: /home/zw963/.config/bcompare

2020年02月20日 上午 01时56分37秒 上午
Beyond Compare Version 4.3.3 (build 24545)
Exception occurred at: 0000000000000008
EAccessViolation: Access violation
  $0000000000000008   .


58303 (Main Thread LWP - Failed - see top trace)
58306 (Child Thread LWP):

  $0000000000000001   

58307 (Child Thread LWP):

  $00007FB5D63B9400   

58341 (Child Thread LWP):

  $00000000017A3EA0   bcomp4 ($0000000000400000) dos.pp line 1667



Name:  BCompare
Umask:  0022
State:  S (sleeping)
Tgid:  58303
Ngid:  0
Pid:  58303
PPid:  58299
TracerPid:  0
Uid:  1000  1000  1000  1000
Gid:  1000  1000  1000  1000
FDSize:  256
Groups:  94 96 98 108 281 986 991 993 994 995 998 1000 
NStgid:  58303
NSpid:  58303
NSpgid:  58299
NSsid:  17991
VmPeak:    375272 kB
VmSize:    375272 kB
VmLck:         0 kB
VmPin:         0 kB
VmHWM:     95944 kB
VmRSS:     95944 kB
RssAnon:     80440 kB
RssFile:     15504 kB
RssShmem:         0 kB
VmData:    102880 kB
VmStk:       164 kB
VmExe:      7124 kB
VmLib:     56564 kB
VmPTE:       312 kB
VmSwap:         0 kB
HugetlbPages:         0 kB
CoreDumping:  0
THP_enabled:  1
Threads:  4
SigQ:  1/62801
SigPnd:  0000000000000000
ShdPnd:  0000000000000000
SigBlk:  0000000000000080
SigIgn:  0000000000000000
SigCgt:  00000001800104c8
CapInh:  0000000000000000
CapPrm:  0000000000000000
CapEff:  0000000000000000
CapBnd:  0000003fffffffff
CapAmb:  0000000000000000
NoNewPrivs:  0
Seccomp:  0
Speculation_Store_Bypass:  thread vulnerable
Cpus_allowed:  ff
Cpus_allowed_list:  0-7
Mems_allowed:  00000001
Mems_allowed_list:  0
voluntary_ctxt_switches:  235
nonvoluntary_ctxt_switches:  2

00400000-01473000 r-xp 00000000 00:00 0 
01473000-01672000 ---p 00000000 00:00 0 
01672000-01673000 r-xp 00000000 00:00 0 
01673000-0236f000 rwxp 00000000 00:00 0 
02400000-02401000 rwxp 00000000 00:00 0 
02f08000-04b1b000 rwxp 00000000 00:00 0                                  [heap]
7fb5c3046000-7fb5c393a000 r-xp 00000000 08:04 404447                     /usr/share/fonts/noto/NotoColorEmoji.ttf
7fb5c393a000-7fb5c3bbe000 rwxp 00000000 00:00 0 
7fb5c3bbe000-7fb5c3c3a000 r-xp 00000000 08:04 403268                     /usr/share/fonts/noto/NotoSans-Medium.ttf
7fb5c3c3a000-7fb5c4000000 rwxp 00000000 00:00 0 
7fb5c4000000-7fb5c4021000 rwxp 00000000 00:00 0 
7fb5c4021000-7fb5c8000000 ---p 00000000 00:00 0 
7fb5c8000000-7fb5c8021000 rwxp 00000000 00:00 0 
7fb5c8021000-7fb5cc000000 ---p 00000000 00:00 0 
7fb5cc000000-7fb5cc021000 rwxp 00000000 00:00 0 
7fb5cc021000-7fb5d0000000 ---p 00000000 00:00 0 
7fb5d0029000-7fb5d008b000 rwxp 00000000 00:00 0 
7fb5d00ed000-7fb5d04d5000 rwxp 00000000 00:00 0 
7fb5d0527000-7fb5d0528000 ---p 00000000 00:00 0 
7fb5d0528000-7fb5d0928000 rwxp 00000000 00:00 0 
7fb5d0928000-7fb5d0929000 ---p 00000000 00:00 0 
7fb5d0929000-7fb5d0d29000 rwxp 00000000 00:00 0 
7fb5d0d29000-7fb5d0d70000 r-xp 00000000 103:02 17832942                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libunrar.so
7fb5d0d70000-7fb5d0f6f000 ---p 00047000 103:02 17832942                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libunrar.so
7fb5d0f6f000-7fb5d0f70000 r-xp 00046000 103:02 17832942                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libunrar.so
7fb5d0f70000-7fb5d0f72000 rwxp 00047000 103:02 17832942                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libunrar.so
7fb5d0f72000-7fb5d10c3000 rwxp 00000000 00:00 0 
7fb5d10c3000-7fb5d10c4000 ---p 00000000 00:00 0 
7fb5d10c4000-7fb5d14c4000 rwxp 00000000 00:00 0 
7fb5d14c4000-7fb5d14ca000 r-xp 00000000 08:04 2782896                    /usr/lib/libXfixes.so.3.1.0
7fb5d14ca000-7fb5d14cb000 ---p 00006000 08:04 2782896                    /usr/lib/libXfixes.so.3.1.0
7fb5d14cb000-7fb5d14cc000 r-xp 00006000 08:04 2782896                    /usr/lib/libXfixes.so.3.1.0
7fb5d14cc000-7fb5d14cd000 rwxp 00007000 08:04 2782896                    /usr/lib/libXfixes.so.3.1.0
7fb5d14cd000-7fb5d14d7000 r-xp 00000000 08:04 2783412                    /usr/lib/libXcursor.so.1.0.2
7fb5d14d7000-7fb5d14d8000 r-xp 00009000 08:04 2783412                    /usr/lib/libXcursor.so.1.0.2
7fb5d14d8000-7fb5d14d9000 rwxp 0000a000 08:04 2783412                    /usr/lib/libXcursor.so.1.0.2
7fb5d14d9000-7fb5d35f0000 rwxp 00000000 00:00 0 
7fb5d35f0000-7fb5d35fb000 r-xp 00000000 08:04 2783458                    /usr/lib/libXrandr.so.2.2.0
7fb5d35fb000-7fb5d35fc000 r-xp 0000a000 08:04 2783458                    /usr/lib/libXrandr.so.2.2.0
7fb5d35fc000-7fb5d35fd000 rwxp 0000b000 08:04 2783458                    /usr/lib/libXrandr.so.2.2.0
7fb5d3636000-7fb5d363c000 rwxp 00000000 00:00 0 
7fb5d363c000-7fb5d363f000 r-xs 00000000 08:04 663734                     /var/cache/fontconfig/1876b2dcf508980ebba421dbe8e808d3-le64.cache-7
7fb5d363f000-7fb5d3641000 r-xs 00000000 08:04 663733                     /var/cache/fontconfig/699564f050ff7e0f9dae359f33bc56a5-le64.cache-7
7fb5d3641000-7fb5d3643000 r-xs 00000000 08:04 663736                     /var/cache/fontconfig/5df9eba3d3f2d3afe4369d5c874815ce-le64.cache-7
7fb5d3643000-7fb5d3647000 r-xs 00000000 08:04 663735                     /var/cache/fontconfig/43166cb5203093156c760aa2c7b8b314-le64.cache-7
7fb5d3647000-7fb5d3714000 r-xs 00000000 08:04 658986                     /var/cache/fontconfig/923e285e415b1073c8df160bee08820f-le64.cache-7
7fb5d3714000-7fb5d3722000 r-xs 00000000 08:04 663731                     /var/cache/fontconfig/491f45a0a771fef1c10b9b647a97fb82-le64.cache-7
7fb5d3722000-7fb5d3735000 r-xs 00000000 08:04 663730                     /var/cache/fontconfig/614d1caaa4d7914789410f6367de37ca-le64.cache-7
7fb5d3735000-7fb5d3d1c000 r-xp 00000000 08:04 2809838                    /usr/lib/locale/locale-archive
7fb5d3d1c000-7fb5d3e64000 rwxp 00000000 00:00 0 
7fb5d3e64000-7fb5d3e86000 r-xp 00000000 08:04 2783027                    /usr/lib/libgraphite2.so.3.2.1
7fb5d3e86000-7fb5d3e88000 r-xp 00021000 08:04 2783027                    /usr/lib/libgraphite2.so.3.2.1
7fb5d3e88000-7fb5d3e89000 rwxp 00023000 08:04 2783027                    /usr/lib/libgraphite2.so.3.2.1
7fb5d3e89000-7fb5d3eb5000 r-xp 00000000 08:04 2765960                    /usr/lib/libexpat.so.1.6.11
7fb5d3eb5000-7fb5d3eb6000 ---p 0002c000 08:04 2765960                    /usr/lib/libexpat.so.1.6.11
7fb5d3eb6000-7fb5d3eb8000 r-xp 0002c000 08:04 2765960                    /usr/lib/libexpat.so.1.6.11
7fb5d3eb8000-7fb5d3eb9000 rwxp 0002e000 08:04 2765960                    /usr/lib/libexpat.so.1.6.11
7fb5d3eb9000-7fb5d3fba000 r-xp 00000000 08:04 2791060                    /usr/lib/libharfbuzz.so.0.20600.4
7fb5d3fba000-7fb5d3fbb000 ---p 00101000 08:04 2791060                    /usr/lib/libharfbuzz.so.0.20600.4
7fb5d3fbb000-7fb5d3fbc000 r-xp 00101000 08:04 2791060                    /usr/lib/libharfbuzz.so.0.20600.4
7fb5d3fbc000-7fb5d3fbd000 rwxp 00102000 08:04 2791060                    /usr/lib/libharfbuzz.so.0.20600.4
7fb5d3fbd000-7fb5d3ff3000 r-xp 00000000 08:04 2783008                    /usr/lib/libpng16.so.16.37.0
7fb5d3ff3000-7fb5d3ff4000 r-xp 00035000 08:04 2783008                    /usr/lib/libpng16.so.16.37.0
7fb5d3ff4000-7fb5d3ff5000 rwxp 00036000 08:04 2783008                    /usr/lib/libpng16.so.16.37.0
7fb5d3ff5000-7fb5d4066000 r-xp 00000000 08:04 2769258                    /usr/lib/libpcre.so.1.2.11
7fb5d4066000-7fb5d4067000 r-xp 00070000 08:04 2769258                    /usr/lib/libpcre.so.1.2.11
7fb5d4067000-7fb5d4068000 rwxp 00071000 08:04 2769258                    /usr/lib/libpcre.so.1.2.11
7fb5d4068000-7fb5d406a000 rwxp 00000000 00:00 0 
7fb5d406a000-7fb5d4070000 r-xp 00000000 08:04 2779540                    /usr/lib/libXdmcp.so.6.0.0
7fb5d4070000-7fb5d4071000 r-xp 00005000 08:04 2779540                    /usr/lib/libXdmcp.so.6.0.0
7fb5d4071000-7fb5d4072000 rwxp 00006000 08:04 2779540                    /usr/lib/libXdmcp.so.6.0.0
7fb5d4072000-7fb5d4075000 r-xp 00000000 08:04 2779544                    /usr/lib/libXau.so.6.0.0
7fb5d4075000-7fb5d4076000 r-xp 00002000 08:04 2779544                    /usr/lib/libXau.so.6.0.0
7fb5d4076000-7fb5d4077000 rwxp 00003000 08:04 2779544                    /usr/lib/libXau.so.6.0.0
7fb5d4077000-7fb5d408a000 r-xp 00000000 08:04 2782754                    /usr/lib/libXext.so.6.4.0
7fb5d408a000-7fb5d408b000 r-xp 00012000 08:04 2782754                    /usr/lib/libXext.so.6.4.0
7fb5d408b000-7fb5d408c000 rwxp 00013000 08:04 2782754                    /usr/lib/libXext.so.6.4.0
7fb5d408c000-7fb5d40d0000 r-xp 00000000 08:04 2783131                    /usr/lib/libfontconfig.so.1.12.0
7fb5d40d0000-7fb5d40d1000 ---p 00044000 08:04 2783131                    /usr/lib/libfontconfig.so.1.12.0
7fb5d40d1000-7fb5d40d3000 r-xp 00044000 08:04 2783131                    /usr/lib/libfontconfig.so.1.12.0
7fb5d40d3000-7fb5d40d4000 rwxp 00046000 08:04 2783131                    /usr/lib/libfontconfig.so.1.12.0
7fb5d40d4000-7fb5d40df000 r-xp 00000000 08:04 2783017                    /usr/lib/libXrender.so.1.3.0
7fb5d40df000-7fb5d40e0000 r-xp 0000a000 08:04 2783017                    /usr/lib/libXrender.so.1.3.0
7fb5d40e0000-7fb5d40e1000 rwxp 0000b000 08:04 2783017                    /usr/lib/libXrender.so.1.3.0
7fb5d40e1000-7fb5d41a6000 r-xp 00000000 08:04 2783126                    /usr/lib/libfreetype.so.6.17.1
7fb5d41a6000-7fb5d41a7000 ---p 000c5000 08:04 2783126                    /usr/lib/libfreetype.so.6.17.1
7fb5d41a7000-7fb5d41ae000 r-xp 000c5000 08:04 2783126                    /usr/lib/libfreetype.so.6.17.1
7fb5d41ae000-7fb5d41af000 rwxp 000cc000 08:04 2783126                    /usr/lib/libfreetype.so.6.17.1
7fb5d41af000-7fb5d41b1000 rwxp 00000000 00:00 0 
7fb5d41b1000-7fb5d42d3000 r-xp 00000000 08:04 2769447                    /usr/lib/libglib-2.0.so.0.6200.4
7fb5d42d3000-7fb5d42d4000 r-xp 00121000 08:04 2769447                    /usr/lib/libglib-2.0.so.0.6200.4
7fb5d42d4000-7fb5d42d5000 rwxp 00122000 08:04 2769447                    /usr/lib/libglib-2.0.so.0.6200.4
7fb5d42d5000-7fb5d42d6000 rwxp 00000000 00:00 0 
7fb5d42d6000-7fb5d42d9000 r-xp 00000000 08:04 2769460                    /usr/lib/libgthread-2.0.so.0.6200.4
7fb5d42d9000-7fb5d42da000 r-xp 00002000 08:04 2769460                    /usr/lib/libgthread-2.0.so.0.6200.4
7fb5d42da000-7fb5d42db000 rwxp 00003000 08:04 2769460                    /usr/lib/libgthread-2.0.so.0.6200.4
7fb5d42db000-7fb5d441f000 r-xp 00000000 08:04 2755998                    /usr/lib/libm-2.31.so
7fb5d441f000-7fb5d4420000 r-xp 00143000 08:04 2755998                    /usr/lib/libm-2.31.so
7fb5d4420000-7fb5d4421000 rwxp 00144000 08:04 2755998                    /usr/lib/libm-2.31.so
7fb5d4421000-7fb5d4449000 r-xp 00000000 08:04 2779625                    /usr/lib/libxcb.so.1.1.0
7fb5d4449000-7fb5d444a000 r-xp 00027000 08:04 2779625                    /usr/lib/libxcb.so.1.1.0
7fb5d444a000-7fb5d444b000 rwxp 00028000 08:04 2779625                    /usr/lib/libxcb.so.1.1.0
7fb5d444b000-7fb5d44b0000 r-xp 00000000 103:02 18356258                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtCore.so.4
7fb5d44b0000-7fb5d4720000 r-xp 00000000 00:00 0 
7fb5d4720000-7fb5d491f000 ---p 002d5000 103:02 18356258                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtCore.so.4
7fb5d491f000-7fb5d492f000 rwxp 00144000 103:02 18356258                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtCore.so.4
7fb5d492f000-7fb5d4931000 rwxp 00000000 00:00 0 
7fb5d4931000-7fb5d4aff000 r-xp 00000000 103:02 18356263                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtGui.so.4
7fb5d4aff000-7fb5d53d0000 r-xp 00000000 00:00 0 
7fb5d53d0000-7fb5d55cf000 ---p 00a9f000 103:02 18356263                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtGui.so.4
7fb5d55cf000-7fb5d5624000 rwxp 0059e000 103:02 18356263                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/qt4/libQtGui.so.4
7fb5d5624000-7fb5d5626000 rwxp 00000000 00:00 0 
7fb5d5626000-7fb5d563e000 r-xp 00000000 08:04 2755994                    /usr/lib/libgcc_s.so.1
7fb5d563e000-7fb5d563f000 r-xp 00017000 08:04 2755994                    /usr/lib/libgcc_s.so.1
7fb5d563f000-7fb5d5640000 rwxp 00018000 08:04 2755994                    /usr/lib/libgcc_s.so.1
7fb5d5640000-7fb5d5818000 r-xp 00000000 08:04 2756723                    /usr/lib/libstdc++.so.6.0.28
7fb5d5818000-7fb5d5825000 r-xp 001d7000 08:04 2756723                    /usr/lib/libstdc++.so.6.0.28
7fb5d5825000-7fb5d5826000 rwxp 001e4000 08:04 2756723                    /usr/lib/libstdc++.so.6.0.28
7fb5d5826000-7fb5d5829000 rwxp 00000000 00:00 0 
7fb5d5829000-7fb5d5840000 r-xp 00000000 08:04 2766910                    /usr/lib/libz.so.1.2.11
7fb5d5840000-7fb5d5841000 ---p 00017000 08:04 2766910                    /usr/lib/libz.so.1.2.11
7fb5d5841000-7fb5d5842000 r-xp 00017000 08:04 2766910                    /usr/lib/libz.so.1.2.11
7fb5d5842000-7fb5d5843000 rwxp 00018000 08:04 2766910                    /usr/lib/libz.so.1.2.11
7fb5d5843000-7fb5d597c000 r-xp 00000000 08:04 2756719                    /usr/lib/libX11.so.6.3.0
7fb5d597c000-7fb5d597f000 r-xp 00138000 08:04 2756719                    /usr/lib/libX11.so.6.3.0
7fb5d597f000-7fb5d5983000 rwxp 0013b000 08:04 2756719                    /usr/lib/libX11.so.6.3.0
7fb5d5983000-7fb5d5b62000 r-xp 00000000 103:02 17433119                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libQt4Pas.so.5
7fb5d5b62000-7fb5d5d62000 ---p 001df000 103:02 17433119                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libQt4Pas.so.5
7fb5d5d62000-7fb5d5d68000 r-xp 001df000 103:02 17433119                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libQt4Pas.so.5
7fb5d5d68000-7fb5d5d72000 rwxp 001e5000 103:02 17433119                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/libQt4Pas.so.5
7fb5d5d72000-7fb5d5d74000 rwxp 00000000 00:00 0 
7fb5d5d74000-7fb5d5d77000 r-xp 00000000 08:04 2755989                    /usr/lib/libdl-2.31.so
7fb5d5d77000-7fb5d5d78000 r-xp 00002000 08:04 2755989                    /usr/lib/libdl-2.31.so
7fb5d5d78000-7fb5d5d79000 rwxp 00003000 08:04 2755989                    /usr/lib/libdl-2.31.so
7fb5d5d79000-7fb5d5f35000 r-xp 00000000 08:04 2755969                    /usr/lib/libc-2.31.so
7fb5d5f35000-7fb5d5f38000 r-xp 001bb000 08:04 2755969                    /usr/lib/libc-2.31.so
7fb5d5f38000-7fb5d5f3b000 rwxp 001be000 08:04 2755969                    /usr/lib/libc-2.31.so
7fb5d5f3b000-7fb5d5f3f000 rwxp 00000000 00:00 0 
7fb5d5f3f000-7fb5d5f5b000 r-xp 00000000 08:04 2756037                    /usr/lib/libpthread-2.31.so
7fb5d5f5b000-7fb5d5f5c000 r-xp 0001b000 08:04 2756037                    /usr/lib/libpthread-2.31.so
7fb5d5f5c000-7fb5d5f5d000 rwxp 0001c000 08:04 2756037                    /usr/lib/libpthread-2.31.so
7fb5d5f5d000-7fb5d5f61000 rwxp 00000000 00:00 0 
7fb5d5f61000-7fb5d617a000 r-xp 00000000 103:02 17433121                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/lib7z.so
7fb5d617a000-7fb5d637a000 ---p 00219000 103:02 17433121                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/lib7z.so
7fb5d637a000-7fb5d638d000 r-xp 00219000 103:02 17433121                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/lib7z.so
7fb5d638d000-7fb5d6391000 rwxp 0022c000 103:02 17433121                  /home/public/Dropbox/linux/utils/bc3/bin.real.4/lib7z.so
7fb5d6391000-7fb5d639a000 rwxp 00000000 00:00 0 
7fb5d639a000-7fb5d63ab000 r-xp 00000000 08:04 2759688                    /usr/lib/libbz2.so.1.0.8
7fb5d63ab000-7fb5d63ac000 r-xp 00010000 08:04 2759688                    /usr/lib/libbz2.so.1.0.8
7fb5d63ac000-7fb5d63ad000 rwxp 00011000 08:04 2759688                    /usr/lib/libbz2.so.1.0.8
7fb5d63ad000-7fb5d63b5000 r-xp 00000000 08:04 2756045                    /usr/lib/librt-2.31.so
7fb5d63b5000-7fb5d63b6000 ---p 00008000 08:04 2756045                    /usr/lib/librt-2.31.so
7fb5d63b6000-7fb5d63b7000 r-xp 00008000 08:04 2756045                    /usr/lib/librt-2.31.so
7fb5d63b7000-7fb5d63b8000 rwxp 00009000 08:04 2756045                    /usr/lib/librt-2.31.so
7fb5d63b8000-7fb5d63ba000 rwxp 00000000 00:00 0 
7fb5d63bb000-7fb5d63c0000 r-xs 00000000 08:04 658985                     /var/cache/fontconfig/b67b32625a2bb51b023d3814a918f351-le64.cache-7
7fb5d63c0000-7fb5d63c5000 r-xs 00000000 08:04 663729                     /var/cache/fontconfig/6ba42ae0000f58711b5caaf10d690066-le64.cache-7
7fb5d63c5000-7fb5d63d0000 r-xs 00000000 08:04 663728                     /var/cache/fontconfig/e83f37fcf327f1deda509da0f6605954-le64.cache-7
7fb5d63d0000-7fb5d63dd000 r-xs 00000000 08:04 663727                     /var/cache/fontconfig/210c0516121708a580e22e6b1f9a103a-le64.cache-7
7fb5d63dd000-7fb5d63e9000 r-xs 00000000 08:04 659442                     /var/cache/fontconfig/f6b893a7224233d96cb72fd88691c0b4-le64.cache-7
7fb5d63e9000-7fb5d63f1000 r-xs 00000000 103:02 2883649                   /home/zw963/.cache/fontconfig/855cad82f487f0cf5ba52cbbfb641e48-le64.cache-7
7fb5d63f1000-7fb5d63f5000 r-xp 00000000 08:04 2755911                    /usr/lib/gconv/UTF-16.so
7fb5d63f5000-7fb5d63f6000 r-xp 00003000 08:04 2755911                    /usr/lib/gconv/UTF-16.so
7fb5d63f6000-7fb5d63f7000 rwxp 00004000 08:04 2755911                    /usr/lib/gconv/UTF-16.so
7fb5d63f7000-7fb5d63f9000 rwxp 00000000 00:00 0 
7fb5d63f9000-7fb5d6423000 r-xp 00000000 08:04 2755941                    /usr/lib/ld-2.31.so
7fb5d6423000-7fb5d6424000 ---p 00000000 00:00 0 
7fb5d6424000-7fb5d6425000 r-xp 0002a000 08:04 2755941                    /usr/lib/ld-2.31.so
7fb5d6425000-7fb5d6426000 rwxp 0002b000 08:04 2755941                    /usr/lib/ld-2.31.so
7fb5d6426000-7fb5d6427000 rwxp 00000000 00:00 0 
7fff1421c000-7fff14245000 rwxp 00000000 00:00 0                          [stack]
7fff142eb000-7fff142ee000 r--p 00000000 00:00 0                          [vvar]
7fff142ee000-7fff142ef000 r-xp 00000000 00:00 0                          [vdso]
ffffffffff600000-ffffffffff601000 --xp 00000000 00:00 0                  [vsyscall]

Last edited by zw963 (2020-02-26 04:46:06)

Offline

#2 2020-02-19 18:19:21

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,510
Website

Re: pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

May be unrelated, but why did you remove optdepends?

Mod note: Moving to AUR Issues.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#3 2020-02-19 18:24:37

zw963
Member
Registered: 2018-06-18
Posts: 108

Re: pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

WorMzy wrote:

May be unrelated, but why did you remove optdepends?

Mod note: Moving to AUR Issues.

Infact, i am not understand well about  "pacman -Qdttq | sudo pacman -Rns -",
i just want to cleanup, and free unuseful disk space.

Maybe there is a history for those deleted package?

Offline

#4 2020-02-19 18:51:17

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 9,510
Website

Re: pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

Sure -- /var/log/pacman.log please post the entire thing.

However, you shouldn't just run things if you don't know what they do. This is especially true whenever root/sudo is involved. Read the pacman man page and see what those options do.

Please also edit your post to use code tags: https://wiki.archlinux.org/index.php/Co … s_and_code

Last edited by WorMzy (2020-02-19 18:51:55)


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: nVidia GeForce GTX 970 // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 5x 1TB HDD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#5 2020-02-20 02:30:02

zw963
Member
Registered: 2018-06-18
Posts: 108

Re: pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

Because the entire file is too long, , so i just post 2020-02-19 logs. please check.

BTW: the reason i run this update, is elasticsearch/kibana was ignored in pacman.conf before.
But,  after several days update,  elasticsearch/kibana 7.4.2 crashed frequently after use several minute.

so, i have to remove ignore, and try update to use both newest version. (7.5.2)
but this cause my beyond compare crash unexpectedly. : )

[2020-02-19T11:08:21+0800] [PACMAN] Running 'pacman -Syu'
[2020-02-19T11:08:21+0800] [PACMAN] synchronizing package lists
[2020-02-19T11:08:28+0800] [PACMAN] starting full system upgrade
[2020-02-19T11:11:39+0800] [PACMAN] Running 'pacman -Syu'
[2020-02-19T11:11:39+0800] [PACMAN] synchronizing package lists
[2020-02-19T11:11:42+0800] [PACMAN] starting full system upgrade
[2020-02-19T19:29:12+0800] [PACMAN] Running 'pacman -R elasticsearch'
[2020-02-19T19:29:13+0800] [ALPM] transaction started
[2020-02-19T19:29:14+0800] [ALPM] removed elasticsearch (7.4.2-1)
[2020-02-19T19:29:14+0800] [ALPM] transaction completed
[2020-02-19T19:29:14+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:29:14+0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-19T19:29:17+0800] [PACMAN] Running 'pacman -R kibana'
[2020-02-19T19:29:18+0800] [ALPM] transaction started
[2020-02-19T19:29:20+0800] [ALPM] removed kibana (7.4.2-1)
[2020-02-19T19:29:20+0800] [ALPM] transaction completed
[2020-02-19T19:29:20+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:29:20+0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-19T19:29:51+0800] [PACMAN] Running 'pacman -Syu'
[2020-02-19T19:29:51+0800] [PACMAN] synchronizing package lists
[2020-02-19T19:30:22+0800] [PACMAN] Running 'pacman -Syu'
[2020-02-19T19:30:22+0800] [PACMAN] synchronizing package lists
[2020-02-19T19:30:24+0800] [PACMAN] starting full system upgrade
[2020-02-19T19:33:23+0800] [ALPM] running '60-mkinitcpio-remove.hook'...
[2020-02-19T19:33:23+0800] [ALPM] running '70-dkms-remove.hook'...
[2020-02-19T19:33:23+0800] [ALPM] transaction started
[2020-02-19T19:33:23+0800] [ALPM] upgraded linux-api-headers (5.3.1-2 -> 5.4.17-1)
[2020-02-19T19:33:23+0800] [ALPM] warning: /etc/locale.gen installed as /etc/locale.gen.pacnew
[2020-02-19T19:33:23+0800] [ALPM] upgraded glibc (2.30-3 -> 2.31-1)
[2020-02-19T19:33:23+0800] [ALPM-SCRIPTLET] Generating locales...
[2020-02-19T19:33:24+0800] [ALPM-SCRIPTLET]   en_US.UTF-8... done
[2020-02-19T19:33:26+0800] [ALPM-SCRIPTLET]   zh_CN.UTF-8... done
[2020-02-19T19:33:27+0800] [ALPM-SCRIPTLET]   zh_TW.UTF-8... done
[2020-02-19T19:33:27+0800] [ALPM-SCRIPTLET] Generation complete.
[2020-02-19T19:33:28+0800] [ALPM] upgraded gcc-libs (9.2.0-4 -> 9.2.1+20200130-2)
[2020-02-19T19:33:28+0800] [ALPM] upgraded ncurses (6.1-7 -> 6.2-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded readline (8.0.001-2 -> 8.0.004-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded bash (5.0.011-2 -> 5.0.016-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded glib2 (2.62.4-1 -> 2.62.4-2)
[2020-02-19T19:33:28+0800] [ALPM] upgraded pango (1:1.44.7-1 -> 1:1.44.7+11+g73b46b04-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded wayland (1.17.0-1 -> 1.18.0-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded mesa (19.3.3-1 -> 19.3.4-2)
[2020-02-19T19:33:28+0800] [ALPM] upgraded gtk-update-icon-cache (1:3.24.13-1 -> 1:3.24.14-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded libcap (2.30-1 -> 2.31-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded libgpg-error (1.36-3 -> 1.37-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded systemd-libs (244.2-1 -> 244.3-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded libldap (2.4.48-2 -> 2.4.49-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded hwids (20191025-2 -> 20200204-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded gmp (6.1.2-3 -> 6.2.0-1)
[2020-02-19T19:33:28+0800] [ALPM] upgraded systemd (244.2-1 -> 244.3-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded js60 (60.9.0-1 -> 60.9.0-2)
[2020-02-19T19:33:29+0800] [ALPM] upgraded polkit (0.116-3 -> 0.116-4)
[2020-02-19T19:33:29+0800] [ALPM] upgraded libtool (2.4.6+42+gb88cebd5-8 -> 2.4.6+42+gb88cebd5-10)
[2020-02-19T19:33:29+0800] [ALPM] upgraded gtk3 (1:3.24.13-1 -> 1:3.24.14-1)
[2020-02-19T19:33:29+0800] [ALPM] installed python-xlib (0.26-2)
[2020-02-19T19:33:29+0800] [ALPM] upgraded python-packaging (20.0-1 -> 20.1-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded python-setuptools (1:44.0.0-1 -> 1:45.2.0-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded accerciser (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded alsa-plugins (1.2.1-1 -> 1.2.1-5)
[2020-02-19T19:33:29+0800] [ALPM] upgraded libinput (1.15.0-1 -> 1.15.1-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded md4c (0.4.2-1 -> 0.4.3-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded qt5-base (5.14.1-1 -> 5.14.1-2)
[2020-02-19T19:33:29+0800] [ALPM] upgraded attica (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded autoconf (2.69-6 -> 2.69-7)
[2020-02-19T19:33:29+0800] [ALPM] upgraded python-jmespath (0.9.4-3 -> 0.9.4-4)
[2020-02-19T19:33:29+0800] [ALPM] upgraded python-botocore (1.14.11-1 -> 1.15.0-1)
[2020-02-19T19:33:29+0800] [ALPM] upgraded python-s3transfer (0.3.2-1 -> 0.3.3-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded aws-cli (1.17.11-1 -> 1.18.0-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded binutils (2.33.1-2 -> 2.34-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded ttf-liberation (2.00.5-2 -> 2.1.0-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded chromium (80.0.3987.87-2 -> 80.0.3987.116-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded dconf-editor (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:30+0800] [ALPM] upgraded wpebackend-fdo (1.4.0-2 -> 1.4.1-1)
[2020-02-19T19:33:31+0800] [ALPM] upgraded webkit2gtk (2.26.3-1 -> 2.26.4-1)
[2020-02-19T19:33:31+0800] [ALPM] upgraded epiphany (3.34.3.1-1 -> 3.34.4-1)
[2020-02-19T19:33:31+0800] [ALPM] upgraded gnome-desktop (1:3.34.2-1 -> 1:3.34.4-1)
[2020-02-19T19:33:31+0800] [ALPM] upgraded evolution-data-server (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:31+0800] [ALPM] upgraded libarchive (3.4.1-1 -> 3.4.2-1)
[2020-02-19T19:33:32+0800] [ALPM] upgraded evolution (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:32+0800] [ALPM] upgraded faudio (20.01-1 -> 20.02-1)
[2020-02-19T19:33:32+0800] [ALPM] upgraded file-roller (3.32.3-1 -> 3.32.4-1)
[2020-02-19T19:33:33+0800] [ALPM] upgraded firefox (72.0.2-1 -> 73.0.1-1)
[2020-02-19T19:33:33+0800] [ALPM] upgraded flashplugin (32.0.0.314-1 -> 32.0.0.330-1)
[2020-02-19T19:33:33+0800] [ALPM] upgraded libmm-glib (1.12.4-1 -> 1.12.6-1)
[2020-02-19T19:33:33+0800] [ALPM] upgraded flatpak (1.6.1-1 -> 1.6.2-1)
[2020-02-19T19:33:33+0800] [ALPM] upgraded four-in-a-row (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gcc (9.2.0-4 -> 9.2.1+20200130-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gcc-fortran (9.2.0-4 -> 9.2.1+20200130-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gjs (2:1.58.4-1 -> 2:1.58.5-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded libgdm (3.34.1-1 -> 3.34.1-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded libnm (1.22.6-1 -> 1.22.8-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded mutter (3.34.3+30+g4959ae8bc-1 -> 3.34.4-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gnome-shell (1:3.34.3-1 -> 1:3.34.4-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gdm (3.34.1-1 -> 3.34.1-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded git (2.25.0-1 -> 2.25.1-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded glib2-docs (2.62.4-1 -> 2.62.4-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gmime3 (3.2.5-1 -> 3.2.6-1)
[2020-02-19T19:33:34+0800] [ALPM] installed libslirp (4.1.0-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded qemu (4.2.0-1 -> 4.2.0-2)
[2020-02-19T19:33:34+0800] [ALPM] upgraded tracker (2.3.1+6+g4d3073954-1 -> 2.3.2-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded gnome-boxes (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded grilo (0.3.11-1 -> 0.3.12-1)
[2020-02-19T19:33:34+0800] [ALPM] upgraded openssh (8.1p1-2 -> 8.2p1-3)
[2020-02-19T19:33:35+0800] [ALPM] upgraded imagemagick (7.0.9.22-1 -> 7.0.9.24-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gptfdisk (1.0.4-1 -> 1.0.5-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded libbytesize (2.1-3 -> 2.2-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-control-center (3.34.2-1 -> 3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-disk-utility (3.34.0-2 -> 3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded libgee (0.20.2-1 -> 0.20.3-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-klotski (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gom (0.3.3-4 -> 0.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded grilo-plugins (0.3.10-1 -> 0.3.11+4+g11cc1f8-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded tracker-miners (2.3.1+23+g139553959-1 -> 2.3.2-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded python-idna (2.8-3 -> 2.9-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded python-requests (2.22.0-3 -> 2.22.0-4)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-music (1:3.34.3-1 -> 1:3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded metis (5.1.0.p7-1 -> 5.1.0.p8-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-photos (3.34.0-1 -> 3.34.1-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-taquin (3.34.3-1 -> 3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded gnome-tetravex (3.34.1-1 -> 3.34.4-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded http-parser (2.9.2-1 -> 2.9.3-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded iagno (3.34.4-1 -> 3.34.5-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded solid (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kcoreaddons (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kwidgetsaddons (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kjobwidgets (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kdbusaddons (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kconfig (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kwindowsystem (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kcrash (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kglobalaccel (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kauth (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kcodecs (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kguiaddons (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded ki18n (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kconfigwidgets (5.66.0-1 -> 5.67.0-2)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kitemviews (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded karchive (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kiconthemes (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kxmlgui (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:35+0800] [ALPM] upgraded kbookmarks (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded knotifications (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kservice (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kwallet (5.66.0-2 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kcompletion (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded sonnet (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded ktextwidgets (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kio (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kpackage (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kdeclarative (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kcmutils (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded signon-ui (0.17+20171022-1 -> 0.17+20171022-2)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kaccounts-integration (19.12.2-1 -> 19.12.2-2)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kactivities (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kinit (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kirigami2 (5.66.0-1 -> 5.67.1-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kjs (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded knewstuff (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded knotifyconfig (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kparts (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded kpty (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded lib32-glibc (2.30-3 -> 2.31-1)
[2020-02-19T19:33:36+0800] [ALPM] upgraded lib32-alsa-plugins (1.2.1-1 -> 1.2.1-2)
[2020-02-19T19:33:36+0800] [ALPM] upgraded lib32-gcc-libs (9.2.0-4 -> 9.2.1+20200130-2)
[2020-02-19T19:33:36+0800] [ALPM] upgraded lib32-wayland (1.17.0-1 -> 1.18.0-1)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-mesa (19.3.3-1 -> 19.3.4-3)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-faudio (20.01-1 -> 20.02-1)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-glib2 (2.62.4-1 -> 2.62.4-2)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-pango (1:1.44.7-1 -> 1:1.44.7+11+g73b46b04-1)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-vulkan-intel (19.3.3-1 -> 19.3.4-3)
[2020-02-19T19:33:37+0800] [ALPM] upgraded lib32-zstd (1.4.4-1 -> 1.4.4-2)
[2020-02-19T19:33:37+0800] [ALPM] upgraded libmagick6 (6.9.10.91-1 -> 6.9.10.93-1)
[2020-02-19T19:33:38+0800] [ALPM] upgraded linux (5.5.2.arch1-1 -> 5.5.4.arch1-1)
[2020-02-19T19:33:39+0800] [ALPM] upgraded linux-firmware (20200122.1eb2408-1 -> 20200204.b791e15-1)
[2020-02-19T19:33:39+0800] [ALPM] upgraded lutris (0.5.4-1 -> 0.5.4-2)
[2020-02-19T19:33:40+0800] [ALPM] upgraded man-pages (5.04-2 -> 5.05-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded mercurial (5.2.2-2 -> 5.3-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded nano (4.7-1 -> 4.8-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded networkmanager (1.22.6-1 -> 1.22.8-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded nodejs (13.7.0-1 -> 13.9.0-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded noto-fonts-emoji (20191016-1 -> 20191016-3)
[2020-02-19T19:33:40+0800] [ALPM] upgraded semver (7.1.2-1 -> 7.1.3-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded npm (6.13.6-1 -> 6.13.7-1)
[2020-02-19T19:33:40+0800] [ALPM] upgraded ntp (4.2.8.p13-2 -> 4.2.8.p13-3)
[2020-02-19T19:33:40+0800] [ALPM] upgraded postgresql-libs (12.1-2 -> 12.2-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded postgresql (12.1-2 -> 12.2-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded purpose (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded python-lxml (4.4.2-1 -> 4.5.0-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded python-sphinx (2.2.1-2 -> 2.4.2-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded python2-packaging (20.0-1 -> 20.1-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded python2-setuptools (1:44.0.0-1 -> 2:44.0.0-1)
[2020-02-19T19:33:41+0800] [ALPM] upgraded simple-scan (3.34.2-1 -> 3.34.4-1)
[2020-02-19T19:33:42+0800] [ALPM] upgraded skypeforlinux-preview-bin (8.57.76.56-1 -> 8.57.76.109-1)
[2020-02-19T19:33:42+0800] [ALPM] upgraded spirv-tools (2019.3-2 -> 2019.5-2)
[2020-02-19T19:33:42+0800] [ALPM] upgraded strace (5.4-1 -> 5.5-1)
[2020-02-19T19:33:42+0800] [ALPM] upgraded stunnel (5.56-1 -> 5.56-2)
[2020-02-19T19:33:42+0800] [ALPM] upgraded systemd-sysvcompat (244.2-1 -> 244.3-1)
[2020-02-19T19:33:43+0800] [ALPM] upgraded telegram-desktop (1.9.9-1 -> 1.9.13-1)
[2020-02-19T19:33:43+0800] [ALPM] upgraded threadweaver (5.66.0-1 -> 5.67.0-1)
[2020-02-19T19:33:43+0800] [ALPM] upgraded vala (0.46.5-1 -> 0.46.6-1)
[2020-02-19T19:33:43+0800] [ALPM] upgraded virtualbox-host-modules-arch (6.1.2-9 -> 6.1.2-13)
[2020-02-19T19:33:43+0800] [ALPM] upgraded vlc (3.0.8-8 -> 3.0.8-9)
[2020-02-19T19:33:43+0800] [ALPM] upgraded vulkan-headers (1:1.2.132-1 -> 1:1.2.133-1)
[2020-02-19T19:33:43+0800] [ALPM] upgraded vulkan-intel (19.3.3-1 -> 19.3.4-2)
[2020-02-19T19:33:43+0800] [ALPM] upgraded whois (5.5.5-1 -> 5.5.6-1)
[2020-02-19T19:33:45+0800] [ALPM] upgraded wine (5.0-1 -> 5.2-1)
[2020-02-19T19:33:45+0800] [ALPM] transaction completed
[2020-02-19T19:33:47+0800] [ALPM] running '20-systemd-sysusers.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-binfmt.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-catalog.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-hwdb.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-sysctl.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-udev-reload.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-19T19:33:47+0800] [ALPM] running '60-depmod.hook'...
[2020-02-19T19:33:54+0800] [ALPM] running '70-dkms-install.hook'...
[2020-02-19T19:33:54+0800] [ALPM] running '80-cronie.hook'...
[2020-02-19T19:33:54+0800] [ALPM] running '90-mkinitcpio-install.hook'...
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET] ==> Starting build: 5.5.4-arch1-1
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> Running build hook: [autodetect]
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-02-19T19:33:54+0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-02-19T19:33:55+0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-02-19T19:33:55+0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-02-19T19:33:55+0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-02-19T19:33:55+0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-02-19T19:33:55+0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET] ==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET]   -> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET] ==> Starting build: 5.5.4-arch1-1
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET]   -> Running build hook: [base]
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET]   -> Running build hook: [udev]
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET]   -> Running build hook: [modconf]
[2020-02-19T19:33:56+0800] [ALPM-SCRIPTLET]   -> Running build hook: [block]
[2020-02-19T19:33:57+0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: wd719x
[2020-02-19T19:33:57+0800] [ALPM-SCRIPTLET] ==> WARNING: Possibly missing firmware for module: aic94xx
[2020-02-19T19:33:58+0800] [ALPM-SCRIPTLET]   -> Running build hook: [filesystems]
[2020-02-19T19:33:59+0800] [ALPM-SCRIPTLET]   -> Running build hook: [keyboard]
[2020-02-19T19:34:00+0800] [ALPM-SCRIPTLET]   -> Running build hook: [fsck]
[2020-02-19T19:34:01+0800] [ALPM-SCRIPTLET] ==> Generating module dependencies
[2020-02-19T19:34:01+0800] [ALPM-SCRIPTLET] ==> Creating gzip-compressed initcpio image: /boot/initramfs-linux-fallback.img
[2020-02-19T19:34:05+0800] [ALPM-SCRIPTLET] ==> Image generation successful
[2020-02-19T19:34:05+0800] [ALPM] running 'dbus-reload.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'detect-old-perl-modules.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'fontconfig.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'fontconfig-32.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'glib-compile-schemas.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'gtk-query-immodules-3.0.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-02-19T19:34:05+0800] [ALPM] running 'texinfo-install.hook'...
[2020-02-19T19:34:06+0800] [ALPM] running 'update-desktop-database.hook'...
[2020-02-19T19:34:06+0800] [ALPM] running 'update-mime-database.hook'...
[2020-02-19T19:34:07+0800] [ALPM] running 'update-vlc-plugin-cache.hook'...
[2020-02-19T19:34:07+0800] [ALPM] running 'xorg-mkfontscale.hook'...
[2020-02-19T19:39:23+0800] [PACMAN] Running 'pacman -Rns -'
[2020-02-19T19:39:26+0800] [ALPM] running 'texinfo-remove.hook'...
[2020-02-19T19:39:26+0800] [ALPM] transaction started
[2020-02-19T19:39:26+0800] [ALPM] removed vulkan-headers (1:1.2.133-1)
[2020-02-19T19:39:26+0800] [ALPM] removed subversion (1.13.0-2)
[2020-02-19T19:39:26+0800] [ALPM] removed serf (1.3.9-3)
[2020-02-19T19:39:26+0800] [ALPM] removed samba (4.10.10-2)
[2020-02-19T19:39:26+0800] [ALPM] removed perl-parse-yapp (1.21-2)
[2020-02-19T19:39:26+0800] [ALPM] removed iniparser (4.1-1)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-sass-listen (4.0.0-7)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-rb-inotify (0.9.10-4)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-ffi (1.11.3-3)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-rdoc (6.2.0-2)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-maruku (0.7.3-5)
[2020-02-19T19:39:26+0800] [ALPM] removed ruby-dbus (0.15.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed ruby (2.7.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed rubygems (3.1.2-4)
[2020-02-19T19:39:27+0800] [ALPM] removed qt5-webkit (5.212.0alpha3-9)
[2020-02-19T19:39:27+0800] [ALPM] removed qt5-sensors (5.14.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed python2-attrs (19.3.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-sip-pyqt5 (4.19.19-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-simplejson (3.17.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed python-pylint (2.4.4-1)
[2020-02-19T19:39:27+0800] [ALPM] removed python-mccabe (0.6.1-4)
[2020-02-19T19:39:27+0800] [ALPM] removed python-isort (4.3.21.2-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-astroid (2.3.3-1)
[2020-02-19T19:39:27+0800] [ALPM] removed python-wrapt (1.11.2-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-typed-ast (1.4.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-lazy-object-proxy (1.4.3-1)
[2020-02-19T19:39:27+0800] [ALPM] removed python-pyflakes (2.1.1-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-pycodestyle (2.5.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed python-attrs (19.3.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed package-query (1.10-1)
[2020-02-19T19:39:27+0800] [ALPM] removed opencl-headers (2:2.2.20170516-2)
[2020-02-19T19:39:27+0800] [ALPM] removed ocl-icd (2.2.12-3)
[2020-02-19T19:39:27+0800] [ALPM] removed mozilla-common (1.4-5)
[2020-02-19T19:39:27+0800] [ALPM] removed libvpx1.3 (1.3.0-2)
[2020-02-19T19:39:27+0800] [ALPM] removed libtiff4 (3.9.7-4)
[2020-02-19T19:39:27+0800] [ALPM] removed librtmp0 (2.4-4)
[2020-02-19T19:39:27+0800] [ALPM] removed libpng12 (1.2.59-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libplacebo (1.29.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed shaderc (2019.0-4)
[2020-02-19T19:39:27+0800] [ALPM] removed glslang (8.13.3559-1)
[2020-02-19T19:39:27+0800] [ALPM] removed spirv-tools (2019.5-2)
[2020-02-19T19:39:27+0800] [ALPM] removed libmp4v2 (2.0.0-5)
[2020-02-19T19:39:27+0800] [ALPM] removed libjpeg6-turbo (1.5.3-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libidn11 (1.33-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libgovirt (0.3.6-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libgcrypt15 (1.5.6-2)
[2020-02-19T19:39:27+0800] [ALPM] removed libatomic_ops (7.6.10-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libappindicator-gtk2 (12.10.0-13)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-v4l-utils (1.18.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl_ttf (2.0.11-5)
[2020-02-19T19:39:27+0800] [ALPM] removed sdl_ttf (2.0.11-5)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl_mixer (1.2.12-3)
[2020-02-19T19:39:27+0800] [ALPM] removed sdl_mixer (1.2.12-7)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-smpeg (0.4.5-3)
[2020-02-19T19:39:27+0800] [ALPM] removed smpeg (0.4.5-4)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libmikmod (3.3.11.1-4)
[2020-02-19T19:39:27+0800] [ALPM] removed libmikmod (3.3.11.1-4)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl_image (1.2.12-6)
[2020-02-19T19:39:27+0800] [ALPM] removed sdl_image (1.2.12-5)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl2_ttf (2.0.15-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl2_mixer (2.0.4-1)
[2020-02-19T19:39:27+0800] [ALPM] removed sdl2_mixer (2.0.4-3)
[2020-02-19T19:39:27+0800] [ALPM] removed opusfile (0.11-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libmodplug (0.8.9.0-3)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-sdl2_image (2.0.5-1)
[2020-02-19T19:39:27+0800] [ALPM] removed sdl2_image (2.0.5-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-openssl-1.0 (1.0.2.u-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-ocl-icd (2.2.12-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libxslt (1.1.34-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libwrap (7.6.24-3)
[2020-02-19T19:39:27+0800] [ALPM] removed libwrap (7.6.28-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libnsl (1.2.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libtirpc (1.1.4-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libvpx1.3 (1.3.0-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libvdpau (1.3-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libva1 (1.8.3-3)
[2020-02-19T19:39:27+0800] [ALPM] removed libva1 (1.8.3-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libudev0-shim (1-4)
[2020-02-19T19:39:27+0800] [ALPM] removed libudev0-shim (1-3)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libtiff4 (3.9.7-4)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libtheora (1.1.1-12)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-librtmp0 (2.4-3)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libpng12 (1.2.59-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libnm-glib (1.18.5dev+12+ga8746f48ca-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libnm-glib (1.18.5dev+12+ga8746f48ca-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libgudev (233-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-dbus-glib (0.110-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libidn11 (1.33-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libgcrypt15 (1.5.6-5)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libcurl-gnutls (7.68.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libcurl-gnutls (7.68.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libcurl-compat (7.68.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libcurl-compat (7.68.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-curl (7.68.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libssh2 (1.9.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libpsl (0.21.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libidn2 (2.3.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libunistring (0.9.10-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libcanberra (0.30+2+gc0620e4-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-tdb (1.3.18-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libcaca (0.99.beta19-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-imlib2 (1.6.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libid3tag (0.15.1b-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-giflib (5.2.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libwebp (1.1.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-gst-plugins-base-libs (1.16.2-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-orc (0.4.31-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libxv (1.0.11-2)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-gstreamer (1.16.2-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libunwind (1.3.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-glew1.10 (1.10.0-4)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libxmu (1.1.3-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-libxt (1.2.0-1)
[2020-02-19T19:39:27+0800] [ALPM] removed lib32-freeglut (3.2.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed leveldb (1.22-1)
[2020-02-19T19:39:27+0800] [ALPM] removed gperftools (2.7-1)
[2020-02-19T19:39:27+0800] [ALPM] removed kaldi-openfst (1.6.7-2)
[2020-02-19T19:39:27+0800] [ALPM] removed jre-openjdk (13.0.2.u8-1)
[2020-02-19T19:39:27+0800] [ALPM] removed jre-openjdk-headless (13.0.2.u8-1)
[2020-02-19T19:39:27+0800] [ALPM] removed intel-media-sdk (19.4.0-4)
[2020-02-19T19:39:27+0800] [ALPM] removed intel-media-driver (19.4.0.r-1)
[2020-02-19T19:39:27+0800] [ALPM] removed intel-gmmlib (19.4.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed gtkspell3 (3.0.10-2)
[2020-02-19T19:39:27+0800] [ALPM] removed gtksourceview3 (3.24.11-1)
[2020-02-19T19:39:27+0800] [ALPM] removed glew1.10 (1.10.0-2)
[2020-02-19T19:39:27+0800] [ALPM] removed geoip (1.6.12-1)
[2020-02-19T19:39:27+0800] [ALPM] removed geoip-database (20180403-1)
[2020-02-19T19:39:27+0800] [ALPM] removed gcc-fortran (9.2.1+20200130-2)
[2020-02-19T19:39:27+0800] [ALPM] removed fontforge (20190801-2)
[2020-02-19T19:39:27+0800] [ALPM] removed potrace (1.16-1)
[2020-02-19T19:39:27+0800] [ALPM] removed libuninameslist (20190701-1)
[2020-02-19T19:39:27+0800] [ALPM] removed doxygen (1.8.17-1)
[2020-02-19T19:39:27+0800] [ALPM] removed dkms (2.8.1-1)
[2020-02-19T19:39:27+0800] [ALPM] removed cub (1.8.0-2)
[2020-02-19T19:39:27+0800] [ALPM] removed cblas (3.9.0-2)
[2020-02-19T19:39:27+0800] [ALPM] transaction completed
[2020-02-19T19:39:27+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:39:27+0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-19T19:39:27+0800] [ALPM] running 'gtk-update-icon-cache.hook'...
[2020-02-19T19:39:27+0800] [ALPM] running 'update-desktop-database.hook'...
[2020-02-19T19:39:27+0800] [ALPM] running 'update-mime-database.hook'...
[2020-02-19T19:39:51+0800] [PACMAN] Running 'pacman -S -y -u --config /etc/pacman.conf --'
[2020-02-19T19:39:51+0800] [PACMAN] synchronizing package lists
[2020-02-19T19:39:52+0800] [PACMAN] starting full system upgrade
[2020-02-19T19:42:23+0800] [PACMAN] Running 'pacman -S elasticsearch'
[2020-02-19T19:42:59+0800] [ALPM] transaction started
[2020-02-19T19:42:59+0800] [ALPM] installed elasticsearch (7.5.2-1)
[2020-02-19T19:42:59+0800] [ALPM] transaction completed
[2020-02-19T19:42:59+0800] [ALPM] running '20-systemd-sysusers.hook'...
[2020-02-19T19:43:00+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:43:00+0800] [ALPM] running '30-systemd-sysctl.hook'...
[2020-02-19T19:43:00+0800] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-02-19T19:43:00+0800] [ALPM] running '30-systemd-update.hook'...
[2020-02-19T19:43:07+0800] [PACMAN] Running 'pacman -S kibana'
[2020-02-19T19:43:09+0800] [ALPM] transaction started
[2020-02-19T19:43:11+0800] [ALPM] installed kibana (7.5.2-1)
[2020-02-19T19:43:11+0800] [ALPM] transaction completed
[2020-02-19T19:43:12+0800] [ALPM] running '20-systemd-sysusers.hook'...
[2020-02-19T19:43:12+0800] [ALPM] running '30-systemd-daemon-reload.hook'...
[2020-02-19T19:43:12+0800] [ALPM] running '30-systemd-tmpfiles.hook'...
[2020-02-19T19:43:12+0800] [ALPM] running '30-systemd-update.hook'...

-----------------------

EDIT:

Because beyond compare is import for my work, so, i have to downgrade my arch to 2020/02/01.
After that,  bc4 start to working again.


Following is the new package since 2020/02/01, 

accerciser-3.34.4-1  alsa-plugins-1.2.1-5  attica-5.67.0-1  autoconf-2.69-7  aws-cli-1.18.3-1  bash-5.0.016-1  bind-tools-9.16.0-1  binutils-2.34-1  bison-3.5.2-1  bluez-5.53-1  bluez-libs-5.53-1  ca-certificates-mozilla-3.50-1
               ceph-libs-14.2.7-1  chromium-80.0.3987.116-1  cmake-3.16.4-1  copyq-3.10.0-1  cryptsetup-2.3.0-1  dconf-editor-3.34.4-1  epiphany-3.34.4-1  evolution-3.34.4-1  evolution-data-server-3.34.4-1  faudio-20.02-1  file-roller-3.32.4-1
               firefox-73.0.1-1  flashplugin-32.0.0.330-1  flatpak-1.6.2-1  fluidsynth-2.1.1-1  four-in-a-row-3.34.4-1  gcc-9.2.1+20200130-2  gcc-fortran-9.2.1+20200130-2  gcc-libs-9.2.1+20200130-2  gdk-pixbuf2-2.40.0-2  gdm-3.34.1-2  git-2.25.1-1
               gjs-2:1.58.5-1  glib2-2.62.4-2  glib2-docs-2.62.4-2  glibc-2.31-1  gmime3-3.2.6-1  gmp-6.2.0-1  gnome-boxes-3.34.4-1  gnome-control-center-3.34.4-1  gnome-desktop-1:3.34.4-1  gnome-disk-utility-3.34.4-1  gnome-klotski-3.34.4-1
               gnome-music-1:3.34.4-1  gnome-photos-3.34.1-1  gnome-shell-1:3.34.4-1  gnome-taquin-3.34.4-1  gnome-tetravex-3.34.4-1  gnutls-3.6.12-1  gom-0.4-1  gptfdisk-1.0.5-1  grilo-0.3.12-1  grilo-plugins-0.3.11+4+g11cc1f8-1
               gtk-update-icon-cache-1:3.24.14+9+g429a6287e0-1  gtk3-1:3.24.14+9+g429a6287e0-1  http-parser-2.9.3-1  hwids-20200204-1  iagno-3.34.5-1  iana-etc-20200117-1  imagemagick-7.0.9.24-1  ipython-7.12.0-1  js60-60.9.0-2
               kaccounts-integration-19.12.2-2  kactivities-5.67.0-1  karchive-5.67.0-1  kauth-5.67.0-1  kbookmarks-5.67.0-1  kcmutils-5.67.0-1  kcodecs-5.67.0-1  kcompletion-5.67.0-1  kconfig-5.67.0-1  kconfigwidgets-5.67.0-2  kcoreaddons-5.67.0-1
               kcrash-5.67.0-1  kdbusaddons-5.67.0-1  kdeclarative-5.67.0-1  kglobalaccel-5.67.0-1  kguiaddons-5.67.0-1  ki18n-5.67.0-1  kiconthemes-5.67.0-1  kinit-5.67.0-1  kio-5.67.0-1  kirigami2-5.67.1-1  kitemviews-5.67.0-1  kjobwidgets-5.67.0-1
               kjs-5.67.0-1  knewstuff-5.67.0-1  knotifications-5.67.0-1  knotifyconfig-5.67.0-1  konsole-19.12.2-1  kpackage-5.67.0-1  kparts-5.67.0-1  kpty-5.67.0-1  kservice-5.67.0-1  ktextwidgets-5.67.0-1  kwallet-5.67.0-1  kwidgetsaddons-5.67.0-1
               kwindowsystem-5.67.0-1  kxmlgui-5.67.0-1  lib32-gcc-libs-9.2.1+20200130-2  lib32-glibc-2.31-1  libarchive-3.4.2-1  libbytesize-2.2-1  libcap-2.31-1  libgdm-3.34.1-2  libgee-0.20.3-1  libgpg-error-1.37-1  libinput-1.15.1-1
               libinstpatch-1.1.2-1  libkate-0.4.1-7  libkexiv2-19.12.2-1  libldap-2.4.49-1  libmagick6-6.9.10.93-1  libmm-glib-1.12.6-1  libmtp-1.1.17-1  libnm-1.22.8-1  libsecret-0.20.1-1  libslirp-4.1.0-1  libtasn1-4.16.0-1
               libtool-2.4.6+42+gb88cebd5-10  libusbmuxd-2.0.1-1  libutil-linux-2.35.1-1  linux-5.5.4.arch1-1  linux-api-headers-5.4.17-1  linux-firmware-20200204.b791e15-1  lutris-0.5.4-2  make-4.3-1  mame-0.218-1  man-pages-5.05-1  md4c-0.4.3-1
               mercurial-5.3-1  mesa-19.3.4-2  metis-5.1.0.p8-1  mutter-3.34.4-1  nano-4.8-1  ncurses-6.2-1  networkmanager-1.22.8-1  nodejs-13.9.0-1  noto-fonts-emoji-20191016-3  npm-6.13.7-1  nspr-4.25-1  nss-3.50-1  ntp-4.2.8.p13-3  numactl-2.0.13-2
               okular-19.12.2-1  openal-1.20.1-2  openssh-8.2p1-3  opusfile-0.11-2  pacman-mirrorlist-20200207-1  pango-1:1.44.7+11+g73b46b04-1  polkit-0.116-4  postgresql-12.2-1  postgresql-libs-12.2-1  protobuf-3.11.4-1  purpose-5.67.0-1
               python-botocore-1.15.3-1  python-dbus-1.2.16-1  python-dbus-common-1.2.16-1  python-idna-2.9-1  python-jmespath-0.9.4-4  python-lxml-4.5.0-1  python-packaging-20.1-1  python-parso-0.6.1-1  python-pexpect-4.8.0-1  python-requests-2.22.0-4
               python-s3transfer-0.3.3-1  python-setuptools-1:45.2.0-1  python-sphinx-2.4.2-1  python-xlib-0.26-2  python2-dbus-1.2.16-1  python2-packaging-20.1-1  python2-setuptools-2:44.0.0-1  qemu-4.2.0-2  qt5-base-5.14.1-2  readline-8.0.004-1
               s-nail-14.9.17-1  sane-1.0.29-1  semver-7.1.3-1  shadow-4.8.1-1  signon-kwallet-extension-19.12.2-1  signon-ui-0.17+20171022-2  simple-scan-3.34.4-1  solid-5.67.0-1  sonnet-5.67.0-1  spirv-tools-2019.5-2  strace-5.5-1  stunnel-5.56-2
               sudo-1.8.31-1  systemd-244.3-1  systemd-libs-244.3-1  systemd-sysvcompat-244.3-1  telegram-desktop-1.9.14-1  threadweaver-5.67.0-1  tracker-2.3.2-1  tracker-miners-2.3.2-1  ttf-liberation-2.1.0-1  util-linux-2.35.1-1  vala-0.46.6-1
               virglrenderer-0.8.2-1  virtualbox-6.1.4-2  virtualbox-guest-iso-6.1.4-1  virtualbox-host-modules-arch-6.1.4-1  vlc-3.0.8-9  vulkan-headers-1:1.2.133-1  vulkan-intel-19.3.4-2  wayland-1.18.0-1  webkit2gtk-2.26.4-1  whois-5.5.6-1
               wpebackend-fdo-1.4.1-1  xkeyboard-config-2.29-1  yarn-1.22.0-1

i try to update to newest version again. (this time, i never remove any  package)
And, as expected,  bc4 crash again. : )

I guess some dependency for bc4 is version too old,  arch is too new, and cause crash, i will report there.

And, i send a formatted version of old/new package compare here.

https://www.scootersoftware.com/vbullet … nux-update

Last edited by zw963 (2020-02-20 19:06:38)

Offline

#6 2020-02-21 05:09:28

zw963
Member
Registered: 2018-06-18
Posts: 108

Re: pacman -Syu cause Beyond compare 4.3.3 crash [EDITED 2020/02/26]

@WorMzy, just for let you know, i updated my reply, thank you.


UPDATED: 2020-02-23

After several hours research, i found the package which cause bc4 broken.

upgraded noto-fonts-emoji (20191016-1 -> 20191016-3)

noto-fonts-emoji

I don't remember when and why i install this, but, obviously, an emoji fonts library cause this issue.

Following is this package info:

Name            : noto-fonts-emoji
Version         : 20191016-3
Description     : Google Noto emoji fonts
Architecture    : any
URL             : https://www.google.com/get/noto/
Licenses        : custom:OFL
Groups          : None
Provides        : emoji-font
Depends On      : None
Optional Deps   : None
Required By     : None
Optional For    : noto-fonts
Conflicts With  : None
Replaces        : None
Installed Size  : 8.96 MiB
Packager        : Antonio Rojas <arojas@archlinux.org>
Build Date      : Thu 13 Feb 2020 08:33:23 PM CST
Install Date    : Sun 23 Feb 2020 01:52:42 AM CST
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : Signature
noto-fonts-emoji /etc/
noto-fonts-emoji /etc/fonts/
noto-fonts-emoji /etc/fonts/conf.avail/
noto-fonts-emoji /etc/fonts/conf.avail/66-noto-color-emoji.conf
noto-fonts-emoji /etc/fonts/conf.d/
noto-fonts-emoji /etc/fonts/conf.d/66-noto-color-emoji.conf
noto-fonts-emoji /usr/
noto-fonts-emoji /usr/share/
noto-fonts-emoji /usr/share/fonts/
noto-fonts-emoji /usr/share/fonts/noto/
noto-fonts-emoji /usr/share/fonts/noto/NotoColorEmoji.ttf
noto-fonts-emoji /usr/share/licenses/
noto-fonts-emoji /usr/share/licenses/noto-fonts-emoji/
noto-fonts-emoji /usr/share/licenses/noto-fonts-emoji/LICENSE

I don't think this is a issue about arch, anyway, i ignore this package, so, it worked for now.


UPDATED: 2020-02-26

We keep talk about this issue on scootersoftware bbs, following is a question about noto-fonts-emoji on arch linux.

https://www.scootersoftware.com/vbullet … date/page2

Last edited by zw963 (2020-02-26 04:48:36)

Offline

Board footer

Powered by FluxBB