You are not logged in.

#1 2020-02-26 17:10:54

archdom
Member
Registered: 2018-09-12
Posts: 96

[SOLVED] Setting Locale Archlinux docker container

Hi guys,
In my dockerfile I'm trying to set up a new locale. The default is set and works well. I would like to add a new locale but it does not find the definition of locales.
This is the mistake:

cannot open locale definition file 'xx_XX': No such file or directory 

How could I solve it?

regards

Last edited by archdom (2020-02-26 20:09:51)

Offline

#2 2020-02-26 19:08:08

V1del
Forum Moderator
Registered: 2012-10-16
Posts: 21,136

Re: [SOLVED] Setting Locale Archlinux docker container

https://wiki.archlinux.org/index.php/Locale

If that is insufficient, clarify what you are actually doing which commands you are using and which actual uncensored error you are getting. And which image you are trying to build with which baseline.

If you just use the default docker image that is heavily stripped, you'll have to set up your own, see: https://wiki.archlinux.org/index.php/Docker#Arch_Linux clone the repo, change the locale and change the noextract rules so that they do not exclude non eng languages.

Last edited by V1del (2020-02-26 19:11:05)

Online

#3 2020-02-26 20:09:28

archdom
Member
Registered: 2018-09-12
Posts: 96

Re: [SOLVED] Setting Locale Archlinux docker container

V1del wrote:

https://wiki.archlinux.org/index.php/Locale

If that is insufficient, clarify what you are actually doing which commands you are using and which actual uncensored error you are getting. And which image you are trying to build with which baseline.

If you just use the default docker image that is heavily stripped, you'll have to set up your own, see: https://wiki.archlinux.org/index.php/Docker#Arch_Linux clone the repo, change the locale and change the noextract rules so that they do not exclude non eng languages.


Done. Thank you so much! Marked as solved

Offline

Board footer

Powered by FluxBB